aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/Makefile25
-rw-r--r--databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/distinfo2
-rw-r--r--databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/pkg-descr4
-rw-r--r--databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/pkg-plist11
5 files changed, 43 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index af736f16bb1b..df9f06f1f873 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -356,6 +356,7 @@
SUBDIR += p5-DBIx-Class-EncodedColumn
SUBDIR += p5-DBIx-Class-Fixtures
SUBDIR += p5-DBIx-Class-FrozenColumns
+ SUBDIR += p5-DBIx-Class-InflateColumn-Authen-Passphrase
SUBDIR += p5-DBIx-Class-InflateColumn-FS
SUBDIR += p5-DBIx-Class-InflateColumn-IP
SUBDIR += p5-DBIx-Class-IntrospectableM2M
diff --git a/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/Makefile b/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/Makefile
new file mode 100644
index 000000000000..d595dbb61eef
--- /dev/null
+++ b/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/Makefile
@@ -0,0 +1,25 @@
+# Created by Frank Wall <fw@moov.de>
+# $FreeBSD$
+
+PORTNAME= DBIx-Class-InflateColumn-Authen-Passphrase
+PORTVERSION= 0.01
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fw@moov.de
+COMMENT= Inflate/deflate columns to Authen::Passphrase instances
+
+RUN_DEPENDS= p5-DBIx-Class-DynamicDefault>=0.03:${PORTSDIR}/databases/p5-DBIx-Class-DynamicDefault \
+ p5-DBIx-Class>=0.08009:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-Authen-Passphrase>=0:${PORTSDIR}/security/p5-Authen-Passphrase
+BUILD_DEPENDS:= p5-DBIx-Class-DynamicDefault>=0.03:${PORTSDIR}/databases/p5-DBIx-Class-DynamicDefault \
+ p5-DBIx-Class>=0.08009:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-Authen-Passphrase>=0:${PORTSDIR}/security/p5-Authen-Passphrase
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Class::InflateColumn::Authen::Passphrase.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/distinfo b/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/distinfo
new file mode 100644
index 000000000000..100ac4f81e10
--- /dev/null
+++ b/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBIx-Class-InflateColumn-Authen-Passphrase-0.01.tar.gz) = 62609ff5baa51139d2f7a9f9bc6701a3e00f4cf4739a150f942bc84bfe6dc0de
+SIZE (DBIx-Class-InflateColumn-Authen-Passphrase-0.01.tar.gz) = 11532
diff --git a/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/pkg-descr b/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/pkg-descr
new file mode 100644
index 000000000000..ca62fea8dba2
--- /dev/null
+++ b/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/pkg-descr
@@ -0,0 +1,4 @@
+Provides inflation and deflation for Authen::Passphrase instances from
+and to either RFC 2307 or crypt encoding.
+
+WWW: http://search.cpan.org/dist/DBIx-Class-InflateColumn-Authen-Passphrase/
diff --git a/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/pkg-plist b/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/pkg-plist
new file mode 100644
index 000000000000..3059955afb82
--- /dev/null
+++ b/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/DBIx/Class/InflateColumn/Authen/Passphrase.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/InflateColumn/Authen/Passphrase/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/InflateColumn/Authen/Passphrase
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/InflateColumn/Authen
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/InflateColumn
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrmtry %%SITE_PERL%%/DBIx/Class/InflateColumn/Authen
+@dirrmtry %%SITE_PERL%%/DBIx/Class/InflateColumn