aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/trac-watchlist/Makefile6
-rw-r--r--www/trac-watchlist/files/patch-tracwatchlist_util.py13
2 files changed, 18 insertions, 1 deletions
diff --git a/www/trac-watchlist/Makefile b/www/trac-watchlist/Makefile
index fd3fd120c095..099138c8fe50 100644
--- a/www/trac-watchlist/Makefile
+++ b/www/trac-watchlist/Makefile
@@ -3,6 +3,7 @@
PORTNAME= watchlist
PORTVERSION= 1.0.${SVN_REV}
+PORTREVISION= 1
CATEGORIES= www devel python
MASTER_SITES= http://distfiles.cse.tw/ \
http://trac-hacks.org/changeset/${SVN_REV}/watchlistplugin?old_path=/&format=zip&filename=/
@@ -26,6 +27,9 @@ USE_PYDISTUTILS= easy_install
FETCH_BEFORE_ARGS= -o ${DISTFILES}
PYDISTUTILS_PKGNAME= TracWatchlistPlugin
PYDISTUTILS_PKGVERSION= ${PORTVERSION:C/.${SVN_REV}//g}
-#PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+post-extract:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${CHMOD} 644
+ @${FIND} ${WRKSRC} -type d | ${XARGS} ${CHMOD} 755
.include <bsd.port.mk>
diff --git a/www/trac-watchlist/files/patch-tracwatchlist_util.py b/www/trac-watchlist/files/patch-tracwatchlist_util.py
new file mode 100644
index 000000000000..9b3ce7b23e7a
--- /dev/null
+++ b/www/trac-watchlist/files/patch-tracwatchlist_util.py
@@ -0,0 +1,13 @@
+--- tracwatchlist/util.py.orig 2013-08-15 04:15:56.000000000 +0800
++++ tracwatchlist/util.py 2013-08-15 04:16:05.000000000 +0800
+@@ -198,8 +198,8 @@
+ try:
+ from babel.dates import get_datetime_format, get_date_format, get_time_format
+ def datetime_format(format='medium', locale=LC_TIME):
+- time_format = unicode(get_time_format(format, locale))
+- date_format = unicode(get_date_format(format, locale))
++ time_format = unicode(get_time_format(format, locale=locale))
++ date_format = unicode(get_date_format(format, locale=locale))
+ return convert_LDML_to_MySQL( get_datetime_format(format, locale)\
+ .replace('{0}', time_format)\
+ .replace('{1}', date_format) )