aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--benchmarks/sysbench/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/benchmarks/sysbench/Makefile b/benchmarks/sysbench/Makefile
index 1c7475e198ff..f0f74912c5ca 100644
--- a/benchmarks/sysbench/Makefile
+++ b/benchmarks/sysbench/Makefile
@@ -11,16 +11,23 @@ CATEGORIES= benchmarks databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= gslin@gslin.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A modular, cross-platform and multi-threaded benchmark tool
USE_AUTOTOOLS= libtool:15
-OPTIONS= MYSQL "Enable MySQL support" on \
+OPTIONS= LARGEFILE "Enable Largefile support" on \
+ MYSQL "Enable MySQL support" on \
POSTGRESQL "Enable PostgreSQL support" off
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_LARGEFILE)
+CONFIGURE_ARGS+= --disable-largefile
+.else
+CONFIGURE_ARGS+= --enable-largefile
+.endif
+
.if defined(WITHOUT_MYSQL)
CONFIGURE_ARGS+= --with-mysql=no
.else