aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.python.mk4
-rw-r--r--lang/python-doc-html/distinfo5
-rw-r--r--lang/python/Makefile10
-rw-r--r--lang/python/distinfo1
-rw-r--r--lang/python/files/patch-Modules-Setup.dist12
-rw-r--r--lang/python23/Makefile10
-rw-r--r--lang/python23/distinfo1
-rw-r--r--lang/python23/files/patch-Modules-Setup.dist12
-rw-r--r--lang/python24/Makefile10
-rw-r--r--lang/python24/distinfo1
-rw-r--r--lang/python24/files/patch-Modules-Setup.dist12
11 files changed, 34 insertions, 44 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 76f554833648..04a75038938a 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -111,7 +111,7 @@ _PYTHON_VERSION!= (${LOCALBASE}/bin/python -c 'import sys; print sys.version[:3]
|| echo 2.3
.endif
PYTHON_VERSION?= python${_PYTHON_VERSION}
-_PYTHON_PORTVERSION= 2.3
+_PYTHON_PORTVERSION= 2.3.1
PYTHON_CMD?= ${PYTHONBASE}/bin/${PYTHON_VERSION}
PYTHONBASE!= (${PYTHON_CMD} -c 'import sys; print sys.prefix') \
2> /dev/null || echo ${LOCALBASE}
@@ -131,7 +131,7 @@ PYTHON_WRKSRC= ${WRKDIR}/Python-2.4a0-20030801
.elif ${PYTHON_VERSION} == "python2.3"
PYTHON_DISTFILE= Python-${_PYTHON_PORTVERSION}.tgz
PYTHON_PORTSDIR= ${PORTSDIR}/lang/python
-PYTHON_REL= 230
+PYTHON_REL= 231
PYTHON_SUFFIX= 23
PYTHON_WRKSRC= ${WRKDIR}/Python-${_PYTHON_PORTVERSION}
diff --git a/lang/python-doc-html/distinfo b/lang/python-doc-html/distinfo
index b710bfa629dd..1664c388f00c 100644
--- a/lang/python-doc-html/distinfo
+++ b/lang/python-doc-html/distinfo
@@ -49,3 +49,8 @@ MD5 (python/pdf-a4-2.3.tar.bz2) = 0556201159879872acdc3eeb170de59e
MD5 (python/pdf-letter-2.3.tar.bz2) = 7894638799efe17916143b4b1f9f581a
MD5 (python/postscript-a4-2.3.tar.bz2) = 59255ce295650103aaf59b9dea7729dc
MD5 (python/postscript-letter-2.3.tar.bz2) = 73fab7f4ffbf4f18afd533ea951dbb98
+MD5 (python/html-2.3.1.tar.bz2) = 276d92220473d452ab3a89005cf0bf1d
+MD5 (python/pdf-a4-2.3.1.tar.bz2) = 675721c2588db2752137b12172ecb90d
+MD5 (python/pdf-letter-2.3.1.tar.bz2) = f3aac660e95d0af61df8f4789f21755f
+MD5 (python/postscript-a4-2.3.1.tar.bz2) = f0931b1e866838721dd062ba1ef7bdab
+MD5 (python/postscript-letter-2.3.1.tar.bz2) = 26aad65ac284bb5d2769399a50bda51c
diff --git a/lang/python/Makefile b/lang/python/Makefile
index e0ddbf78e425..386618c09faf 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 2.3
-PORTREVISION= 1
+PORTVERSION= 2.3.1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -71,6 +70,9 @@ PLIST_SUB+= X86_ONLY=""
.else
PLIST_SUB+= X86_ONLY="@comment "
.endif
+.if ${ARCH} == amd64
+CFLAGS+= -fPIC
+.endif
.if ${OSVERSION} < 400000
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
@@ -111,6 +113,10 @@ post-patch:
${REINPLACE_CMD} -e \
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
+.if ${ARCH} == amd64 || ${ARCH} == sparc64
+ ${REINPLACE_CMD} -e \
+ 's,^#\(dl .*\),\1,' ${WRKSRC}/Modules/Setup.dist
+.endif
pre-install:
.for platform in ${PLATFORMS}
diff --git a/lang/python/distinfo b/lang/python/distinfo
index 962f6b52b806..17d0a7cc7c66 100644
--- a/lang/python/distinfo
+++ b/lang/python/distinfo
@@ -11,4 +11,5 @@ MD5 (python/Python-2.2.1.tgz) = e7012d611602b62e36073c2fd02396a3
MD5 (python/Python-2.2.2.tgz) = 1c1067396e5aa0299978486eb5bd1a5c
MD5 (python/Python-2.2.3.tgz) = 169f89f318e252dac0c54dd1b165d229
MD5 (python/Python-2.3.tgz) = 595620a4769073a812e353597585c4e8
+MD5 (python/Python-2.3.1.tgz) = a3dcbe1c7f173c8e3c7cce28495016ae
MD5 (python/Python-2.4a0-20030801.tgz) = 7bb219e81cd565ed1c360108d9e8ba16
diff --git a/lang/python/files/patch-Modules-Setup.dist b/lang/python/files/patch-Modules-Setup.dist
deleted file mode 100644
index 74b1ef29f224..000000000000
--- a/lang/python/files/patch-Modules-Setup.dist
+++ /dev/null
@@ -1,12 +0,0 @@
---- Modules/Setup.dist Thu Aug 8 15:52:42 2002
-+++ Modules/Setup.dist.new Thu Nov 21 10:40:05 2002
-@@ -356,8 +356,7 @@
- # it is a highly experimental and dangerous device for calling
- # *arbitrary* C functions in *arbitrary* shared libraries:
-
--#dl dlmodule.c
--
-+dl dlmodule.c
-
- # Modules that provide persistent dictionary-like semantics. You will
- # probably want to arrange for at least one of them to be available on
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index e0ddbf78e425..386618c09faf 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 2.3
-PORTREVISION= 1
+PORTVERSION= 2.3.1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -71,6 +70,9 @@ PLIST_SUB+= X86_ONLY=""
.else
PLIST_SUB+= X86_ONLY="@comment "
.endif
+.if ${ARCH} == amd64
+CFLAGS+= -fPIC
+.endif
.if ${OSVERSION} < 400000
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
@@ -111,6 +113,10 @@ post-patch:
${REINPLACE_CMD} -e \
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
+.if ${ARCH} == amd64 || ${ARCH} == sparc64
+ ${REINPLACE_CMD} -e \
+ 's,^#\(dl .*\),\1,' ${WRKSRC}/Modules/Setup.dist
+.endif
pre-install:
.for platform in ${PLATFORMS}
diff --git a/lang/python23/distinfo b/lang/python23/distinfo
index 962f6b52b806..17d0a7cc7c66 100644
--- a/lang/python23/distinfo
+++ b/lang/python23/distinfo
@@ -11,4 +11,5 @@ MD5 (python/Python-2.2.1.tgz) = e7012d611602b62e36073c2fd02396a3
MD5 (python/Python-2.2.2.tgz) = 1c1067396e5aa0299978486eb5bd1a5c
MD5 (python/Python-2.2.3.tgz) = 169f89f318e252dac0c54dd1b165d229
MD5 (python/Python-2.3.tgz) = 595620a4769073a812e353597585c4e8
+MD5 (python/Python-2.3.1.tgz) = a3dcbe1c7f173c8e3c7cce28495016ae
MD5 (python/Python-2.4a0-20030801.tgz) = 7bb219e81cd565ed1c360108d9e8ba16
diff --git a/lang/python23/files/patch-Modules-Setup.dist b/lang/python23/files/patch-Modules-Setup.dist
deleted file mode 100644
index 74b1ef29f224..000000000000
--- a/lang/python23/files/patch-Modules-Setup.dist
+++ /dev/null
@@ -1,12 +0,0 @@
---- Modules/Setup.dist Thu Aug 8 15:52:42 2002
-+++ Modules/Setup.dist.new Thu Nov 21 10:40:05 2002
-@@ -356,8 +356,7 @@
- # it is a highly experimental and dangerous device for calling
- # *arbitrary* C functions in *arbitrary* shared libraries:
-
--#dl dlmodule.c
--
-+dl dlmodule.c
-
- # Modules that provide persistent dictionary-like semantics. You will
- # probably want to arrange for at least one of them to be available on
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index e0ddbf78e425..386618c09faf 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 2.3
-PORTREVISION= 1
+PORTVERSION= 2.3.1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -71,6 +70,9 @@ PLIST_SUB+= X86_ONLY=""
.else
PLIST_SUB+= X86_ONLY="@comment "
.endif
+.if ${ARCH} == amd64
+CFLAGS+= -fPIC
+.endif
.if ${OSVERSION} < 400000
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
@@ -111,6 +113,10 @@ post-patch:
${REINPLACE_CMD} -e \
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
+.if ${ARCH} == amd64 || ${ARCH} == sparc64
+ ${REINPLACE_CMD} -e \
+ 's,^#\(dl .*\),\1,' ${WRKSRC}/Modules/Setup.dist
+.endif
pre-install:
.for platform in ${PLATFORMS}
diff --git a/lang/python24/distinfo b/lang/python24/distinfo
index 962f6b52b806..17d0a7cc7c66 100644
--- a/lang/python24/distinfo
+++ b/lang/python24/distinfo
@@ -11,4 +11,5 @@ MD5 (python/Python-2.2.1.tgz) = e7012d611602b62e36073c2fd02396a3
MD5 (python/Python-2.2.2.tgz) = 1c1067396e5aa0299978486eb5bd1a5c
MD5 (python/Python-2.2.3.tgz) = 169f89f318e252dac0c54dd1b165d229
MD5 (python/Python-2.3.tgz) = 595620a4769073a812e353597585c4e8
+MD5 (python/Python-2.3.1.tgz) = a3dcbe1c7f173c8e3c7cce28495016ae
MD5 (python/Python-2.4a0-20030801.tgz) = 7bb219e81cd565ed1c360108d9e8ba16
diff --git a/lang/python24/files/patch-Modules-Setup.dist b/lang/python24/files/patch-Modules-Setup.dist
deleted file mode 100644
index 74b1ef29f224..000000000000
--- a/lang/python24/files/patch-Modules-Setup.dist
+++ /dev/null
@@ -1,12 +0,0 @@
---- Modules/Setup.dist Thu Aug 8 15:52:42 2002
-+++ Modules/Setup.dist.new Thu Nov 21 10:40:05 2002
-@@ -356,8 +356,7 @@
- # it is a highly experimental and dangerous device for calling
- # *arbitrary* C functions in *arbitrary* shared libraries:
-
--#dl dlmodule.c
--
-+dl dlmodule.c
-
- # Modules that provide persistent dictionary-like semantics. You will
- # probably want to arrange for at least one of them to be available on