aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/xjman/Makefile8
-rw-r--r--multimedia/transcode/Makefile4
-rw-r--r--net-im/gtkyahoo/Makefile8
-rw-r--r--net/gtkyahoo/Makefile8
4 files changed, 25 insertions, 3 deletions
diff --git a/japanese/xjman/Makefile b/japanese/xjman/Makefile
index aff000b80f44..8511cbbb2324 100644
--- a/japanese/xjman/Makefile
+++ b/japanese/xjman/Makefile
@@ -28,6 +28,12 @@ SCRIPTS_ENV+= MANSECS="${MANSECS}"
MANSECS= 1 3 5
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-extract:
.for i in Makefile Makefile.inc
@${CP} ${FILESDIR}/$i ${WRKSRC}
@@ -72,4 +78,4 @@ post-install:
.endfor
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 7f31c518e0e8..5ec16059b0cc 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -37,6 +37,10 @@ MAN1= avifix.1 aviindex.1 avimerge.1 avisplit.1 avisync.1 tccat.1 tcdemux.1 \
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
.if exists(${LOCALBASE}/lib/libMagick.so)
WITH_IMAGEMAGICK= yes
.endif
diff --git a/net-im/gtkyahoo/Makefile b/net-im/gtkyahoo/Makefile
index 438b407b254c..7ff396c6bfc7 100644
--- a/net-im/gtkyahoo/Makefile
+++ b/net-im/gtkyahoo/Makefile
@@ -20,4 +20,10 @@ USE_GNOME= gtk12
USE_BISON= yes
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/gtkyahoo/Makefile b/net/gtkyahoo/Makefile
index 438b407b254c..7ff396c6bfc7 100644
--- a/net/gtkyahoo/Makefile
+++ b/net/gtkyahoo/Makefile
@@ -20,4 +20,10 @@ USE_GNOME= gtk12
USE_BISON= yes
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile"
+.endif
+
+.include <bsd.port.post.mk>