aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Debug-Client/Makefile3
-rw-r--r--devel/p5-Debug-Client/pkg-plist1
-rw-r--r--devel/p5-Event-RPC/Makefile13
-rw-r--r--devel/p5-Event-RPC/pkg-plist11
-rw-r--r--emulators/p5-Acme-6502/Makefile4
-rw-r--r--emulators/p5-Acme-6502/pkg-plist2
-rw-r--r--finance/p5-Finance-Bitcoin/Makefile10
-rw-r--r--finance/p5-Finance-Bitcoin/pkg-plist4
-rw-r--r--finance/p5-Finance-YahooQuote/Makefile4
-rw-r--r--finance/p5-Finance-YahooQuote/pkg-plist2
-rw-r--r--security/p5-Crypt-T_e_a/Makefile4
-rw-r--r--security/p5-Crypt-T_e_a/pkg-plist2
12 files changed, 23 insertions, 37 deletions
diff --git a/devel/p5-Debug-Client/Makefile b/devel/p5-Debug-Client/Makefile
index 9fdb4fbf188a..7453ee79e3ca 100644
--- a/devel/p5-Debug-Client/Makefile
+++ b/devel/p5-Debug-Client/Makefile
@@ -23,9 +23,6 @@ TEST_DEPENDS= p5-File-HomeDir>=1.00:${PORTSDIR}/devel/p5-File-HomeDir \
USES= perl5
USE_PERL5= configure
-MAN3= Debug::Client.3
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 501400
diff --git a/devel/p5-Debug-Client/pkg-plist b/devel/p5-Debug-Client/pkg-plist
index d07ef104c12c..a88fcab9e3e2 100644
--- a/devel/p5-Debug-Client/pkg-plist
+++ b/devel/p5-Debug-Client/pkg-plist
@@ -1,5 +1,6 @@
%%SITE_PERL%%/Debug/Client.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Debug/Client/.packlist
+%%PERL5_MAN3%%/Debug::Client.3.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Debug/Client
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Debug
@dirrmtry %%SITE_PERL%%/Debug
diff --git a/devel/p5-Event-RPC/Makefile b/devel/p5-Event-RPC/Makefile
index fd91e087df19..f4801f1bc516 100644
--- a/devel/p5-Event-RPC/Makefile
+++ b/devel/p5-Event-RPC/Makefile
@@ -16,18 +16,6 @@ LICENSE_COMB= dual
USES= perl5
USE_PERL5= configure
-MAN3= Event::RPC.3 \
- Event::RPC::Client.3 \
- Event::RPC::Connection.3 \
- Event::RPC::LogConnection.3 \
- Event::RPC::Logger.3 \
- Event::RPC::Loop.3 \
- Event::RPC::Loop::AnyEvent.3 \
- Event::RPC::Loop::Event.3 \
- Event::RPC::Loop::Glib.3 \
- Event::RPC::Message.3 \
- Event::RPC::Server.3
-
OPTIONS_DEFINE= GLIB EVENT ANYEVENT SSL
GLIB_DESC= Dependency to Glib event handler
EVENT_DESC= Dependency to Event.pm event handler
@@ -36,7 +24,6 @@ SSL_DESC= Dependency to SSL lib
OPTIONS_DEFAULT= EVENT ANYEVENT SSL
-NO_STAGE= yes
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
diff --git a/devel/p5-Event-RPC/pkg-plist b/devel/p5-Event-RPC/pkg-plist
index 23280c76ba4e..93a8a92102c4 100644
--- a/devel/p5-Event-RPC/pkg-plist
+++ b/devel/p5-Event-RPC/pkg-plist
@@ -11,6 +11,17 @@
%%SITE_PERL%%/Event/RPC/Message.pm
%%SITE_PERL%%/Event/RPC/Server.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/RPC/.packlist
+%%PERL5_MAN3%%/Event::RPC.3.gz
+%%PERL5_MAN3%%/Event::RPC::Client.3.gz
+%%PERL5_MAN3%%/Event::RPC::Connection.3.gz
+%%PERL5_MAN3%%/Event::RPC::LogConnection.3.gz
+%%PERL5_MAN3%%/Event::RPC::Logger.3.gz
+%%PERL5_MAN3%%/Event::RPC::Loop.3.gz
+%%PERL5_MAN3%%/Event::RPC::Loop::AnyEvent.3.gz
+%%PERL5_MAN3%%/Event::RPC::Loop::Event.3.gz
+%%PERL5_MAN3%%/Event::RPC::Loop::Glib.3.gz
+%%PERL5_MAN3%%/Event::RPC::Message.3.gz
+%%PERL5_MAN3%%/Event::RPC::Server.3.gz
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/RPC
@dirrm %%SITE_PERL%%/Event/RPC/Loop
@dirrm %%SITE_PERL%%/Event/RPC
diff --git a/emulators/p5-Acme-6502/Makefile b/emulators/p5-Acme-6502/Makefile
index 3e1b82b84d26..88880f57b97c 100644
--- a/emulators/p5-Acme-6502/Makefile
+++ b/emulators/p5-Acme-6502/Makefile
@@ -17,8 +17,4 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= modbuild
-MAN3= Acme::6502.3 \
- Acme::6502::Tube.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/emulators/p5-Acme-6502/pkg-plist b/emulators/p5-Acme-6502/pkg-plist
index 066f25e64a04..b5257afb6eb3 100644
--- a/emulators/p5-Acme-6502/pkg-plist
+++ b/emulators/p5-Acme-6502/pkg-plist
@@ -1,4 +1,6 @@
%%SITE_PERL%%/Acme/6502.pm
%%SITE_PERL%%/Acme/6502/Tube.pm
+%%PERL5_MAN3%%/Acme::6502.3.gz
+%%PERL5_MAN3%%/Acme::6502::Tube.3.gz
@dirrm %%SITE_PERL%%/Acme/6502/
@dirrmtry %%SITE_PERL%%/Acme/
diff --git a/finance/p5-Finance-Bitcoin/Makefile b/finance/p5-Finance-Bitcoin/Makefile
index f2c3e7309bb6..5c4afef45b23 100644
--- a/finance/p5-Finance-Bitcoin/Makefile
+++ b/finance/p5-Finance-Bitcoin/Makefile
@@ -21,15 +21,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= Finance::Bitcoin::API.3 \
- Finance::Bitcoin::Address.3 \
- Finance::Bitcoin::Wallet.3 \
- Finance::Bitcoin.3
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
post-patch:
-@${RM} ${WRKSRC}/lib/Finance/Bitcoin/API.pm.orig
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/finance/p5-Finance-Bitcoin/pkg-plist b/finance/p5-Finance-Bitcoin/pkg-plist
index cf4fa4f650ff..d7150e879fde 100644
--- a/finance/p5-Finance-Bitcoin/pkg-plist
+++ b/finance/p5-Finance-Bitcoin/pkg-plist
@@ -3,6 +3,10 @@
%%SITE_PERL%%/Finance/Bitcoin/Wallet.pm
%%SITE_PERL%%/Finance/Bitcoin.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/Bitcoin/.packlist
+%%PERL5_MAN3%%/Finance::Bitcoin.3.gz
+%%PERL5_MAN3%%/Finance::Bitcoin::API.3.gz
+%%PERL5_MAN3%%/Finance::Bitcoin::Address.3.gz
+%%PERL5_MAN3%%/Finance::Bitcoin::Wallet.3.gz
@dirrm %%SITE_PERL%%/Finance/Bitcoin
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/Bitcoin
@dirrmtry %%SITE_PERL%%/Finance
diff --git a/finance/p5-Finance-YahooQuote/Makefile b/finance/p5-Finance-YahooQuote/Makefile
index 57cfaf57ad43..09101db5d831 100644
--- a/finance/p5-Finance-YahooQuote/Makefile
+++ b/finance/p5-Finance-YahooQuote/Makefile
@@ -17,8 +17,4 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN1= yahooquote.1
-MAN3= Finance::YahooQuote.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/finance/p5-Finance-YahooQuote/pkg-plist b/finance/p5-Finance-YahooQuote/pkg-plist
index 951e0c3c9456..de0d23e7d847 100644
--- a/finance/p5-Finance-YahooQuote/pkg-plist
+++ b/finance/p5-Finance-YahooQuote/pkg-plist
@@ -1,6 +1,8 @@
bin/yahooquote
%%SITE_PERL%%/Finance/YahooQuote.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/YahooQuote/.packlist
+%%PERL5_MAN3%%/Finance::YahooQuote.3.gz
+man/man1/yahooquote.1.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/YahooQuote
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance
@dirrmtry %%SITE_PERL%%/Finance
diff --git a/security/p5-Crypt-T_e_a/Makefile b/security/p5-Crypt-T_e_a/Makefile
index d8c35c9b40cf..b6c4bed61be3 100644
--- a/security/p5-Crypt-T_e_a/Makefile
+++ b/security/p5-Crypt-T_e_a/Makefile
@@ -15,8 +15,4 @@ COMMENT= The Tiny Encryption Algorithm in Perl and JavaScript
USES= perl5
USE_PERL5= configure
-MAN3= Crypt::Tea.3
-MAN1= tea.1
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-T_e_a/pkg-plist b/security/p5-Crypt-T_e_a/pkg-plist
index f2e53764cd04..0b363e71f3e4 100644
--- a/security/p5-Crypt-T_e_a/pkg-plist
+++ b/security/p5-Crypt-T_e_a/pkg-plist
@@ -1,6 +1,8 @@
bin/tea
%%SITE_PERL%%/Crypt/Tea.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Tea/.packlist
+%%PERL5_MAN3%%/Crypt::Tea.3.gz
+man/man1/tea.1.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Tea
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
@dirrmtry %%SITE_PERL%%/Crypt