aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-activesupport4/Makefile29
-rw-r--r--devel/rubygem-activesupport4/distinfo2
-rw-r--r--devel/rubygem-activesupport4/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a71b47d5c117..b0d517c03b13 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4010,6 +4010,7 @@
SUBDIR += rubygem-active_scaffold
SUBDIR += rubygem-activemessaging
SUBDIR += rubygem-activesupport
+ SUBDIR += rubygem-activesupport4
SUBDIR += rubygem-allison
SUBDIR += rubygem-analogger
SUBDIR += rubygem-annoy
diff --git a/devel/rubygem-activesupport4/Makefile b/devel/rubygem-activesupport4/Makefile
new file mode 100644
index 000000000000..a329dce38d35
--- /dev/null
+++ b/devel/rubygem-activesupport4/Makefile
@@ -0,0 +1,29 @@
+# Created by: Jonathan Weiss (<jw@innerewut.de>)
+# $FreeBSD$
+
+PORTNAME= activesupport
+PORTVERSION= 4.0.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Utility classes and extension that are required by Rails MVC Framework
+
+RUN_DEPENDS= rubygem-i18n>=0.6.4:${PORTSDIR}/devel/rubygem-i18n \
+ rubygem-minitest4>=4.2:${PORTSDIR}/devel/rubygem-minitest4 \
+ rubygem-multi_json>=1.3:${PORTSDIR}/devel/rubygem-multi_json \
+ rubygem-thread_safe>=0.1:${PORTSDIR}/devel/rubygem-thread_safe \
+ rubygem-tzinfo>=0.3.37:${PORTSDIR}/devel/rubygem-tzinfo
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+USE_RUBY_FEATURES= iconv
+
+PKGNAMESUFFIX= 4
+
+NOPORTDOCS= yes
+
+NO_STAGE= yes
+.include <bsd.port.mk>
diff --git a/devel/rubygem-activesupport4/distinfo b/devel/rubygem-activesupport4/distinfo
new file mode 100644
index 000000000000..d417666594ab
--- /dev/null
+++ b/devel/rubygem-activesupport4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/activesupport-4.0.0.gem) = bac5915af0e0bb115f36443f0a378431584dbc958f51506f4ed96c08e59efd29
+SIZE (rubygem/activesupport-4.0.0.gem) = 309248
diff --git a/devel/rubygem-activesupport4/pkg-descr b/devel/rubygem-activesupport4/pkg-descr
new file mode 100644
index 000000000000..efec585f4b7b
--- /dev/null
+++ b/devel/rubygem-activesupport4/pkg-descr
@@ -0,0 +1,6 @@
+Active Support
+
+Utility classes and extension to the standard library that
+were required by Rails, but found of general use.
+
+WWW: http://www.rubyonrails.org