aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/linux_dist-gentoo-stage1/Makefile12
-rw-r--r--emulators/linux_dist-gentoo-stage2/Makefile6
-rw-r--r--emulators/linux_dist-gentoo-stage3/Makefile4
3 files changed, 11 insertions, 11 deletions
diff --git a/emulators/linux_dist-gentoo-stage1/Makefile b/emulators/linux_dist-gentoo-stage1/Makefile
index 958138e90996..60d189e31211 100644
--- a/emulators/linux_dist-gentoo-stage1/Makefile
+++ b/emulators/linux_dist-gentoo-stage1/Makefile
@@ -22,7 +22,6 @@ USE_BZIP2= YES
DIST_SUBDIR= gentoo-linux
NO_BUILD= YES
NO_FILTER_SHLIBS= YES
-NO_MTREE= YES
ONLY_FOR_ARCHS= amd64 i386
SUB_FILES+= pkg-message pkg-install pkg-deinstall
SUB_LIST+= PREFIX_SUBDIR="${PREFIX_SUBDIR}"
@@ -32,15 +31,16 @@ PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
.if defined(WITH_LINUXBASE)
-PKGNAMEPREFIX= linux_base-
-CONFLICTS= linux_base-7* linux_base-8* linux_base-debian* \
+PKGNAMEPREFIX= linux_base-
+CONFLICTS= linux_base-7* linux_base-8* linux_base-debian* \
linux_base-rh* linux_base-suse* linux_base-fc* \
linux_base-gentoo-stage[23]-*
-PREFIX?= ${LINUXBASE}
+USE_LINUX_PREFIX= YES
PREFIX_SUBDIR=
.else
-PKGNAMEPREFIX= linux_dist-
-PREFIX_SUBDIR= ${PORTNAME}/
+NO_MTREE= YES
+PKGNAMEPREFIX= linux_dist-
+PREFIX_SUBDIR= ${PORTNAME}/
.endif
.include <bsd.port.pre.mk>
diff --git a/emulators/linux_dist-gentoo-stage2/Makefile b/emulators/linux_dist-gentoo-stage2/Makefile
index 7b701d00d94f..4321bfa9ea0b 100644
--- a/emulators/linux_dist-gentoo-stage2/Makefile
+++ b/emulators/linux_dist-gentoo-stage2/Makefile
@@ -20,7 +20,6 @@ USE_BZIP2= YES
DIST_SUBDIR= gentoo-linux
NO_BUILD= YES
NO_FILTER_SHLIBS= YES
-NO_MTREE= YES
ONLY_FOR_ARCHS= i386 amd64
GENTOO_OPTIMIZED?= x86
SUB_FILES+= pkg-message pkg-install pkg-deinstall
@@ -32,13 +31,14 @@ PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
.if defined(WITH_LINUXBASE)
-PKGNAMEPREFIX= linux_base-
+PKGNAMEPREFIX= linux_base-
CONFLICTS= linux_base-7* linux_base-8* linux_base-debian* \
linux_base-rh* linux_base-suse* linux_base-fc* \
linux_base-gentoo-stage[13]-*
-PREFIX?= ${LINUXBASE}
+USE_LINUX_PREFIX= YES
PREFIX_SUBDIR=
.else
+NO_MTREE= YES
PKGNAMEPREFIX= linux_dist-
PREFIX_SUBDIR= ${PORTNAME}/
.endif
diff --git a/emulators/linux_dist-gentoo-stage3/Makefile b/emulators/linux_dist-gentoo-stage3/Makefile
index ae90dfd3293c..601f7e62f9a9 100644
--- a/emulators/linux_dist-gentoo-stage3/Makefile
+++ b/emulators/linux_dist-gentoo-stage3/Makefile
@@ -20,7 +20,6 @@ USE_BZIP2= YES
DIST_SUBDIR= gentoo-linux
NO_BUILD= YES
NO_FILTER_SHLIBS= YES
-NO_MTREE= YES
ONLY_FOR_ARCHS= i386 amd64
GENTOO_OPTIMIZED?= x86
SUB_FILES+= pkg-message pkg-install pkg-deinstall
@@ -36,9 +35,10 @@ PKGNAMEPREFIX= linux_base-
CONFLICTS= linux_base-7* linux_base-8* linux_base-debian* \
linux_base-rh* linux_base-suse* linux_base-fc* \
linux_base-gentoo-stage[12]-*
-PREFIX?= ${LINUXBASE}
+USE_LINUX_PREFIX= YES
PREFIX_SUBDIR=
.else
+NO_MTREE= YES
PKGNAMEPREFIX= linux_dist-
PREFIX_SUBDIR= ${PORTNAME}/
.endif