aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/bogofilter-current/Makefile8
-rw-r--r--mail/bogofilter/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/mail/bogofilter-current/Makefile b/mail/bogofilter-current/Makefile
index dc376247f043..23d2634226b1 100644
--- a/mail/bogofilter-current/Makefile
+++ b/mail/bogofilter-current/Makefile
@@ -43,6 +43,12 @@ INSTALL_TARGET= install-strip prefix=${PREFIX}
MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
+IGNORE= "Does not compile on alpha 5.x \(infinite loop in build\)"
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
${WRKSRC}/contrib/randomtrain \
@@ -94,4 +100,4 @@ post-install::
${INSTALL_MAN} ${WRKSRC}/doc/programmer/README.freebsd ${DOCSDIR}/programmer
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index dc376247f043..23d2634226b1 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -43,6 +43,12 @@ INSTALL_TARGET= install-strip prefix=${PREFIX}
MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
+IGNORE= "Does not compile on alpha 5.x \(infinite loop in build\)"
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
${WRKSRC}/contrib/randomtrain \
@@ -94,4 +100,4 @@ post-install::
${INSTALL_MAN} ${WRKSRC}/doc/programmer/README.freebsd ${DOCSDIR}/programmer
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>