aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/dmtx-utils/Makefile26
-rw-r--r--graphics/dmtx-utils/distinfo2
-rw-r--r--graphics/dmtx-utils/pkg-descr15
4 files changed, 44 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4b1d8c3b4799..de6cc9d4b098 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -119,6 +119,7 @@
SUBDIR += djview4
SUBDIR += djvulibre
SUBDIR += djvulibre-nox11
+ SUBDIR += dmtx-utils
SUBDIR += dri
SUBDIR += driconf
SUBDIR += duhdraw
diff --git a/graphics/dmtx-utils/Makefile b/graphics/dmtx-utils/Makefile
new file mode 100644
index 000000000000..fb0e1373e826
--- /dev/null
+++ b/graphics/dmtx-utils/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: dmtx-utils
+# Date created: 3 June 2011
+# Whom: johans
+#
+# $FreeBSD$
+#
+
+PORTNAME= dmtx-utils
+PORTVERSION= 0.7.4
+CATEGORIES= graphics
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=libdmtx/libdmtx/${PORTVERSION}
+
+MAINTAINER= johans@FreeBSD.org
+COMMENT= Software for reading and writing Data Matrix barcodes
+
+LIB_DEPENDS= dmtx.0:${PORTSDIR}/graphics/libdmtx
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+
+MAN1= dmtxread.1 dmtxwrite.1 dmtxquery.1
+PLIST_FILES= bin/dmtxread bin/dmtxwrite bin/dmtxquery
+
+.include <bsd.port.mk>
diff --git a/graphics/dmtx-utils/distinfo b/graphics/dmtx-utils/distinfo
new file mode 100644
index 000000000000..b91c9593c2d8
--- /dev/null
+++ b/graphics/dmtx-utils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dmtx-utils-0.7.4.tar.bz2) = 9f510f6c26a2a73e44da28eae78308973cc274043873cc7f90606624066ec7d0
+SIZE (dmtx-utils-0.7.4.tar.bz2) = 280232
diff --git a/graphics/dmtx-utils/pkg-descr b/graphics/dmtx-utils/pkg-descr
new file mode 100644
index 000000000000..b30ca78e1fd2
--- /dev/null
+++ b/graphics/dmtx-utils/pkg-descr
@@ -0,0 +1,15 @@
+dmtx-utils - software for reading and writing Data Matrix barcodes
+
+libdmtx is open source software for reading and writing Data Matrix
+barcodes on Linux, Unix, OS X, Windows, and certain mobile devices.
+The included utility programs, dmtxread and dmtxwrite, serve as the
+official interface to libdmtx from the command line, and also provide
+a good reference for programmers who wish to write their own programs
+that interact with libdmtx.
+
+Data Matrix barcodes are two-dimensional symbols that hold a dense
+pattern of data with built-in error correction. The Data Matrix
+symbology (sometimes casually referred to as "DataMatrix") was invented
+and released into the public domain by RVSI Acuity CiMatrix.
+
+WWW: http://www.libdmtx.org/