aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/quagga/Makefile2
-rw-r--r--net/quagga/files/patch-configure11
-rw-r--r--net/quagga/files/patch-configure.ac11
3 files changed, 12 insertions, 12 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 4db0cf264d9e..5980ed086e0b 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= openbgpd-[0-9]* openospfd-[0-9]* zebra-0* quagga-re-[0-9]*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-exampledir=${PREFIX}/share/examples/quagga
INSTALL_TARGET= install-strip
-USES= gmake libtool makeinfo perl5 readline autoreconf
+USES= gmake libtool makeinfo perl5 readline
USE_LDCONFIG= yes
USE_PERL5= build
diff --git a/net/quagga/files/patch-configure b/net/quagga/files/patch-configure
new file mode 100644
index 000000000000..b9640b0124b5
--- /dev/null
+++ b/net/quagga/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2014-08-25 17:02:06 UTC
++++ configure
+@@ -18158,7 +18158,7 @@ fi
+
+
+
+-if test "${enable_snmp}" != ""; then
++if test "x${enable_snmp}" != "xno"; then
+ if test -n "$ac_tool_prefix"; then
+ # Extract the first word of "${ac_tool_prefix}net-snmp-config", so it can be a program name with args.
+ set dummy ${ac_tool_prefix}net-snmp-config; ac_word=$2
diff --git a/net/quagga/files/patch-configure.ac b/net/quagga/files/patch-configure.ac
deleted file mode 100644
index ca491c46db73..000000000000
--- a/net/quagga/files/patch-configure.ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2014-08-25 16:56:53 UTC
-+++ configure.ac
-@@ -1415,7 +1415,7 @@
- dnl ------------------
- dnl check Net-SNMP library
- dnl ------------------
--if test "${enable_snmp}" != ""; then
-+if test "x${enable_snmp}" != "xno"; then
- AC_PATH_TOOL([NETSNMP_CONFIG], [net-snmp-config], [no])
- if test x"$NETSNMP_CONFIG" = x"no"; then
- AC_MSG_ERROR([--enable-snmp given but unable to find net-snmp-config])