aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/libsndfile/Makefile2
-rw-r--r--chinese/fcitx/Makefile9
-rw-r--r--chinese/pyzy/Makefile4
-rw-r--r--devel/codeblocks/Makefile10
4 files changed, 16 insertions, 9 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index 92f5763214de..0479b49cc453 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libsndfile
PORTVERSION= 1.0.26
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.mega-nerd.com/libsndfile/files/
@@ -31,6 +32,7 @@ CPU_CLIP_VARS= MANUAL_PACKAGE_BUILD="WITH_CPU_CLIP may customize the package for
CPU_CLIP_CONFIGURE_OFF= --disable-cpu-clip
EXTERNAL_LIB_DEPENDS= libFLAC.so:audio/flac \
+ libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
EXTERNAL_CONFIGURE_OFF= --disable-external-libs
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index 0626a206921f..ac04e669a69d 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fcitx
PORTVERSION= 4.2.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= chinese x11
MASTER_SITES= http://download.fcitx-im.org/fcitx/:fcitx \
http://download.fcitx-im.org/data/:data
@@ -38,9 +38,10 @@ SUB_LIST+= PORTSDIR=${PORTSDIR}
CONFLICTS= zh-scim-fcitx-3.*
USE_GNOME= pango intltool libxml2 introspection
-USE_XORG= x11 xext xkbfile
+USE_XORG= x11 xext xkbfile sm ice
USE_LDCONFIG= yes
-USES= tar:xz cmake desktop-file-utils execinfo gettext iconv:wchar_t \
+USES= tar:xz cmake desktop-file-utils execinfo \
+ gettext-tools:build,run gettext-runtime iconv:wchar_t \
pkgconfig shared-mime-info
INSTALLS_ICONS= yes
@@ -87,7 +88,7 @@ SUB_LIST+= GTK3_IM=xim
.endif
.if ${PORT_OPTIONS:MQT4}
-USE_QT4+= qmake_build moc_build rcc_build uic_build dbus gui inputmethods
+USE_QT4+= qmake_build moc_build rcc_build uic_build dbus gui inputmethods corelib
USE_LDCONFIG+= ${PREFIX}/lib/fcitx/qt
PLIST_SUB+= QT4=""
.else
diff --git a/chinese/pyzy/Makefile b/chinese/pyzy/Makefile
index 4ba6b0831e68..e83c03008044 100644
--- a/chinese/pyzy/Makefile
+++ b/chinese/pyzy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pyzy
PORTVERSION= 0.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= chinese
MASTER_SITES= GOOGLE_CODE
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -18,7 +18,7 @@ BROKEN= Unfetchable (google code has gone away)
LIB_DEPENDS= libsqlite3.so:databases/sqlite3
-USES= compiler:c++11-lib gmake libtool pkgconfig python:build shebangfix
+USES= compiler:c++11-lib gettext-runtime gmake libtool pkgconfig python:build shebangfix
SHEBANG_FILES= data/db/android/create_db.py
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/devel/codeblocks/Makefile b/devel/codeblocks/Makefile
index 4117bc323a69..8cc23ce7b3a0 100644
--- a/devel/codeblocks/Makefile
+++ b/devel/codeblocks/Makefile
@@ -3,6 +3,7 @@
PORTNAME= codeblocks
PORTVERSION= 16.01
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/Sources/${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -15,12 +16,15 @@ LICENSE_COMB= multi
BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libhunspell-1.3.so:textproc/hunspell
-USES= autoreconf compiler desktop-file-utils fam:gamin libtool pathfix \
- pkgconfig shared-mime-info
+USES= autoreconf compiler desktop-file-utils fam:gamin \
+ gettext-runtime libtool pathfix pkgconfig shared-mime-info
USE_WX= 2.8
-WANT_UNICODE= yes
+USE_GNOME= gtk20 cairo
+USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG} --with-contrib-plugins=all \
--disable-pch