aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/hs-scroll/Makefile22
-rw-r--r--games/hs-scroll/distinfo2
-rw-r--r--games/hs-scroll/pkg-descr5
-rw-r--r--lang/ghc/bsd.hackage.mk1
5 files changed, 31 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 3a0b4c5b48d7..892c3db5baee 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -411,6 +411,7 @@
SUBDIR += hoichess
SUBDIR += holotz-castle
SUBDIR += hoverboard-sdl
+ SUBDIR += hs-scroll
SUBDIR += hypatia_engine
SUBDIR += iagno
SUBDIR += icbm3d
diff --git a/games/hs-scroll/Makefile b/games/hs-scroll/Makefile
new file mode 100644
index 000000000000..855e4ddf5cb2
--- /dev/null
+++ b/games/hs-scroll/Makefile
@@ -0,0 +1,22 @@
+# Created by: Nikolai Lifanov <lifanov@mail.lifanov.com>
+# $FreeBSD$
+
+PORTNAME= scroll
+PORTVERSION= 1.20151219
+CATEGORIES= games haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A roguelike game
+
+LICENSE= GPLv2
+
+PKGNAMEPREFIX=
+
+USE_CABAL= IfElse case-insensitive data-default monad-loops mtl \
+ optparse-applicative ncurses random text vector
+
+STANDALONE= yes
+EXECUTABLE= scroll
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/games/hs-scroll/distinfo b/games/hs-scroll/distinfo
new file mode 100644
index 000000000000..ebc88c27979a
--- /dev/null
+++ b/games/hs-scroll/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/scroll-1.20151219.tar.gz) = 4f91c20e645ee715c9d3549fffffcc58943bee4fb3ba2e622e0189ccb70dd050
+SIZE (cabal/scroll-1.20151219.tar.gz) = 265861
diff --git a/games/hs-scroll/pkg-descr b/games/hs-scroll/pkg-descr
new file mode 100644
index 000000000000..73a32766c6a7
--- /dev/null
+++ b/games/hs-scroll/pkg-descr
@@ -0,0 +1,5 @@
+In scroll, you're a bookworm that's stuck on a scroll. You have to dodge
+between words and use spells to make your way down the page as the scroll
+is read. Go too slow and you'll get wound up in the scroll and crushed.
+
+WWW: http://joeyh.name/code/scroll/
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 44e8bc1c0a34..3b71711aef3f 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -370,6 +370,7 @@ safe_port= devel/hs-safe
SafeSemaphore_port= devel/hs-SafeSemaphore
sandi_port= converters/hs-sandi
scientific_port= devel/hs-scientific
+scroll_port= games/hs-scroll # executable
securemem_port= devel/hs-securemem
semigroupoids_port= math/hs-semigroupoids
semigroups_port= math/hs-semigroups