aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/openssh-portable/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 00c1e6b7c8f5..bc13ce810fe0 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -60,6 +60,7 @@ OPTIONS= PAM "Enable pam(3) support" on \
SUID_SSH "Enable suid SSH (Recommended off)" off \
GSSAPI "Enable GSSAPI support" off \
OPENSSH_CHROOT "Enable CHROOT support" off \
+ OPENSC "Enable OpenSC smartcard support" off \
HPN "Enable HPN-11 SSH/SCP patch" off \
HPN_NONECIPHER "Enable HPN-11 with None Cipher patch" off \
OVERWRITE_BASE "OpenSSH overwrite base" off
@@ -122,6 +123,11 @@ CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLBASE}
CFLAGS+= -DCHROOT
.endif
+.if defined(WITH_OPENSC)
+LIB_DEPENDS+= opensc.2:${PORTSDIR}/security/opensc
+CONFIGURE_ARGS+= --with-opensc=${LOCALBASE}
+.endif
+
.if defined(WITH_HPN)
.if defined(WITH_HPN_NONECIPHER)
IGNORE= please, select only one HPN patch. Rerun 'make config'