aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/p5-Net-Z3950/files/patch-yazwrap-Makefile.PL19
1 files changed, 19 insertions, 0 deletions
diff --git a/net/p5-Net-Z3950/files/patch-yazwrap-Makefile.PL b/net/p5-Net-Z3950/files/patch-yazwrap-Makefile.PL
new file mode 100644
index 000000000000..f1c804bfd08c
--- /dev/null
+++ b/net/p5-Net-Z3950/files/patch-yazwrap-Makefile.PL
@@ -0,0 +1,19 @@
+--- yazwrap/Makefile.PL.orig Tue May 6 17:59:59 2003
++++ yazwrap/Makefile.PL Fri Sep 19 10:57:34 2003
+@@ -1,8 +1,15 @@
++my $yazinc = `yaz-config --cflags`;
++my $yazlibs = `yaz-config --libs`;
++if (!$yazinc || !$yazlibs) {
++ die "ERROR: Unable to call script 'yaz-config': is YAZ installed?";
++}
++
+ use ExtUtils::MakeMaker;
+-$Verbose = 1;
+
+ WriteMakefile(
+ 'NAME' => 'Net::Z3950::yazwrap',
++ 'LIBS' => [ $yazlibs ],
++ 'INC' => $yazinc,
+ 'SKIP' => [qw(all static dynamic test)],
+ 'clean' => {'FILES' => 'libyazwrap$(LIB_EXT)'},
+ 'OPTIMIZE' => '-g', ### temporary