aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--print/lilypond-devel/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index dd964b1d6bcb..6d50070bf196 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -32,8 +32,6 @@ LIB_DEPENDS= libltdl.so:devel/libltdl \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-BROKEN_FreeBSD_9= does not build on FreeBSD < 10.x
-
INFO= internals \
lilypond-changes \
lilypond-contributor \
@@ -73,6 +71,12 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000 && ${OSVERSION} < 1003000
+BROKEN= does not build on < 10.3 (undefined reference to `__cxa_throw_bad_array_new_length')
+.endif
+
post-patch:
${FIND} ${WRKSRC} -name "*.cc" | ${XARGS} \
${REINPLACE_CMD} -e 's|isinf[ ]*(|::isinf(|g' -e 's|isnan|::isnan|g'
@@ -87,4 +91,4 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lilypond/${PORTVERSION}/python/midi.so
(cd ${STAGEDIR}/${DATADIR} && ${LN} -fs ${PORTVERSION} current)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>