aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/gnustep-base/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index 853b22cc1d34..da3a4a4c0667 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -42,6 +42,12 @@ BREAKS_IF_PEDANTIC= yes
PLIST_SUB+= MAJORVERSION=${PORTVERSION:C/([0-9]).*/\1/1}
PLIST_SUB+= LOCALBASE=${LOCALBASE}
+.if defined(WITHOUT_OPENSSL)
+CONFIGURE_ARGS+= --disable-openssl
+.else
+USE_OPENSSL= yes
+.endif
+
.include <bsd.port.pre.mk>
TARGLIB!= (cd ${PORTSDIR}/${GNUSTEP_OBJC_PORT} && make -V TARGLIB)