aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/horde4-passwd/Makefile34
-rw-r--r--www/horde4-passwd/distinfo2
-rw-r--r--www/horde4-passwd/pkg-descr10
4 files changed, 47 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 668918d22a90..ac93cc0248b5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -281,6 +281,7 @@
SUBDIR += horde-wicked
SUBDIR += horde4-ansel
SUBDIR += horde4-base
+ SUBDIR += horde4-passwd
SUBDIR += horde4-wicked
SUBDIR += hotcrp
SUBDIR += hs-HTTP
diff --git a/www/horde4-passwd/Makefile b/www/horde4-passwd/Makefile
new file mode 100644
index 000000000000..2dcea655b052
--- /dev/null
+++ b/www/horde4-passwd/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: horde4-passwd
+# Date created: Oct 28, 2011
+# Whom: Martin Matuska (mm@FreeBSD.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= passwd
+DISTVERSION= 4.0.0RC1
+CATEGORIES= www pear
+PKGNAMEPREFIX= horde-
+
+MAINTAINER= horde@FreeBSD.org
+COMMENT= Horde password changing application
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LATEST_LINK= horde4-${PORTNAME}
+
+USE_PHP= gettext
+USE_HORDE_BUILD= Horde_Role
+USE_HORDE_RUN= Horde_Role \
+ horde \
+ Horde_Auth \
+ Horde_Core \
+ Horde_Exception \
+ Horde_Injector \
+ Horde_Util \
+ Horde_View
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
+.include <bsd.port.post.mk>
diff --git a/www/horde4-passwd/distinfo b/www/horde4-passwd/distinfo
new file mode 100644
index 000000000000..fe4b7a412c7a
--- /dev/null
+++ b/www/horde4-passwd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde/passwd-4.0.0RC1.tgz) = e6d094c7600d401605e0738fade8d976af002404ed8f804813c16050694e5277
+SIZE (Horde/passwd-4.0.0RC1.tgz) = 1324280
diff --git a/www/horde4-passwd/pkg-descr b/www/horde4-passwd/pkg-descr
new file mode 100644
index 000000000000..26ca337bf778
--- /dev/null
+++ b/www/horde4-passwd/pkg-descr
@@ -0,0 +1,10 @@
+Passwd is the Horde password changing application. While it has been
+released and is in production use at many sites, it is also under heavy
+development in an effort to expand and improve the module.
+
+Right now, Passwd provides fairly complete support for changing passwords
+via Poppassd, LDAP, Unix expect scripts, the Unix smbpasswd command for
+SMB/CIFS passwords, Kolab, ADSI, Pine, Serv-U FTP, VMailMgr, vpopmail,
+and SQL passwords.
+
+WWW: http://www.horde.org/apps/passwd/