aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/netpbm/Makefile3
-rw-r--r--graphics/netpbm/distinfo4
-rw-r--r--graphics/netpbm/files/patch-converter-other-Makefile11
-rw-r--r--graphics/netpbm/files/patch-converter-other-jbig-Makefile11
-rw-r--r--graphics/netpbm/files/patch-converter-other-pnmtopalm-Makefile11
-rw-r--r--graphics/netpbm/files/patch-converter-pbm-pbmtoppa-Makefile11
-rw-r--r--graphics/netpbm/files/patch-converter-ppm-ppmtodjvurle.c12
-rw-r--r--graphics/netpbm/files/patch-lib-Makefile20
-rw-r--r--graphics/netpbm/pkg-plist8
9 files changed, 74 insertions, 17 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 779532f55383..5d4d160ddea1 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= netpbm
-PORTVERSION= 10.20
-PORTREVISION= 2
+PORTVERSION= 10.21
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/netpbm/distinfo b/graphics/netpbm/distinfo
index 8545731d833b..e29f92083055 100644
--- a/graphics/netpbm/distinfo
+++ b/graphics/netpbm/distinfo
@@ -1,2 +1,2 @@
-MD5 (netpbm-10.20.tgz) = 4aa2f767c4d58bcbdafaba6a7dd03313
-SIZE (netpbm-10.20.tgz) = 2110651
+MD5 (netpbm-10.21.tgz) = 82da13e01e34e6cbf9392bdaf4968b9e
+SIZE (netpbm-10.21.tgz) = 2130256
diff --git a/graphics/netpbm/files/patch-converter-other-Makefile b/graphics/netpbm/files/patch-converter-other-Makefile
new file mode 100644
index 000000000000..229d64de3fae
--- /dev/null
+++ b/graphics/netpbm/files/patch-converter-other-Makefile
@@ -0,0 +1,11 @@
+--- converter/other/Makefile.orig Fri Jul 11 05:23:53 2003
++++ converter/other/Makefile Tue Mar 30 06:59:13 2004
+@@ -7,6 +7,8 @@
+
+ include $(BUILDDIR)/Makefile.config
+
++LADD += -lm
++
+ SUBDIRS = jbig pnmtopalm
+ ifneq ($(BUILD_FIASCO), N)
+ SUBDIRS += fiasco
diff --git a/graphics/netpbm/files/patch-converter-other-jbig-Makefile b/graphics/netpbm/files/patch-converter-other-jbig-Makefile
new file mode 100644
index 000000000000..2e0f37f2d0a9
--- /dev/null
+++ b/graphics/netpbm/files/patch-converter-other-jbig-Makefile
@@ -0,0 +1,11 @@
+--- converter/other/jbig/Makefile.orig Sat Sep 13 04:43:39 2003
++++ converter/other/jbig/Makefile Tue Mar 30 07:04:32 2004
+@@ -7,6 +7,8 @@
+
+ include $(BUILDDIR)/Makefile.config
+
++LADD += -lm
++
+ LIBJBIG_OBJECTS = jbig.o jbig_tab.o
+
+ INCLUDES =
diff --git a/graphics/netpbm/files/patch-converter-other-pnmtopalm-Makefile b/graphics/netpbm/files/patch-converter-other-pnmtopalm-Makefile
new file mode 100644
index 000000000000..8dbe9b5bf064
--- /dev/null
+++ b/graphics/netpbm/files/patch-converter-other-pnmtopalm-Makefile
@@ -0,0 +1,11 @@
+--- converter/other/pnmtopalm/Makefile.orig Sat Sep 13 04:43:54 2003
++++ converter/other/pnmtopalm/Makefile Tue Mar 30 07:05:24 2004
+@@ -7,6 +7,8 @@
+
+ include $(BUILDDIR)/Makefile.config
+
++LADD += -lm
++
+ BINARIES = palmtopnm pnmtopalm
+ SCRIPTS =
+ OBJECTS = $(BINARIES:%=%.o) palmcolormap.o
diff --git a/graphics/netpbm/files/patch-converter-pbm-pbmtoppa-Makefile b/graphics/netpbm/files/patch-converter-pbm-pbmtoppa-Makefile
new file mode 100644
index 000000000000..f91e314733f0
--- /dev/null
+++ b/graphics/netpbm/files/patch-converter-pbm-pbmtoppa-Makefile
@@ -0,0 +1,11 @@
+--- converter/pbm/pbmtoppa/Makefile.orig Fri Jun 6 04:54:07 2003
++++ converter/pbm/pbmtoppa/Makefile Tue Mar 30 06:53:38 2004
+@@ -7,6 +7,8 @@
+
+ include $(BUILDDIR)/Makefile.config
+
++LADD += -lm
++
+ all: pbmtoppa
+
+ BINARIES = pbmtoppa
diff --git a/graphics/netpbm/files/patch-converter-ppm-ppmtodjvurle.c b/graphics/netpbm/files/patch-converter-ppm-ppmtodjvurle.c
new file mode 100644
index 000000000000..9c0bd50138ff
--- /dev/null
+++ b/graphics/netpbm/files/patch-converter-ppm-ppmtodjvurle.c
@@ -0,0 +1,12 @@
+--- converter/ppm/ppmtodjvurle.c.orig Sun Mar 21 02:27:26 2004
++++ converter/ppm/ppmtodjvurle.c Tue Mar 30 06:57:57 2004
+@@ -33,7 +33,9 @@
+
+ #include <stdio.h>
+ #include <inttypes.h>
++#ifndef __FreeBSD__
+ #include <netinet/in.h>
++#endif
+
+ #include "ppm.h"
+ #include "ppmcmap.h"
diff --git a/graphics/netpbm/files/patch-lib-Makefile b/graphics/netpbm/files/patch-lib-Makefile
index 2b480b273929..e83390e31881 100644
--- a/graphics/netpbm/files/patch-lib-Makefile
+++ b/graphics/netpbm/files/patch-lib-Makefile
@@ -1,6 +1,6 @@
---- lib/Makefile.orig Thu Sep 25 18:23:47 2003
-+++ lib/Makefile Mon Dec 1 14:28:48 2003
-@@ -32,12 +32,14 @@
+--- lib/Makefile.orig Thu Mar 18 19:09:21 2004
++++ lib/Makefile Tue Mar 30 06:34:58 2004
+@@ -34,6 +34,8 @@
# Library objects to be linked but not built by Makefile.common:
LIBOBJECTS_X = util/shhopt.o util/nstring.o
@@ -9,13 +9,7 @@
MANUALS3 = libnetpbm
MANUALS5 = pbm pgm ppm pnm pam
- INTERFACE_HEADERS = pm.h pbm.h bitio.h pbmfont.h \
- pgm.h ppm.h ppm.h ppmcmap.h ppmfloyd.h colorname.h \
- pnm.h pam.h pammap.h util/shhopt.h util/nstring.h util/mallocvar.h
-
- DATAFILES = rgb.txt
-
-@@ -71,12 +71,15 @@
+@@ -74,12 +76,15 @@
$(LIBOBJECTS): %.o: %.c $(HEADERLINKS)
# Note that the user may have configured -I options into CFLAGS.
@@ -32,7 +26,7 @@
ifeq ($(NETPBMLIBTYPE),irixshared)
# The libxxx.so link is needed to link the executables.
-@@ -101,11 +104,8 @@
+@@ -104,11 +109,8 @@
# The $(SONAME) link is needed only to test the programs without
# installing the libraries (in that case, you also need to direct the
# dynamic linker to the source directories, e.g. set LD_LIBRARY_PATH).
@@ -46,7 +40,7 @@
$(SHLIB_CLIB) $(LADD)
endif
-@@ -183,13 +183,10 @@
+@@ -186,13 +188,10 @@
.PHONY: install.lib
ifeq ($(NETPBMLIBTYPE),unixshared)
# install a Unix-style shared library
@@ -64,7 +58,7 @@
endif
ifeq ($(NETPBMLIBTYPE),dll)
#install a Windows DLL shared library
-@@ -219,23 +216,23 @@
+@@ -222,23 +221,23 @@
# directory when you compile your programs.
%_installhdr: $(PKGDIR)/include
diff --git a/graphics/netpbm/pkg-plist b/graphics/netpbm/pkg-plist
index 083424660fe6..2264b229d1a1 100644
--- a/graphics/netpbm/pkg-plist
+++ b/graphics/netpbm/pkg-plist
@@ -39,6 +39,7 @@ bin/neotoppm
bin/palmtopnm
bin/pamarith
bin/pamchannel
+bin/pamcomp
bin/pamcut
bin/pamdeinterlace
bin/pamdice
@@ -52,10 +53,14 @@ bin/pamoil
bin/pampop9
bin/pamscale
bin/pamseq
+bin/pamsharpmap
+bin/pamsharpness
bin/pamslice
bin/pamstack
bin/pamstretch
bin/pamstretch-gen
+bin/pamsumm
+bin/pamsummcol
bin/pamtohdiff
bin/pamtohtmltbl
bin/pamtopnm
@@ -170,6 +175,7 @@ bin/pnmsplit
bin/pnmstitch
bin/pnmtile
bin/pnmtoddif
+bin/ppmtodjvurle
bin/pnmtofiasco
bin/pnmtofits
bin/pnmtojbig
@@ -287,6 +293,8 @@ include/pbmfont.h
include/pgm.h
include/pm.h
include/pm_config.h
+include/pm_gamma.h
+include/pm_system.h
include/pnm.h
include/ppm.h
include/ppmcmap.h