aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/powerdns/Makefile3
-rw-r--r--ftp/curl/Makefile3
-rw-r--r--net/belle-sip/Makefile3
-rw-r--r--net/mediastreamer/Makefile4
-rw-r--r--security/libbzrtp/Makefile3
-rw-r--r--security/openvpn-devel/Makefile3
-rw-r--r--security/polarssl13/Makefile47
-rw-r--r--security/polarssl13/distinfo4
-rw-r--r--security/polarssl13/files/patch-include-polarssl-config_h11
-rw-r--r--security/polarssl13/files/patch-include_polarssl_config.h9
-rw-r--r--security/polarssl13/files/patch-library-Makefile24
-rw-r--r--security/polarssl13/pkg-descr23
-rw-r--r--security/polarssl13/pkg-plist78
13 files changed, 100 insertions, 115 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 0529dfd97ebd..e2b2b86ad1cf 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -2,6 +2,7 @@
PORTNAME= powerdns
PORTVERSION= 3.4.4
+PORTREVISION= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
DISTNAME= pdns-${PORTVERSION}
@@ -160,7 +161,7 @@ MODULES+= opendbx
.if ${PORT_OPTIONS:MPOLARSSL}
CONFIGURE_ARGS+= --without-system-polarssl
.else
-LIB_DEPENDS+= libpolarssl.so.8:${PORTSDIR}/security/polarssl13
+LIB_DEPENDS+= libmbedtls.so.9:${PORTSDIR}/security/polarssl13
.endif
post-install:
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index c88110b7a7b4..2479220315bd 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.42.1
+PORTREVISION= 1
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -126,7 +127,7 @@ OPENSSL_LDFLAGS= -L${OPENSSLLIB}
OPENSSL_USE= OPENSSL=yes
POLARSSL_CONFIGURE_OFF= --without-polarssl
POLARSSL_CONFIGURE_ON= --with-polarssl=${LOCALBASE}
-POLARSSL_LIB_DEPENDS= libpolarssl.so.8:${PORTSDIR}/security/polarssl13
+POLARSSL_LIB_DEPENDS= libmbedtls.so.9:${PORTSDIR}/security/polarssl13
PROXY_CONFIGURE_OFF= --disable-proxy
PROXY_CONFIGURE_ON= --enable-proxy
RTMP_CONFIGURE_OFF= --without-librtmp
diff --git a/net/belle-sip/Makefile b/net/belle-sip/Makefile
index 4355dfd07fbc..6a289230a10e 100644
--- a/net/belle-sip/Makefile
+++ b/net/belle-sip/Makefile
@@ -2,6 +2,7 @@
PORTNAME= belle-sip
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= net java
MASTER_SITES= SAVANNAH/linphone/${PORTNAME}/ \
http://www.antlr3.org/download/:source2
@@ -33,7 +34,7 @@ OPTIONS_DEFINE= POLARSSL
OPTIONS_DEFAULT=POLARSSL
POLARSSL_CONFIGURE_ENABLE= tls
-POLARSSL_LIB_DEPENDS= libpolarssl.so.8:${PORTSDIR}/security/polarssl13
+POLARSSL_LIB_DEPENDS= libmbedtls.so.9:${PORTSDIR}/security/polarssl13
post-extract:
@${CP} ${DISTDIR}/antlr-3.4-complete.jar ${WRKDIR}/antlr-complete.jar
diff --git a/net/mediastreamer/Makefile b/net/mediastreamer/Makefile
index 9501906a4348..67dc95ea2ae8 100644
--- a/net/mediastreamer/Makefile
+++ b/net/mediastreamer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mediastreamer
PORTVERSION= 2.11.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= SAVANNAH/linphone/mediastreamer
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libortp.so:${PORTSDIR}/net/ortp \
libsrtp.so:${PORTSDIR}/net/libsrtp \
libbzrtp.so:${PORTSDIR}/security/libbzrtp \
- libpolarssl.so.8:${PORTSDIR}/security/polarssl13
+ libmbedtls.so.9:${PORTSDIR}/security/polarssl13
CONFLICTS_INSTALL= linphone-base-[0-9]*
diff --git a/security/libbzrtp/Makefile b/security/libbzrtp/Makefile
index 988c9a9db602..e464bd59dd90 100644
--- a/security/libbzrtp/Makefile
+++ b/security/libbzrtp/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libbzrtp
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SAVANNAH/linphone/bzrtp
DISTNAME= bzrtp-${DISTVERSION}
@@ -12,7 +13,7 @@ COMMENT= ZRTP support library (RFC 6189)
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libpolarssl.so.8:${PORTSDIR}/security/polarssl13
+LIB_DEPENDS= libmbedtls.so.9:${PORTSDIR}/security/polarssl13
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules --disable-strict \
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index eb86cbaae7da..0f77f624bf03 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openvpn
DISTVERSION= 201516
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= ftp://ftp.secure-computing.net/pub/FreeBSD/ports/openvpn-devel/ \
ftp://ftp2.secure-computing.net/pub/FreeBSD/ports/openvpn-devel/
@@ -48,7 +49,7 @@ PW_SAVE_CONFIGURE_ENABLE= password-save
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPOLARSSL}
-LIB_DEPENDS+= libpolarssl.so.8:${PORTSDIR}/security/polarssl13
+LIB_DEPENDS+= libmbedtls.so.9:${PORTSDIR}/security/polarssl13
CONFIGURE_ARGS+=--with-crypto-library=polarssl
.else
USE_OPENSSL= yes
diff --git a/security/polarssl13/Makefile b/security/polarssl13/Makefile
index f44a714da9e3..30ae70026a1d 100644
--- a/security/polarssl13/Makefile
+++ b/security/polarssl13/Makefile
@@ -1,21 +1,21 @@
# $FreeBSD$
PORTNAME= polarssl
-PORTVERSION= 1.3.10
+PORTVERSION= 1.3.11
DISTVERSIONSUFFIX= -gpl
-#PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= https://polarssl.org/download/
PKGNAMESUFFIX= 13
DISTNAME= mbedtls-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Open Source embedded SSL/TLS cryptographic library
+COMMENT= SSL/TLS and cryptography library
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
ALL_TARGET= no_test
-
+MAKE_ENV= SHARED=1
USES= cpe gmake tar:tgz
USE_LDCONFIG= yes
@@ -23,39 +23,14 @@ WRKSRC= ${WRKDIR}/mbedtls-${PORTVERSION}
CONFLICTS= polarssl-[0-9]*
-DOCFILES= ChangeLog README.rst LICENSE
-BINFILES= aescrypt2 benchmark dh_client dh_genprime dh_server hello \
- md5sum mpi_demo rsa_genkey rsa_sign rsa_verify selftest \
- sha1sum sha2sum ssl_cert_test ssl_client1 ssl_client2 \
- ssl_server ssl_test
-
-# cmake install is broken, so we do it by hand
-do-install:
- @cd ${WRKSRC}/include && ${COPYTREE_SHARE} ${PORTNAME} ${STAGEDIR}${PREFIX}/include "! -name *.orig"
- ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.a ${STAGEDIR}${PREFIX}/lib/
- ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.so ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.8
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.8
- (cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.8 libpolarssl.so)
- (cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.8 libmbedtls.so.8)
- (cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libmbedtls.so.8 libmbedtls.so)
-.for i in ${BINFILES}
- ${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${STAGEDIR}${PREFIX}/bin/polarssl_${i}
-.endfor
-
-OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's/PREFIX/NAMEPREFIX/' \
+ -e 's/$$(DESTDIR)/&$$(PREFIX)/' \
+ ${WRKSRC}/Makefile
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for i in ${DOCFILES}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
-.endfor
-.endif
-
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
+ ${FIND} ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${PREFIX}/lib -type f | \
+ ${XARGS} ${STRIP_CMD}
.include <bsd.port.mk>
diff --git a/security/polarssl13/distinfo b/security/polarssl13/distinfo
index 7d1b12956a09..e02df4b8b26a 100644
--- a/security/polarssl13/distinfo
+++ b/security/polarssl13/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mbedtls-1.3.10-gpl.tgz) = 746fd88e0c6623691fc56c4eed52e40a57b2da0ac80f6dd8995094aa6adb407e
-SIZE (mbedtls-1.3.10-gpl.tgz) = 1709888
+SHA256 (mbedtls-1.3.11-gpl.tgz) = 67a593027b6a442a4fa5b6c224c4ac8cdae5be721f5a28a11d34f10dcda441cb
+SIZE (mbedtls-1.3.11-gpl.tgz) = 1731809
diff --git a/security/polarssl13/files/patch-include-polarssl-config_h b/security/polarssl13/files/patch-include-polarssl-config_h
deleted file mode 100644
index 17dd114141b3..000000000000
--- a/security/polarssl13/files/patch-include-polarssl-config_h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/polarssl/config.h.old 2014-11-28 15:57:37.000000000 +0000
-+++ include/polarssl/config.h 2014-11-28 16:00:32.000000000 +0000
-@@ -1518,7 +1518,7 @@
- *
- * Uncomment to enable the HAVEGE random generator.
- */
--//#define POLARSSL_HAVEGE_C
-+#define POLARSSL_HAVEGE_C
-
- /**
- * \def POLARSSL_HMAC_DRBG_C
diff --git a/security/polarssl13/files/patch-include_polarssl_config.h b/security/polarssl13/files/patch-include_polarssl_config.h
deleted file mode 100644
index 73d2b920205f..000000000000
--- a/security/polarssl13/files/patch-include_polarssl_config.h
+++ /dev/null
@@ -1,9 +0,0 @@
---- include/polarssl/config.h.bak 2014-04-11 22:33:59.000000000 +0900
-+++ include/polarssl/config.h 2014-04-30 17:36:41.000000000 +0900
-@@ -2383,4 +2383,6 @@
- #error "POLARSSL_X509_CSR_WRITE_C defined, but not all prerequisites"
- #endif
-
-+#define SHOW_PROTOTYPE_CHANGE_WARNINGS
-+
- #endif /* config.h */
diff --git a/security/polarssl13/files/patch-library-Makefile b/security/polarssl13/files/patch-library-Makefile
deleted file mode 100644
index 786f97efcbed..000000000000
--- a/security/polarssl13/files/patch-library-Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
---- library/Makefile.orig 2015-02-11 01:00:42.000000000 +0900
-+++ library/Makefile 2015-02-18 12:47:25.000000000 +0900
-@@ -18,9 +18,7 @@
- # CFLAGS += -D_BSD_EXTENSION
-
- # To compile as a shared library:
--ifdef SHARED
- CFLAGS += -fPIC
--endif
-
- SONAME=libmbedtls.so.8
-
-@@ -65,11 +63,7 @@
-
- .SILENT:
-
--ifndef SHARED
--all: static
--else
- all: shared static
--endif
-
- static: libpolarssl.a
-
diff --git a/security/polarssl13/pkg-descr b/security/polarssl13/pkg-descr
index 5016535825c7..8901bb50743e 100644
--- a/security/polarssl13/pkg-descr
+++ b/security/polarssl13/pkg-descr
@@ -1,21 +1,4 @@
-PolarSSL is a light-weight open source cryptographic and SSL/TLS library
-written in C. PolarSSL is written with embedded systems in mind and has
-been ported on a number of architectures, including ARM, PowerPC, MIPS
-and Motorola 68000.
+mbed TLS is a lightweight, portable, fully featured and standards compliant
+SSL/TLS and cryptography library.
-Features include:
- * Small memory footprint
- * Clean and simple API for integration
- * Loose coupling of cryptographic code.
- * Symmetric encryption algorithms: AES, Triple-DES, DES, ARC4, Camellia, XTEA
- * Hash algorithms: MD2, MD4, MD5, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512
- * HAVEGE random number generator
- * RSA with PKCS#1 v1.5 padding
- * SSL version 3 and TLS version 1 client support
- * X.509 certificate and CRL reading from memory or disk in PEM and DER formats
- * Over 900 regression and code coverage tests
- * Example applications
-
-LICENSE: GPL2
-
-WWW: http://polarssl.org/
+WWW: https://tls.mbed.org/
diff --git a/security/polarssl13/pkg-plist b/security/polarssl13/pkg-plist
index 045bc7c4354c..a1787a1441da 100644
--- a/security/polarssl13/pkg-plist
+++ b/security/polarssl13/pkg-plist
@@ -1,22 +1,91 @@
+bin/mbedtls_aescrypt2
+bin/mbedtls_benchmark
+bin/mbedtls_cert_app
+bin/mbedtls_cert_req
+bin/mbedtls_crl_app
+bin/mbedtls_crypt_and_hash
+bin/mbedtls_dh_client
+bin/mbedtls_dh_genprime
+bin/mbedtls_dh_server
+bin/mbedtls_gen_entropy
+bin/mbedtls_gen_key
+bin/mbedtls_gen_random_ctr_drbg
+bin/mbedtls_gen_random_havege
+bin/mbedtls_generic_sum
+bin/mbedtls_hello
+bin/mbedtls_key_app
+bin/mbedtls_key_app_writer
+bin/mbedtls_md5sum
+bin/mbedtls_mini_client
+bin/mbedtls_mpi_demo
+bin/mbedtls_pem2der
+bin/mbedtls_pk_decrypt
+bin/mbedtls_pk_encrypt
+bin/mbedtls_pk_sign
+bin/mbedtls_pk_verify
+bin/mbedtls_rsa_decrypt
+bin/mbedtls_rsa_encrypt
+bin/mbedtls_rsa_genkey
+bin/mbedtls_rsa_sign
+bin/mbedtls_rsa_sign_pss
+bin/mbedtls_rsa_verify
+bin/mbedtls_rsa_verify_pss
+bin/mbedtls_selftest
+bin/mbedtls_sha1sum
+bin/mbedtls_sha2sum
+bin/mbedtls_ssl_cert_test
+bin/mbedtls_ssl_client1
+bin/mbedtls_ssl_client2
+bin/mbedtls_ssl_fork_server
+bin/mbedtls_ssl_mail_client
+bin/mbedtls_ssl_server
+bin/mbedtls_ssl_server2
+bin/mbedtls_ssl_test
+bin/mbedtls_strerror
bin/polarssl_aescrypt2
bin/polarssl_benchmark
+bin/polarssl_cert_app
+bin/polarssl_cert_req
+bin/polarssl_crl_app
+bin/polarssl_crypt_and_hash
bin/polarssl_dh_client
bin/polarssl_dh_genprime
bin/polarssl_dh_server
+bin/polarssl_gen_entropy
+bin/polarssl_gen_key
+bin/polarssl_gen_random_ctr_drbg
+bin/polarssl_gen_random_havege
+bin/polarssl_generic_sum
bin/polarssl_hello
+bin/polarssl_key_app
+bin/polarssl_key_app_writer
bin/polarssl_md5sum
+bin/polarssl_mini_client
bin/polarssl_mpi_demo
+bin/polarssl_pem2der
+bin/polarssl_pk_decrypt
+bin/polarssl_pk_encrypt
+bin/polarssl_pk_sign
+bin/polarssl_pk_verify
+bin/polarssl_rsa_decrypt
+bin/polarssl_rsa_encrypt
bin/polarssl_rsa_genkey
bin/polarssl_rsa_sign
+bin/polarssl_rsa_sign_pss
bin/polarssl_rsa_verify
+bin/polarssl_rsa_verify_pss
bin/polarssl_selftest
bin/polarssl_sha1sum
bin/polarssl_sha2sum
bin/polarssl_ssl_cert_test
bin/polarssl_ssl_client1
bin/polarssl_ssl_client2
+bin/polarssl_ssl_fork_server
+bin/polarssl_ssl_mail_client
bin/polarssl_ssl_server
+bin/polarssl_ssl_server2
bin/polarssl_ssl_test
+bin/polarssl_strerror
include/polarssl/aes.h
include/polarssl/aesni.h
include/polarssl/arc4.h
@@ -82,11 +151,8 @@ include/polarssl/x509_crl.h
include/polarssl/x509_crt.h
include/polarssl/x509_csr.h
include/polarssl/xtea.h
+lib/libmbedtls.a
+lib/libmbedtls.so
+lib/libmbedtls.so.9
lib/libpolarssl.a
lib/libpolarssl.so
-lib/libpolarssl.so.8
-lib/libmbedtls.so
-lib/libmbedtls.so.8
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/README.rst
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE