aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/kde4-baseapps/Makefile10
-rw-r--r--x11/kde4-baseapps/files/pkg-message (renamed from x11/kde4-baseapps/pkg-message)0
-rw-r--r--x11/kde4-runtime/Makefile10
-rw-r--r--x11/kde4-runtime/files/pkg-message (renamed from x11/kde4-runtime/pkg-message)0
-rw-r--r--x11/kde4-workspace/Makefile10
-rw-r--r--x11/kde4-workspace/files/pkg-message (renamed from x11/kde4-workspace/pkg-message)0
-rw-r--r--x11/kdebase3/Makefile10
-rw-r--r--x11/kdebase3/files/pkg-message (renamed from x11/kdebase3/pkg-message)0
-rw-r--r--x11/kdebase4-runtime/Makefile10
-rw-r--r--x11/kdebase4-runtime/files/pkg-message (renamed from x11/kdebase4-runtime/pkg-message)0
-rw-r--r--x11/kdebase4-workspace/Makefile10
-rw-r--r--x11/kdebase4-workspace/files/pkg-message (renamed from x11/kdebase4-workspace/pkg-message)0
-rw-r--r--x11/kdebase4/Makefile10
-rw-r--r--x11/kdebase4/files/pkg-message (renamed from x11/kdebase4/pkg-message)0
14 files changed, 49 insertions, 21 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index 4d2f8252ffa1..5e7be64d5308 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
+PKGMESSAGE= ${WRKDIR}/MESSAGE
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -65,14 +66,17 @@ post-configure:
${REINPLACE_CMD} -e 's/444/644/g' \
${WRKSRC}/kdesktop/init/Templates/Makefile
+post-build:
+ @${CAT} ${FILESDIR}/pkg-message | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGMESSAGE}
+
post-install:
${LOCALBASE}/bin/genkdmconf --no-old --in ${PREFIX}/share/config/kdm/default
${LOCALBASE}/bin/genkdmconf --no-backup --no-old-scripts --in ${PREFIX}/share/config/kdm
${RM} -f ${PREFIX}/share/apps/konsole/linux.desktop
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
- ${CHMOD} g+s ${PREFIX}/bin/ksysguardd
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- | ${SED} -e 's,%%X11BASE%%,${X11BASE},g'
+ ${CHMOD} g+s ${PREFIX}/bin/ksysguard$d
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/x11/kde4-baseapps/pkg-message b/x11/kde4-baseapps/files/pkg-message
index f97e3656f98b..f97e3656f98b 100644
--- a/x11/kde4-baseapps/pkg-message
+++ b/x11/kde4-baseapps/files/pkg-message
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 4d2f8252ffa1..5e7be64d5308 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
+PKGMESSAGE= ${WRKDIR}/MESSAGE
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -65,14 +66,17 @@ post-configure:
${REINPLACE_CMD} -e 's/444/644/g' \
${WRKSRC}/kdesktop/init/Templates/Makefile
+post-build:
+ @${CAT} ${FILESDIR}/pkg-message | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGMESSAGE}
+
post-install:
${LOCALBASE}/bin/genkdmconf --no-old --in ${PREFIX}/share/config/kdm/default
${LOCALBASE}/bin/genkdmconf --no-backup --no-old-scripts --in ${PREFIX}/share/config/kdm
${RM} -f ${PREFIX}/share/apps/konsole/linux.desktop
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
- ${CHMOD} g+s ${PREFIX}/bin/ksysguardd
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- | ${SED} -e 's,%%X11BASE%%,${X11BASE},g'
+ ${CHMOD} g+s ${PREFIX}/bin/ksysguard$d
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/x11/kde4-runtime/pkg-message b/x11/kde4-runtime/files/pkg-message
index f97e3656f98b..f97e3656f98b 100644
--- a/x11/kde4-runtime/pkg-message
+++ b/x11/kde4-runtime/files/pkg-message
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 4d2f8252ffa1..5e7be64d5308 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
+PKGMESSAGE= ${WRKDIR}/MESSAGE
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -65,14 +66,17 @@ post-configure:
${REINPLACE_CMD} -e 's/444/644/g' \
${WRKSRC}/kdesktop/init/Templates/Makefile
+post-build:
+ @${CAT} ${FILESDIR}/pkg-message | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGMESSAGE}
+
post-install:
${LOCALBASE}/bin/genkdmconf --no-old --in ${PREFIX}/share/config/kdm/default
${LOCALBASE}/bin/genkdmconf --no-backup --no-old-scripts --in ${PREFIX}/share/config/kdm
${RM} -f ${PREFIX}/share/apps/konsole/linux.desktop
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
- ${CHMOD} g+s ${PREFIX}/bin/ksysguardd
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- | ${SED} -e 's,%%X11BASE%%,${X11BASE},g'
+ ${CHMOD} g+s ${PREFIX}/bin/ksysguard$d
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/x11/kde4-workspace/pkg-message b/x11/kde4-workspace/files/pkg-message
index f97e3656f98b..f97e3656f98b 100644
--- a/x11/kde4-workspace/pkg-message
+++ b/x11/kde4-workspace/files/pkg-message
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index 4d2f8252ffa1..5e7be64d5308 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
+PKGMESSAGE= ${WRKDIR}/MESSAGE
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -65,14 +66,17 @@ post-configure:
${REINPLACE_CMD} -e 's/444/644/g' \
${WRKSRC}/kdesktop/init/Templates/Makefile
+post-build:
+ @${CAT} ${FILESDIR}/pkg-message | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGMESSAGE}
+
post-install:
${LOCALBASE}/bin/genkdmconf --no-old --in ${PREFIX}/share/config/kdm/default
${LOCALBASE}/bin/genkdmconf --no-backup --no-old-scripts --in ${PREFIX}/share/config/kdm
${RM} -f ${PREFIX}/share/apps/konsole/linux.desktop
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
- ${CHMOD} g+s ${PREFIX}/bin/ksysguardd
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- | ${SED} -e 's,%%X11BASE%%,${X11BASE},g'
+ ${CHMOD} g+s ${PREFIX}/bin/ksysguard$d
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/x11/kdebase3/pkg-message b/x11/kdebase3/files/pkg-message
index f97e3656f98b..f97e3656f98b 100644
--- a/x11/kdebase3/pkg-message
+++ b/x11/kdebase3/files/pkg-message
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index 4d2f8252ffa1..5e7be64d5308 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
+PKGMESSAGE= ${WRKDIR}/MESSAGE
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -65,14 +66,17 @@ post-configure:
${REINPLACE_CMD} -e 's/444/644/g' \
${WRKSRC}/kdesktop/init/Templates/Makefile
+post-build:
+ @${CAT} ${FILESDIR}/pkg-message | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGMESSAGE}
+
post-install:
${LOCALBASE}/bin/genkdmconf --no-old --in ${PREFIX}/share/config/kdm/default
${LOCALBASE}/bin/genkdmconf --no-backup --no-old-scripts --in ${PREFIX}/share/config/kdm
${RM} -f ${PREFIX}/share/apps/konsole/linux.desktop
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
- ${CHMOD} g+s ${PREFIX}/bin/ksysguardd
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- | ${SED} -e 's,%%X11BASE%%,${X11BASE},g'
+ ${CHMOD} g+s ${PREFIX}/bin/ksysguard$d
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/x11/kdebase4-runtime/pkg-message b/x11/kdebase4-runtime/files/pkg-message
index f97e3656f98b..f97e3656f98b 100644
--- a/x11/kdebase4-runtime/pkg-message
+++ b/x11/kdebase4-runtime/files/pkg-message
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index 4d2f8252ffa1..5e7be64d5308 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
+PKGMESSAGE= ${WRKDIR}/MESSAGE
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -65,14 +66,17 @@ post-configure:
${REINPLACE_CMD} -e 's/444/644/g' \
${WRKSRC}/kdesktop/init/Templates/Makefile
+post-build:
+ @${CAT} ${FILESDIR}/pkg-message | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGMESSAGE}
+
post-install:
${LOCALBASE}/bin/genkdmconf --no-old --in ${PREFIX}/share/config/kdm/default
${LOCALBASE}/bin/genkdmconf --no-backup --no-old-scripts --in ${PREFIX}/share/config/kdm
${RM} -f ${PREFIX}/share/apps/konsole/linux.desktop
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
- ${CHMOD} g+s ${PREFIX}/bin/ksysguardd
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- | ${SED} -e 's,%%X11BASE%%,${X11BASE},g'
+ ${CHMOD} g+s ${PREFIX}/bin/ksysguard$d
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/x11/kdebase4-workspace/pkg-message b/x11/kdebase4-workspace/files/pkg-message
index f97e3656f98b..f97e3656f98b 100644
--- a/x11/kdebase4-workspace/pkg-message
+++ b/x11/kdebase4-workspace/files/pkg-message
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 4d2f8252ffa1..5e7be64d5308 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
+PKGMESSAGE= ${WRKDIR}/MESSAGE
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -65,14 +66,17 @@ post-configure:
${REINPLACE_CMD} -e 's/444/644/g' \
${WRKSRC}/kdesktop/init/Templates/Makefile
+post-build:
+ @${CAT} ${FILESDIR}/pkg-message | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGMESSAGE}
+
post-install:
${LOCALBASE}/bin/genkdmconf --no-old --in ${PREFIX}/share/config/kdm/default
${LOCALBASE}/bin/genkdmconf --no-backup --no-old-scripts --in ${PREFIX}/share/config/kdm
${RM} -f ${PREFIX}/share/apps/konsole/linux.desktop
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
- ${CHMOD} g+s ${PREFIX}/bin/ksysguardd
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- | ${SED} -e 's,%%X11BASE%%,${X11BASE},g'
+ ${CHMOD} g+s ${PREFIX}/bin/ksysguard$d
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/x11/kdebase4/pkg-message b/x11/kdebase4/files/pkg-message
index f97e3656f98b..f97e3656f98b 100644
--- a/x11/kdebase4/pkg-message
+++ b/x11/kdebase4/files/pkg-message