aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/gcc8-devel/Makefile2
-rw-r--r--lang/gcc8-devel/distinfo6
-rw-r--r--lang/gcc8-devel/files/patch-clang3.4.1-fixes29
3 files changed, 4 insertions, 33 deletions
diff --git a/lang/gcc8-devel/Makefile b/lang/gcc8-devel/Makefile
index d978ee71e5b6..f6fd40816d0b 100644
--- a/lang/gcc8-devel/Makefile
+++ b/lang/gcc8-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 8.0.0.s20171126
+PORTVERSION= 8.0.0.s20171203
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
diff --git a/lang/gcc8-devel/distinfo b/lang/gcc8-devel/distinfo
index 9a1135c718a7..6745e28478d8 100644
--- a/lang/gcc8-devel/distinfo
+++ b/lang/gcc8-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1511737702
-SHA256 (gcc-8-20171126.tar.xz) = b3fc82c0714f1489119bfbde242221bdd851e105af236da1f15b4a542da98b51
-SIZE (gcc-8-20171126.tar.xz) = 60566772
+TIMESTAMP = 1512367452
+SHA256 (gcc-8-20171203.tar.xz) = c53fc75277fa6730330d8e766d0110a561182c9a0a41f29563fa9065d632e029
+SIZE (gcc-8-20171203.tar.xz) = 60299312
diff --git a/lang/gcc8-devel/files/patch-clang3.4.1-fixes b/lang/gcc8-devel/files/patch-clang3.4.1-fixes
deleted file mode 100644
index e8ff9285ea69..000000000000
--- a/lang/gcc8-devel/files/patch-clang3.4.1-fixes
+++ /dev/null
@@ -1,29 +0,0 @@
---- UTC
-Index: gcc/hash-set.h
-===================================================================
---- gcc/hash-set.h (revision 255155)
-+++ gcc/hash-set.h (working copy)
-@@ -150,7 +150,7 @@
- }
-
- #define DEFINE_DEBUG_HASH_SET(T) \
-- template static void debug_helper (hash_set<T> &); \
-+ template void debug_helper (hash_set<T> &); \
- DEBUG_FUNCTION void \
- debug (hash_set<T> &ref) \
- { \
-Index: gcc/vec.h
-===================================================================
---- gcc/vec.h (revision 255155)
-+++ gcc/vec.h (working copy)
-@@ -453,8 +453,8 @@
- functions for a type T. */
-
- #define DEFINE_DEBUG_VEC(T) \
-- template static void debug_helper (vec<T> &); \
-- template static void debug_helper (vec<T, va_gc> &); \
-+ template void debug_helper (vec<T> &); \
-+ template void debug_helper (vec<T, va_gc> &); \
- /* Define the vec<T> debug functions. */ \
- DEBUG_FUNCTION void \
- debug (vec<T> &ref) \