aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Sockets-devel/Makefile2
-rw-r--r--net/Sockets-devel/files/extra-patch-SocketHandler.h10
-rw-r--r--net/Sockets/Makefile2
-rw-r--r--net/Sockets/files/extra-patch-SocketHandler.h10
4 files changed, 22 insertions, 2 deletions
diff --git a/net/Sockets-devel/Makefile b/net/Sockets-devel/Makefile
index 90887bfab411..d879fa405b5d 100644
--- a/net/Sockets-devel/Makefile
+++ b/net/Sockets-devel/Makefile
@@ -42,7 +42,7 @@ post-patch:
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-SocketHandler.h
.endif
.include <bsd.port.post.mk>
diff --git a/net/Sockets-devel/files/extra-patch-SocketHandler.h b/net/Sockets-devel/files/extra-patch-SocketHandler.h
new file mode 100644
index 000000000000..f1e501090d69
--- /dev/null
+++ b/net/Sockets-devel/files/extra-patch-SocketHandler.h
@@ -0,0 +1,10 @@
+--- SocketHandler.h.orig 2008-11-30 02:37:01.000000000 -0200
++++ SocketHandler.h 2008-11-30 02:37:09.000000000 -0200
+@@ -49,6 +49,7 @@
+ \ingroup basic */
+ class SocketHandler
+ {
++protected:
+ /** Map type for holding file descriptors/socket object pointers. */
+ typedef std::map<SOCKET,Socket *> socket_m;
+
diff --git a/net/Sockets/Makefile b/net/Sockets/Makefile
index f4728f9dc778..c161eb433aab 100644
--- a/net/Sockets/Makefile
+++ b/net/Sockets/Makefile
@@ -36,7 +36,7 @@ post-patch:
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-SocketHandler.h
.endif
.include <bsd.port.post.mk>
diff --git a/net/Sockets/files/extra-patch-SocketHandler.h b/net/Sockets/files/extra-patch-SocketHandler.h
new file mode 100644
index 000000000000..5fe04cf4ecd6
--- /dev/null
+++ b/net/Sockets/files/extra-patch-SocketHandler.h
@@ -0,0 +1,10 @@
+--- SocketHandler.h.orig 2008-11-30 02:32:59.000000000 -0200
++++ SocketHandler.h 2008-11-30 02:33:51.000000000 -0200
+@@ -36,6 +36,7 @@
+
+ class SocketHandler
+ {
++protected:
+ /** Map type for holding file descriptors/socket object pointers. */
+ typedef std::map<SOCKET,Socket *> socket_m;
+