aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/hping/Makefile10
-rw-r--r--net/hping/pkg-plist7
-rw-r--r--security/hping/Makefile10
-rw-r--r--security/hping/pkg-plist7
4 files changed, 14 insertions, 20 deletions
diff --git a/net/hping/Makefile b/net/hping/Makefile
index 3f409de70a71..db529bea3ce0 100644
--- a/net/hping/Makefile
+++ b/net/hping/Makefile
@@ -21,15 +21,19 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --force-libpcap
USE_GMAKE= yes
+PLIST_FILES= sbin/hping
+PORTDOCS= AS-BACKDOOR HPING2-HOWTO.txt HPING2-IS-OPEN \
+ MORE-FUN-WITH-IPID SPOOFED_SCAN.txt
+
MAN8= hping.8
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hping2 ${PREFIX}/sbin/hping
${INSTALL_MAN} ${WRKSRC}/docs/hping2.8 ${PREFIX}/man/man8/hping.8
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/hping
-.for i in AS-BACKDOOR HPING2-HOWTO.txt HPING2-IS-OPEN MORE-FUN-WITH-IPID SPOOFED_SCAN.txt
- ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${PREFIX}/share/doc/hping/
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}/
.endfor
.endif
diff --git a/net/hping/pkg-plist b/net/hping/pkg-plist
deleted file mode 100644
index 53c3a3af705f..000000000000
--- a/net/hping/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-sbin/hping
-%%PORTDOCS%%share/doc/hping/AS-BACKDOOR
-%%PORTDOCS%%share/doc/hping/HPING2-HOWTO.txt
-%%PORTDOCS%%share/doc/hping/HPING2-IS-OPEN
-%%PORTDOCS%%share/doc/hping/MORE-FUN-WITH-IPID
-%%PORTDOCS%%share/doc/hping/SPOOFED_SCAN.txt
-%%PORTDOCS%%@dirrm share/doc/hping
diff --git a/security/hping/Makefile b/security/hping/Makefile
index 3f409de70a71..db529bea3ce0 100644
--- a/security/hping/Makefile
+++ b/security/hping/Makefile
@@ -21,15 +21,19 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --force-libpcap
USE_GMAKE= yes
+PLIST_FILES= sbin/hping
+PORTDOCS= AS-BACKDOOR HPING2-HOWTO.txt HPING2-IS-OPEN \
+ MORE-FUN-WITH-IPID SPOOFED_SCAN.txt
+
MAN8= hping.8
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hping2 ${PREFIX}/sbin/hping
${INSTALL_MAN} ${WRKSRC}/docs/hping2.8 ${PREFIX}/man/man8/hping.8
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/hping
-.for i in AS-BACKDOOR HPING2-HOWTO.txt HPING2-IS-OPEN MORE-FUN-WITH-IPID SPOOFED_SCAN.txt
- ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${PREFIX}/share/doc/hping/
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}/
.endfor
.endif
diff --git a/security/hping/pkg-plist b/security/hping/pkg-plist
deleted file mode 100644
index 53c3a3af705f..000000000000
--- a/security/hping/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-sbin/hping
-%%PORTDOCS%%share/doc/hping/AS-BACKDOOR
-%%PORTDOCS%%share/doc/hping/HPING2-HOWTO.txt
-%%PORTDOCS%%share/doc/hping/HPING2-IS-OPEN
-%%PORTDOCS%%share/doc/hping/MORE-FUN-WITH-IPID
-%%PORTDOCS%%share/doc/hping/SPOOFED_SCAN.txt
-%%PORTDOCS%%@dirrm share/doc/hping
isakmpd?h=gstreamer&id=5483add61ababfc732e7c8456df49c4279831ffc'>fix hardcoded pathijliao2003-01-031-0/+6 * upgrade to 20021118ijliao2003-01-033-8/+17 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-112-2/+1 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-072-1/+2 * Fix build on -current (add LIB_DEPENDS on libgmp4)kris2002-09-091-0/+2 * Apply patch from OpenBSD for out-of-sequence packets.nectar2002-08-202-2/+6 * Add another URL (from Jacques Vidrine) to the FORBIDDEN line.trevor2002-08-201-1/+1