aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/openldap24-client/Makefile12
-rw-r--r--net/openldap24-sasl-client/Makefile12
-rw-r--r--net/openldap24-server/Makefile200
-rw-r--r--net/openldap24-server/distinfo6
-rw-r--r--net/openldap24-server/files/manpages10
-rw-r--r--net/openldap24-server/files/pkg-deinstall.in (renamed from net/openldap24-server/pkg-deinstall)0
-rw-r--r--net/openldap24-server/files/pkg-install.in (renamed from net/openldap24-server/pkg-install)0
-rw-r--r--net/openldap24-server/files/pkg-message.client.in (renamed from net/openldap24-server/pkg-message.client)0
-rw-r--r--net/openldap24-server/files/pkg-message.in (renamed from net/openldap24-server/pkg-message)4
-rw-r--r--net/openldap24-server/files/slapd.sh.in (renamed from net/openldap24-server/files/slapd.sh)0
-rw-r--r--net/openldap24-server/files/slurpd.sh.in (renamed from net/openldap24-server/files/slurpd.sh)0
-rw-r--r--net/openldap24-server/pkg-plist62
-rw-r--r--net/openldap24-server/pkg-plist.client23
13 files changed, 169 insertions, 160 deletions
diff --git a/net/openldap24-client/Makefile b/net/openldap24-client/Makefile
index 7c7cf46a5c9e..e4024a08ff18 100644
--- a/net/openldap24-client/Makefile
+++ b/net/openldap24-client/Makefile
@@ -1,17 +1,13 @@
-# New ports collection makefile for: openldap23-client
-# Date created: 02 May 2005
-# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+# New ports collection makefile for: openldap24-client
+# Date created: 19 May 2006
+# Whom: Xin LI <delphij@FreeBSD.org>
#
# $FreeBSD$
#
-PKGNAMESUFFIX= -client
-
-COMMENT= Open source LDAP client implementation
-
CLIENT_ONLY= yes
WITHOUT_SASL= yes
-MASTERDIR= ${.CURDIR}/../openldap23-server
+MASTERDIR= ${.CURDIR}/../openldap24-server
.include "${MASTERDIR}/Makefile"
diff --git a/net/openldap24-sasl-client/Makefile b/net/openldap24-sasl-client/Makefile
index 9e084695240b..18c63f04190b 100644
--- a/net/openldap24-sasl-client/Makefile
+++ b/net/openldap24-sasl-client/Makefile
@@ -1,17 +1,13 @@
-# New ports collection makefile for: openldap23-sasl-client
-# Date created: 02 May 2005
-# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+# New ports collection makefile for: openldap24-sasl-client
+# Date created: 19 May 2006
+# Whom: Xin LI <delphij@FreeBSD.org>
#
# $FreeBSD$
#
-PKGNAMESUFFIX= -sasl-client
-
-COMMENT= Open source LDAP client implementation with SASL2 support
-
CLIENT_ONLY= yes
WITH_SASL= yes
-MASTERDIR= ${.CURDIR}/../openldap23-server
+MASTERDIR= ${.CURDIR}/../openldap24-server
.include "${MASTERDIR}/Makefile"
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 3d46b36b9008..59dd634d3fe5 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -1,12 +1,12 @@
-# New ports collection makefile for: openldap23-server
-# Date created: 02 May 2005
-# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+# New ports collection makefile for: openldap24-server
+# Date created: 19 May 2006
+# Whom: Xin LI <delphij@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= openldap
-DISTVERSION= 2.3.21
+DISTVERSION= 2.4.2alpha
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -23,35 +23,41 @@ MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.rediris.es/mirror/OpenLDAP/%SUBDIR%/ \
ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/%SUBDIR%/ \
ftp://ftp.plig.org/pub/OpenLDAP/%SUBDIR%/
-MASTER_SITE_SUBDIR= openldap-release
+MASTER_SITE_SUBDIR= openldap-test
PKGNAMESUFFIX?= -server
EXTRACT_SUFX= .tgz
MAINTAINER= delphij@FreeBSD.org
COMMENT?= Open source LDAP server implementation
-UNIQUENAME?= ${PKGNAMEPREFIX}openldap23
+UNIQUENAME?= ${PKGNAMEPREFIX}openldap24
LATEST_LINK?= ${UNIQUENAME}${PKGNAMESUFFIX}
+USE_OPENSSL= yes
-WANT_OPENLDAP_VER?= 23
-.if ${WANT_OPENLDAP_VER} != 23
-BROKEN= "incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}"
+WANT_OPENLDAP_VER?= 24
+.if ${WANT_OPENLDAP_VER} != 24
+BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 2
+PORTREVISION_SERVER= 0
.if !defined(CLIENT_ONLY)
OPTIONS= SASL "With (Cyrus) SASL2 support" on \
+ DNSSRV "With Dnssrv backend" off \
+ PASSWD "With Passwd backend" off \
PERL "With Perl backend" off \
- SHELL "With Shell backend" on \
+ RELAY "With Relay backend" off \
+ SHELL "With Shell backend (disables threading)" off \
ODBC "With SQL backend" off \
+ RLOOKUPS "With reverse lookups of client hostnames" off \
SLP "With SLPv2 (RFC 2608) support" off \
SLAPI "With Netscape SLAPI plugin API" off \
TCP_WRAPPERS "With tcp wrapper support" on \
BDB "With BerkeleyDB support" on \
ACCESSLOG "With In-Directory Access Logging overlay" off \
AUDITLOG "With Audit Logging overlay" off \
+ DDS "Dynamic Directory Services overlay" off \
DENYOP "With Deny Operation overlay" off \
DYNGROUP "With Dynamic Group overlay" off \
DYNLIST "With Dynamic List overlay" off \
@@ -61,61 +67,64 @@ OPTIONS= SASL "With (Cyrus) SASL2 support" on \
REFINT "With Referential Integrity overlay" off \
RETCODE "With Return Code testing overlay" off \
RWM "With Rewrite/Remap overlay" off \
+ SEQMOD "Sequential Modify overlay" off \
SYNCPROV "With Syncrepl Provider overlay" off \
TRANSLUCENT "With Translucent Proxy overlay" off \
UNIQUE "With attribute Uniqueness overlay" off \
VALSORT "With Value Sorting overlay" off \
ACI "With per-object ACIs (experimental)" off \
- DYNAMIC_BACKENDS "Build dynamic backends" on \
- RCORDER "Add rc order for slapd(1)" off
+ DYNACL "With run-time loadable ACLs (experimental)" off \
+ DYNAMIC_BACKENDS "Build dynamic backends" on
.endif
-.include <bsd.port.pre.mk>
-
.if defined(CLIENT_ONLY)
OPENLDAP_PORTREVISION= ${PORTREVISION_CLIENT}
OPENLDAP_PKGFILESUFX= .client
+.else
+OPENLDAP_PORTREVISION= ${PORTREVISION_SERVER}
+OPENLDAP_PKGFILESUFX=
+.endif
+
+.include <bsd.port.pre.mk>
-.if ${PKGNAMESUFFIX} == "-sasl-client"
+.if defined(CLIENT_ONLY)
+.if defined(WITH_SASL)
+PKGNAMESUFFIX= -sasl-client
+COMMENT= Open source LDAP client implementation with SASL2 support
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.* \
- ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[!3].*
-.elif ${PKGNAMESUFFIX} == "-client"
-CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[!3].* \
- ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[!4].*
.else
-BROKEN= "Unknown PKGNAMESUFFIX ${PKGNAMESUFFIX}"
+PKGNAMESUFFIX= -client
+COMMENT= Open source LDAP client implementation
+CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[!4].* \
+ ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
.endif
PORTDOCS= CHANGES drafts rfc
.if defined(USE_OPENLDAP)
-IGNORE= : You have \`USE_OPENLDAP' defined either in your environment or in make(1) arguments
+BROKEN= You have `USE_OPENLDAP' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
.else
-OPENLDAP_PORTREVISION= ${PORTREVISION_SERVER}
-OPENLDAP_PKGFILESUFX=
+USE_OPENLDAP= yes
+WANT_OPENLDAP_VER= 24
.if defined(WITH_SASL) && !defined(WITHOUT_SASL)
-RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.3.so.2:${PORTSDIR}/net/openldap23-sasl-client
+WANT_OPENLDAP_SASL= yes
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.*
.else
-RUN_DEPENDS= ${LOCALBASE}/lib/libldap-2.3.so.2:${PORTSDIR}/net/openldap23-client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
.endif
.endif
-USE_OPENSSL= yes
USE_AUTOTOOLS= libtool:15
DESCR= ${PKGDIR}/pkg-descr${OPENLDAP_PKGFILESUFX}
PLIST= ${PKGDIR}/pkg-plist${OPENLDAP_PKGFILESUFX}
-PKGINSTALL= ${WRKDIR}/pkg-install
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SCHEMATA= corba core cosine dyngroup \
- inetorgperson java misc \
+SCHEMATA= collective corba core cosine duaconf dyngroup \
+ inetorgperson java misc nadf \
nis openldap ppolicy
LDAP_RUN_DIR?= /var/run/openldap
@@ -123,15 +132,10 @@ LOCALSTATEDIR?= /var/db
DATABASEDIR?= ${LOCALSTATEDIR}/openldap-data
SLURPDIR?= ${LOCALSTATEDIR}/openldap-slurp
-PLIST_SUB+= LDAP_RUN_DIR=${LDAP_RUN_DIR} \
+SUB_LIST+= LDAP_RUN_DIR=${LDAP_RUN_DIR} \
DATABASEDIR=${DATABASEDIR} \
SLURPDIR=${SLURPDIR} \
-
-SED_SCRIPT= -e 's,%%PKGNAME%%,${PKGNAME},g' \
- -e 's,%%PREFIX%%,${PREFIX},g' \
- -e 's,%%LDAP_RUN_DIR%%,${LDAP_RUN_DIR},g' \
- -e 's,%%DATABASEDIR%%,${DATABASEDIR},g' \
- -e 's,%%SLURPDIR%%,${SLURPDIR},g'
+ PKGNAME=${PKGNAME}
CONFIGURE_ARGS= --with-threads=posix \
--with-tls=openssl \
@@ -153,13 +157,16 @@ CONFIGURE_ARGS+= --disable-slapd \
--disable-relay \
--disable-glue \
--disable-syncprov
+SUB_FILES+= pkg-message.client
+PKGMESSAGE= ${WRKSRC}/pkg-message.client
INSTALLS_SHLIB= yes
.else
# server specific configuration
-USE_RC_SUBR= yes
+SUB_FILES+= pkg-install pkg-message pkg-deinstall
+USE_RC_SUBR= slapd.sh slurpd.sh
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-Makefile.in
@@ -184,7 +191,6 @@ BACKEND_PLIST= "@comment "
.endif
CONFIGURE_ARGS+= --localstatedir=${LOCALSTATEDIR} \
- --enable-ldbm=${BACKEND_ENABLE} \
--enable-crypt \
--enable-lmpasswd \
--enable-ldap=${BACKEND_ENABLE} \
@@ -203,6 +209,10 @@ CONFIGURE_ARGS+= --enable-accesslog
CONFIGURE_ARGS+= --enable-auditlog
.endif
+.if defined(WITH_DDS)
+CONFIGURE_ARGS+= --enable-dds
+.endif
+
.if defined(WITH_DENYOP)
CONFIGURE_ARGS+= --enable-denyop
.endif
@@ -239,6 +249,10 @@ CONFIGURE_ARGS+= --enable-retcode
CONFIGURE_ARGS+= --enable-rwm
.endif
+.if defined(WITH_SEQMOD)
+CONFIGURE_ARGS+= --enable-seqmod
+.endif
+
.if defined(WITH_SYNCPROV)
CONFIGURE_ARGS+= --enable-syncprov
.else
@@ -261,62 +275,68 @@ CONFIGURE_ARGS+= --enable-valsort
CONFIGURE_ARGS+= --enable-aci
.endif
+.if defined(WITH_DYNACL)
+CONFIGURE_ARGS+= --enable-dynacl
+.endif
+
.if defined(WITHOUT_BDB)
CONFIGURE_ARGS+= --disable-bdb \
- --disable-hdb \
- --enable-ldbm-api=bcompat
+ --disable-hdb
PLIST_SUB+= BACK_BDB="@comment " \
BACK_HDB="@comment "
.else
WITH_BDB_VER?= 43
+USE_BDB= yes
-.if ${WITH_BDB_VER} == 43
+.if ${WITH_BDB_VER} >= 42
CONFIGURE_ARGS+= --enable-bdb=${BACKEND_ENABLE} \
--enable-hdb=${BACKEND_ENABLE}
PLIST_SUB+= BACK_BDB=${BACKEND_PLIST} \
BACK_HDB=${BACKEND_PLIST}
-BDBLIB= db-4.3.0
-.elif ${WITH_BDB_VER} == 42
-CONFIGURE_ARGS+= --enable-bdb=${BACKEND_ENABLE} \
- --enable-hdb=${BACKEND_ENABLE}
-PLIST_SUB+= BACK_BDB=${BACKEND_PLIST} \
- BACK_HDB=${BACKEND_PLIST}
-BDBLIB= db-4.2.2
-.elif ${WITH_BDB_VER} == 41
-CONFIGURE_ARGS+= --disable-bdb \
- --enable-hdb=${BACKEND_ENABLE}
-PLIST_SUB+= BACK_BDB="@comment " \
- BACK_HDB=${BACKEND_PLIST}
-BDBLIB= db41.1
-.elif ${WITH_BDB_VER} == 4
+.elif ${WITH_BDB_VER} >= 4
CONFIGURE_ARGS+= --disable-bdb \
--enable-hdb=${BACKEND_ENABLE}
PLIST_SUB+= BACK_BDB="@comment " \
BACK_HDB=${BACKEND_PLIST}
-BDBLIB= db4.0
.elif ${WITH_BDB_VER} == 3
CONFIGURE_ARGS+= --disable-bdb \
--disable-hdb
PLIST_SUB+= BACK_BDB="@comment " \
BACK_HDB="@comment "
-BDBLIB= db3.3
+.endif
+
+CPPFLAGS+= -I${BDB_INCLUDE_DIR}
+CONFIGURE_SED+= -e 's,ol_DB_LIB=$$,&-l${BDB_LIB_NAME:R},' \
+ -e 's,(ol_cv_lib_db=)yes$$,\1-l${BDB_LIB_NAME:R},'
+.endif
+
+.if defined(WITH_DNSSRV)
+CONFIGURE_ARGS+= --enable-dnssrv=${BACKEND_ENABLE}
+PLIST_SUB+= BACK_DNSSRV=${BACKEND_PLIST}
.else
-IGNORE= : WITH_BDB_VER must be 3, 4, 41, 42 or 43
+PLIST_SUB+= BACK_DNSSRV="@comment "
.endif
-LIB_DEPENDS+= ${BDBLIB}:${PORTSDIR}/databases/db${WITH_BDB_VER}
-CPPFLAGS+= -I${LOCALBASE}/include/db${WITH_BDB_VER}
-CONFIGURE_ARGS+= --enable-ldbm-api=berkeley
-CONFIGURE_SED+= -e 's,ol_DB_LIB=$$,&-l${BDBLIB:R},' \
- -e 's,(ol_cv_lib_db=)yes$$,\1-l${BDBLIB:R},'
+.if defined(WITH_PASSWD)
+CONFIGURE_ARGS+= --enable-passwd=${BACKEND_ENABLE}
+PLIST_SUB+= BACK_PASSWD=${BACKEND_PLIST}
+.else
+PLIST_SUB+= BACK_PASSWD="@comment "
.endif
-.if defined(WITHOUT_SHELL)
-PLIST_SUB+= BACK_SHELL="@comment "
+.if defined(WITH_RELAY)
+CONFIGURE_ARGS+= --enable-relay=${BACKEND_ENABLE}
+PLIST_SUB+= BACK_RELAY=${BACKEND_PLIST}
.else
-CONFIGURE_ARGS+= --enable-shell=${BACKEND_ENABLE}
+PLIST_SUB+= BACK_RELAY="@comment "
+.endif
+
+.if defined(WITH_SHELL)
+CONFIGURE_ARGS+= --without-threads --enable-shell=${BACKEND_ENABLE}
PLIST_SUB+= BACK_SHELL=${BACKEND_PLIST}
+.else
+PLIST_SUB+= BACK_SHELL="@comment "
.endif
.if defined(WITH_PERL)
@@ -341,12 +361,19 @@ LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
.elif ${WITH_ODBC_TYPE:L} == unixodbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
.else
-IGNORE= : WITH_ODBC_TYPE must be iODBC or unixODBC
+BROKEN= choose either iODBC or unixODBC for WITH_ODBC_TYPE
.endif
.else
PLIST_SUB+= BACK_SQL="@comment "
.endif
+.if defined(WITH_RLOOKUPS)
+CONFIGURE_ARGS+= --enable-rlookups
+PLIST_SUB+= RLOOKUPS=""
+.else
+PLIST_SUB+= RLOOKUPS="@comment "
+.endif
+
.if defined(WITH_SLAPI)
CONFIGURE_ARGS+= --enable-slapi
PLIST_SUB+= SLAPI=""
@@ -385,21 +412,19 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
.if defined(CLIENT_ONLY)
.include "${FILESDIR}/manpages"
.else
-.if defined(WITH_RCORDER) && ( defined(DFOSVERSION) || ${OSVERSION} >= 500038 )
-RC_DIR= /
+.if (${OSVERSION} >= 700007 || (${OSVERSION} < 700000 && ${OSVERSION} >= 600101))
RC_SUFX=
-PLIST_SUB+= RCORDER="" RC_DIR=""
.else
-RC_DIR= ${PREFIX}
RC_SUFX= .sh
-PLIST_SUB+= RCORDER="@comment " RC_DIR="%D"
.endif
-SED_SCRIPT+= -e 's,%%RC_SUBR%%,${RC_SUBR},g' \
- -e 's,%%RC_DIR%%,${RC_DIR:S/\/$//},g' \
- -e 's,%%RC_SUFX%%,${RC_SUFX},g'
-PLIST_SUB+= RC_SUFX=${RC_SUFX}
+SUB_LIST+= RC_DIR=${PREFIX} \
+ RC_SUFX=${RC_SUFX} \
+ LDAP_RUN_DIR=${LDAP_RUN_DIR} \
+ DATABASEDIR=${DATABASEDIR}
.endif
+PLIST_SUB+= ${SUB_LIST}
+
post-patch:
@${REINPLACE_CMD} -e 's,%LOCALSTATEDIR%/run/,${LDAP_RUN_DIR}/,g' \
${SED_MODULES} ${WRKSRC}/servers/slapd/slapd.conf
@@ -414,17 +439,6 @@ pre-configure:
${FALSE}; \
fi
-post-build:
-.for script in slapd slurpd
- @${SED} ${SED_SCRIPT} ${FILESDIR}/${script}.sh >${WRKDIR}/${script}.sh
-.endfor
-.for text in pkg-install pkg-message pkg-deinstall
- @if [ -f ${PKGDIR}/${text}${OPENLDAP_PKGFILESUFX} ]; then \
- ${SED} ${SED_SCRIPT} ${PKGDIR}/${text}${OPENLDAP_PKGFILESUFX} \
- >${WRKDIR}/${text}; \
- fi
-.endfor
-
.if !defined(CLIENT_ONLY)
test: build
@cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
@@ -460,12 +474,6 @@ post-install:
done >>${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/etc/openldap/schema 2>/dev/null || true" >>${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/etc/openldap 2>/dev/null || true" >>${TMPPLIST}
- @[ "${RC_DIR:S/\/$//}" = "${PREFIX}" ] || ${ECHO_CMD} "@cwd ${RC_DIR}" >>${TMPPLIST}
-.for script in slapd slurpd
- @${INSTALL_SCRIPT} ${WRKDIR}/${script}.sh ${DESTDIR}${RC_DIR:S/\/$//}/etc/rc.d/${script}${RC_SUFX}
- @${ECHO_CMD} "etc/rc.d/${script}${RC_SUFX}" >>${TMPPLIST}
-.endfor
- @[ "${RC_DIR:S/\/$//}" = "${PREFIX}" ] || ${ECHO_CMD} "@cwd ${PREFIX}" >>${TMPPLIST}
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/net/openldap24-server/distinfo b/net/openldap24-server/distinfo
index 2bddc86361f8..bf46a405da26 100644
--- a/net/openldap24-server/distinfo
+++ b/net/openldap24-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (openldap-2.3.21.tgz) = 37ef142fc05abd088a4bb2d30dc4c679
-SHA256 (openldap-2.3.21.tgz) = 12204e82276036742f4595122ca2c4ca173e7144a449f1d6d4950273c94a0ef5
-SIZE (openldap-2.3.21.tgz) = 3750778
+MD5 (openldap-2.4.2alpha.tgz) = 7033eb6652ee9ea0d64309364a68c001
+SHA256 (openldap-2.4.2alpha.tgz) = da5d6102823d66853f6d16f40cf627bebe253660a1b9d4352887e7380c389c56
+SIZE (openldap-2.4.2alpha.tgz) = 3812376
diff --git a/net/openldap24-server/files/manpages b/net/openldap24-server/files/manpages
index 9c08b2ad84c3..3988e5d8014e 100644
--- a/net/openldap24-server/files/manpages
+++ b/net/openldap24-server/files/manpages
@@ -23,6 +23,7 @@ MAN3+= lber-decode.3 \
ldap_compare.3 \
ldap_delete.3 \
ldap_error.3 \
+ ldap_extended_operation.3 \
ldap_first_attribute.3 \
ldap_first_entry.3 \
ldap_first_message.3 \
@@ -34,6 +35,9 @@ MAN3+= lber-decode.3 \
ldap_open.3 \
ldap_parse_reference.3 \
ldap_parse_result.3 \
+ ldap_parse_sort_control.3 \
+ ldap_parse_vlv_control.3 \
+ ldap_rename.3 \
ldap_result.3 \
ldap_schema.3 \
ldap_search.3 \
@@ -87,6 +91,7 @@ MLINKS+= \
ldap_bind.3 ldap_kerberos_bind_s.3 \
ldap_bind.3 ldap_sasl_bind.3 \
ldap_bind.3 ldap_sasl_bind_s.3 \
+ ldap_bind.3 ldap_set_rebind_proc.3 \
ldap_bind.3 ldap_simple_bind.3 \
ldap_bind.3 ldap_simple_bind_s.3 \
ldap_bind.3 ldap_unbind.3 \
@@ -104,6 +109,7 @@ MLINKS+= \
ldap_error.3 ldap_errlist.3 \
ldap_error.3 ldap_perror.3 \
ldap_error.3 ldap_result2error.3 \
+ ldap_extended_operation.3 ldap_extended_operation_s.3 \
ldap_first_attribute.3 ldap_next_attribute.3 \
ldap_first_entry.3 ldap_count_entries.3 \
ldap_first_entry.3 ldap_next_entry.3 \
@@ -132,8 +138,10 @@ MLINKS+= \
ldap_modrdn.3 ldap_modrdn2_s.3 \
ldap_modrdn.3 ldap_modrdn_s.3 \
ldap_open.3 ldap_init.3 \
+ ldap_open.3 ldap_initialize.3 \
ldap_parse_result.3 ldap_parse_extended_result.3 \
ldap_parse_result.3 ldap_parse_sasl_bind_result.3 \
+ ldap_rename.3 ldap_rename_s.3 \
ldap_result.3 ldap_msgfree.3 \
ldap_result.3 ldap_msgid.3 \
ldap_result.3 ldap_msgtype.3 \
@@ -180,7 +188,6 @@ MAN5+= ldap.conf.5 \
slapd-relay.5 \
slapd-shell.5 \
slapd-sql.5 \
- slapd-tcl.5 \
slapd.access.5 \
slapd.conf.5 \
slapd.plugin.5 \
@@ -188,6 +195,7 @@ MAN5+= ldap.conf.5 \
slapo-accesslog.5 \
slapo-auditlog.5 \
slapo-chain.5 \
+ slapo-dds.5 \
slapo-dynlist.5 \
slapo-lastmod.5 \
slapo-pcache.5 \
diff --git a/net/openldap24-server/pkg-deinstall b/net/openldap24-server/files/pkg-deinstall.in
index 2a5ec1ef8f65..2a5ec1ef8f65 100644
--- a/net/openldap24-server/pkg-deinstall
+++ b/net/openldap24-server/files/pkg-deinstall.in
diff --git a/net/openldap24-server/pkg-install b/net/openldap24-server/files/pkg-install.in
index aa9b0cf46da9..aa9b0cf46da9 100644
--- a/net/openldap24-server/pkg-install
+++ b/net/openldap24-server/files/pkg-install.in
diff --git a/net/openldap24-server/pkg-message.client b/net/openldap24-server/files/pkg-message.client.in
index 92ef70d0f99b..92ef70d0f99b 100644
--- a/net/openldap24-server/pkg-message.client
+++ b/net/openldap24-server/files/pkg-message.client.in
diff --git a/net/openldap24-server/pkg-message b/net/openldap24-server/files/pkg-message.in
index 61f386264246..bdda2435ce87 100644
--- a/net/openldap24-server/pkg-message
+++ b/net/openldap24-server/files/pkg-message.in
@@ -10,7 +10,7 @@ to suit your needs and add the following lines to /etc/rc.conf:
slapd_sockets="/var/run/openldap/ldapi"
Then start the server with
- %%RC_DIR%%/etc/rc.d/slapd%%RC_SUFX%% start
+ %%PREFIX%%/etc/rc.d/slapd%%RC_SUFX%% start
or reboot.
Try `man slapd' and the online manual at
@@ -18,6 +18,6 @@ Try `man slapd' and the online manual at
for more information.
slapd runs under a non-privileged user id (by default `ldap'),
-see %%RC_DIR%%/etc/rc.d/slapd%%RC_SUFX%% for more information.
+see %%PREFIX%%/etc/rc.d/slapd%%RC_SUFX%% for more information.
************************************************************
diff --git a/net/openldap24-server/files/slapd.sh b/net/openldap24-server/files/slapd.sh.in
index a663f674af2c..a663f674af2c 100644
--- a/net/openldap24-server/files/slapd.sh
+++ b/net/openldap24-server/files/slapd.sh.in
diff --git a/net/openldap24-server/files/slurpd.sh b/net/openldap24-server/files/slurpd.sh.in
index ea5e5b0642b6..ea5e5b0642b6 100644
--- a/net/openldap24-server/files/slurpd.sh
+++ b/net/openldap24-server/files/slurpd.sh.in
diff --git a/net/openldap24-server/pkg-plist b/net/openldap24-server/pkg-plist
index 3e3bff42a860..caec3cf746bd 100644
--- a/net/openldap24-server/pkg-plist
+++ b/net/openldap24-server/pkg-plist
@@ -11,47 +11,55 @@ etc/openldap/DB_CONFIG.example
%%SLAPI%%lib/libslapi.a
%%SLAPI%%lib/libslapi.la
%%SLAPI%%lib/libslapi.so
-%%SLAPI%%lib/libslapi-2.3.so
-%%SLAPI%%lib/libslapi-2.3.so.2
+%%SLAPI%%lib/libslapi-2.4.so
+%%SLAPI%%lib/libslapi-2.4.so.1
%%MODULES%%@exec mkdir -p %D/libexec/openldap
-%%BACK_BDB%%libexec/openldap/back_bdb-2.3.so
-%%BACK_BDB%%libexec/openldap/back_bdb-2.3.so.2
+%%BACK_BDB%%libexec/openldap/back_bdb-2.4.so
+%%BACK_BDB%%libexec/openldap/back_bdb-2.4.so.1
%%BACK_BDB%%libexec/openldap/back_bdb.la
%%BACK_BDB%%libexec/openldap/back_bdb.so
-%%BACK_HDB%%libexec/openldap/back_hdb-2.3.so
-%%BACK_HDB%%libexec/openldap/back_hdb-2.3.so.2
+%%BACK_HDB%%libexec/openldap/back_hdb-2.4.so
+%%BACK_HDB%%libexec/openldap/back_hdb-2.4.so.1
%%BACK_HDB%%libexec/openldap/back_hdb.la
%%BACK_HDB%%libexec/openldap/back_hdb.so
-%%BACKEND%%libexec/openldap/back_ldap-2.3.so
-%%BACKEND%%libexec/openldap/back_ldap-2.3.so.2
+%%BACKEND%%libexec/openldap/back_ldap-2.4.so
+%%BACKEND%%libexec/openldap/back_ldap-2.4.so.1
%%BACKEND%%libexec/openldap/back_ldap.la
%%BACKEND%%libexec/openldap/back_ldap.so
-%%BACKEND%%libexec/openldap/back_ldbm-2.3.so
-%%BACKEND%%libexec/openldap/back_ldbm-2.3.so.2
-%%BACKEND%%libexec/openldap/back_ldbm.la
-%%BACKEND%%libexec/openldap/back_ldbm.so
-%%BACKEND%%libexec/openldap/back_meta-2.3.so
-%%BACKEND%%libexec/openldap/back_meta-2.3.so.2
+%%BACKEND%%libexec/openldap/back_meta-2.4.so
+%%BACKEND%%libexec/openldap/back_meta-2.4.so.1
%%BACKEND%%libexec/openldap/back_meta.la
%%BACKEND%%libexec/openldap/back_meta.so
-%%BACKEND%%libexec/openldap/back_monitor-2.3.so
-%%BACKEND%%libexec/openldap/back_monitor-2.3.so.2
+%%BACKEND%%libexec/openldap/back_monitor-2.4.so
+%%BACKEND%%libexec/openldap/back_monitor-2.4.so.1
%%BACKEND%%libexec/openldap/back_monitor.la
%%BACKEND%%libexec/openldap/back_monitor.so
-%%BACKEND%%libexec/openldap/back_null-2.3.so
-%%BACKEND%%libexec/openldap/back_null-2.3.so.2
+%%BACKEND%%libexec/openldap/back_null-2.4.so
+%%BACKEND%%libexec/openldap/back_null-2.4.so.1
%%BACKEND%%libexec/openldap/back_null.la
%%BACKEND%%libexec/openldap/back_null.so
-%%BACK_PERL%%libexec/openldap/back_perl-2.3.so
-%%BACK_PERL%%libexec/openldap/back_perl-2.3.so.2
+%%BACK_DNSSRV%%libexec/openldap/back_dnssrv-2.4.so
+%%BACK_DNSSRV%%libexec/openldap/back_dnssrv-2.4.so.1
+%%BACK_DNSSRV%%libexec/openldap/back_dnssrv.la
+%%BACK_DNSSRV%%libexec/openldap/back_dnssrv.so
+%%BACK_PASSWD%%libexec/openldap/back_passwd-2.4.so
+%%BACK_PASSWD%%libexec/openldap/back_passwd-2.4.so.1
+%%BACK_PASSWD%%libexec/openldap/back_passwd.la
+%%BACK_PASSWD%%libexec/openldap/back_passwd.so
+%%BACK_PERL%%libexec/openldap/back_perl-2.4.so
+%%BACK_PERL%%libexec/openldap/back_perl-2.4.so.1
%%BACK_PERL%%libexec/openldap/back_perl.la
%%BACK_PERL%%libexec/openldap/back_perl.so
-%%BACK_SHELL%%libexec/openldap/back_shell-2.3.so
-%%BACK_SHELL%%libexec/openldap/back_shell-2.3.so.2
+%%BACK_RELAY%%libexec/openldap/back_relay-2.4.so
+%%BACK_RELAY%%libexec/openldap/back_relay-2.4.so.1
+%%BACK_RELAY%%libexec/openldap/back_relay.la
+%%BACK_RELAY%%libexec/openldap/back_relay.so
+%%BACK_SHELL%%libexec/openldap/back_shell-2.4.so
+%%BACK_SHELL%%libexec/openldap/back_shell-2.4.so.1
%%BACK_SHELL%%libexec/openldap/back_shell.la
%%BACK_SHELL%%libexec/openldap/back_shell.so
-%%BACK_SQL%%libexec/openldap/back_sql-2.3.so
-%%BACK_SQL%%libexec/openldap/back_sql-2.3.so.2
+%%BACK_SQL%%libexec/openldap/back_sql-2.4.so
+%%BACK_SQL%%libexec/openldap/back_sql-2.4.so.1
%%BACK_SQL%%libexec/openldap/back_sql.la
%%BACK_SQL%%libexec/openldap/back_sql.so
libexec/slapd
@@ -66,8 +74,8 @@ sbin/slapindex
sbin/slappasswd
sbin/slaptest
@exec mkdir -p %%LDAP_RUN_DIR%%
-@unexec rmdir %%LDAP_RUN_DIR%% 2>/dev/null || true
+@dirrmtry %%LDAP_RUN_DIR%%
@exec mkdir -p %%DATABASEDIR%%
-@unexec rmdir %%DATABASEDIR%% 2>/dev/null || true
+@dirrmtry %%DATABASEDIR%%
@exec mkdir -p %%SLURPDIR%%
-@unexec rmdir %%SLURPDIR%% 2>/dev/null || true
+@dirrmtry %%SLURPDIR%%
diff --git a/net/openldap24-server/pkg-plist.client b/net/openldap24-server/pkg-plist.client
index 1fe93c92531c..21436f5dee50 100644
--- a/net/openldap24-server/pkg-plist.client
+++ b/net/openldap24-server/pkg-plist.client
@@ -2,6 +2,7 @@
bin/ldapadd
bin/ldapcompare
bin/ldapdelete
+bin/ldapexop
bin/ldapmodify
bin/ldapmodrdn
bin/ldappasswd
@@ -19,28 +20,20 @@ include/ldap_features.h
include/ldap_schema.h
include/ldap_utf8.h
include/slapi-plugin.h
-lib/liblber-2.3.so
-lib/liblber-2.3.so.2
+lib/liblber-2.4.so
+lib/liblber-2.4.so.1
lib/liblber.a
lib/liblber.la
lib/liblber.so
-lib/libldap-2.3.so
-lib/libldap-2.3.so.2
+lib/libldap-2.4.so
+lib/libldap-2.4.so.1
lib/libldap.a
lib/libldap.la
lib/libldap.so
-lib/libldap_r-2.3.so
-lib/libldap_r-2.3.so.2
+lib/libldap_r-2.4.so
+lib/libldap_r-2.4.so.1
lib/libldap_r.a
lib/libldap_r.la
lib/libldap_r.so
-@comment share/openldap/ucdata/case.dat
-@comment share/openldap/ucdata/cmbcl.dat
-@comment share/openldap/ucdata/comp.dat
-@comment share/openldap/ucdata/ctype.dat
-@comment share/openldap/ucdata/decomp.dat
-@comment share/openldap/ucdata/kdecomp.dat
-@comment share/openldap/ucdata/num.dat
-@comment @dirrm share/openldap/ucdata
-@comment @dirrm share/openldap
@dirrmtry libexec/openldap
+@dirrmtry etc/openldap