aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/openoffice-1.0-es/Makefile2
-rw-r--r--editors/openoffice-1.0-it/Makefile1
-rw-r--r--editors/openoffice-1.0-se/Makefile1
-rw-r--r--editors/openoffice-1.0/Makefile50
-rw-r--r--editors/openoffice-1.0/distinfo12
-rw-r--r--editors/openoffice-es/Makefile2
-rw-r--r--editors/openoffice-it/Makefile1
-rw-r--r--editors/openoffice-se/Makefile1
-rw-r--r--editors/openoffice.org-1.0/Makefile50
-rw-r--r--editors/openoffice.org-1.0/distinfo12
-rw-r--r--editors/openoffice/Makefile50
-rw-r--r--editors/openoffice/distinfo12
-rw-r--r--french/openoffice-1.0/Makefile1
-rw-r--r--french/openoffice/Makefile1
-rw-r--r--german/openoffice-1.0/Makefile1
-rw-r--r--german/openoffice/Makefile1
-rw-r--r--japanese/openoffice-1.0/Makefile4
-rw-r--r--japanese/openoffice/Makefile4
18 files changed, 150 insertions, 56 deletions
diff --git a/editors/openoffice-1.0-es/Makefile b/editors/openoffice-1.0-es/Makefile
index 92deeef5e9c7..89685af41da4 100644
--- a/editors/openoffice-1.0-es/Makefile
+++ b/editors/openoffice-1.0-es/Makefile
@@ -9,6 +9,8 @@ CATEGORIES= editors
LANG_PKGNAME= es
LANG_EXT= 34
+L10NHELP= helpcontent_${LANG_EXT}_unix.tgz
+
LANG_CONFIGURE_ARG= SPAN
MASTERDIR= ${.CURDIR}/../openoffice
diff --git a/editors/openoffice-1.0-it/Makefile b/editors/openoffice-1.0-it/Makefile
index 458c71b71728..1ada4e02d4c6 100644
--- a/editors/openoffice-1.0-it/Makefile
+++ b/editors/openoffice-1.0-it/Makefile
@@ -9,6 +9,7 @@ CATEGORIES= editors
LANG_PKGNAME= it
LANG_EXT= 39
+L10NHELP= helpcontent_${LANG_EXT}_unix.tgz
LANG_CONFIGURE_ARG= ITAL
MASTERDIR= ${.CURDIR}/../openoffice
diff --git a/editors/openoffice-1.0-se/Makefile b/editors/openoffice-1.0-se/Makefile
index 72cd34ac7e02..90143cf8e6bb 100644
--- a/editors/openoffice-1.0-se/Makefile
+++ b/editors/openoffice-1.0-se/Makefile
@@ -9,6 +9,7 @@ CATEGORIES= editors
LANG_PKGNAME= se
LANG_EXT= 46
+L10NHELP= helpcontent_${LANG_EXT}_unix.tgz
LANG_CONFIGURE_ARG= SWED
MASTERDIR= ${.CURDIR}/../openoffice
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index e54df00c22dd..3675db769315 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -7,13 +7,15 @@
PORTNAME= openoffice
PORTVERSION= 1.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= editors
MASTER_SITES+= http://sf1.mirror.openoffice.org/${PORTVERSION}/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/ \
- http://people.freebsd.org/~mbr/distfiles/ \
- http://dict.progbits.com/
+ http://sf1.mirror.openoffice.org/miscellaneous/helpcontent/
DISTFILES+= OOo_${PORTVERSION}_source.tar.bz2 gpc231.tar.Z
+.if defined(L10NHELP)
+DISTFILES+= ${L10NHELP}
+.endif
SORT?= /usr/bin/sort
CUT?= /usr/bin/cut
@@ -268,9 +270,17 @@ post-extract:
done
@${CP} ${WRKDIR}/gpc231/gpc.c ${WRKSRC}/../external/gpc/
@${CP} ${WRKDIR}/gpc231/gpc.h ${WRKSRC}/../external/gpc/
+ @${MAKE} extract-mozilla
@${RM} ${WRKSRC}/../moz/zipped/*.zip
+.if defined(L10NHELP)
+ @${ECHO_MSG} "===> Extracting L10NHELP sub project"
+ @${MKDIR} ${WRKDIR}/L10NHELP
+ @cd ${WRKDIR}/L10NHELP && \
+ ${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${L10NHELP}
+.endif
post-patch:
+ @${MAKE} patch-mozilla
.if defined(WITH_TTF_BYTECODE_ENABLED)
@if [ "`echo ${PATCHDIR}/optpatch-*`" != "${PATCHDIR}/optpatch-*" ]; then \
${ECHO_MSG} "===> Applying additional TTF bytecode patches for ${PKGNAME}" ; \
@@ -311,10 +321,9 @@ post-patch:
@${FIND} ${WRKSRC}/.. | ${EGREP} "\.(cxx|h|c)$$" | ${XARGS} \
${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g"
-mozilla:
-.if ! exists(${WRKDIR}/FREEBSDGCCIinc.zip)
+extract-mozilla:
.if ! exists(${WRKDIR}/mozilla/Makefile)
- @${ECHO_MSG} "===> Building mozilla sub project"
+ @${ECHO_MSG} "===> Extracting mozilla sub project"
@${MKDIR} ${WRKDIR}/mozilla
@${CP} -r ${PORTSDIR}/www/mozilla/files ${WRKDIR}/mozilla
@${CP} ${PORTSDIR}/www/mozilla/Makefile ${WRKDIR}/mozilla
@@ -323,6 +332,14 @@ mozilla:
@${CP} ${PORTSDIR}/www/mozilla/pkg-descr ${WRKDIR}/mozilla
@${CP} ${PORTSDIR}/www/mozilla/pkg-plist ${WRKDIR}/mozilla
.endif
+ @cd ${WRKDIR}/mozilla && ${MAKE} extract
+
+patch-mozilla:
+ @cd ${WRKDIR}/mozilla && ${MAKE} patch
+
+build-mozilla:
+.if ! exists(${WRKDIR}/FREEBSDGCCIinc.zip)
+ @${ECHO_MSG} "===> Building mozilla sub project"
.if defined(WITH_DEBUG)
@${CP} ${WRKDIR}/mozilla/Makefile ${WRKDIR}/mozilla/Makefile.new
@${SED} -e 's|--disable-debug||' \
@@ -332,12 +349,12 @@ mozilla:
.endif
.if defined(USE_GCC)
.if ${USE_GCC} == 3.1
- cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+ @cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
.else
- cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+ @cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
.endif
.else
- cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
+ @cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
.endif
@${CP} ${FILESDIR}/zipmoz.sh ${WRKDIR}
@${CHMOD} 755 ${WRKDIR}/zipmoz.sh
@@ -347,6 +364,11 @@ mozilla:
@${CP} ${WRKDIR}/FREEBSDGCCIruntime.zip ${WRKSRC}/../moz/zipped/
.endif
+mozilla:
+ @${MAKE} extract-mozilla
+ @${MAKE} patch-mozilla
+ @${MAKE} build-mozilla
+
do-build:
@${MAKE} mozilla
.if exists(${WRKDIR}/.Xvfb.pid)
@@ -361,6 +383,10 @@ do-build:
@sleep 5
.endif
@cd ${WRKSRC}/.. && PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" ./bootstrap
+.if defined(L10NHELP)
+ @${MKDIR} ${WRKSRC}/../solver/641/unxfbsd.pro/pck
+ @${MV} ${WRKDIR}/L10NHELP/*.zip ${WRKSRC}/../solver/641/unxfbsd.pro/pck
+.endif
.if !defined(DISPLAY)
@cd ${WRKSRC}/.. && DISPLAY=${DISPLAYHACK} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${DMAKE}'
@@ -378,8 +404,6 @@ do-build:
pre-install:
@${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/oo_setup.resp \
> ${WRKSRC}/../instsetoo/unxfbsd.pro/${LANG_EXT}/normal/oo_setup.resp
- @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/openoffice-wrapper \
- > ${WRKSRC}/openoffice
do-install:
.if !defined(DISPLAY)
@@ -405,7 +429,9 @@ install-user:
post-install:
@${ECHO_MSG} "===> Add wrapper scripts";
- @${INSTALL_SCRIPT} ${WRKSRC}/openoffice ${PREFIX}/bin/openoffice
+ @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/openoffice-wrapper \
+ > ${WRKDIR}/openoffice
+ @${INSTALL_SCRIPT} ${WRKDIR}/openoffice ${PREFIX}/bin/openoffice
@${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sagenda
@${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-scalc
@${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sdraw
diff --git a/editors/openoffice-1.0/distinfo b/editors/openoffice-1.0/distinfo
index 4cb1020701ed..92575f99c367 100644
--- a/editors/openoffice-1.0/distinfo
+++ b/editors/openoffice-1.0/distinfo
@@ -1,8 +1,8 @@
MD5 (openoffice/OOo_1.0.1_source.tar.bz2) = 34f2ca644b7d70573148c82d64eb6064
MD5 (openoffice/gpc231.tar.Z) = fdb06fdb5a4670b172f9fb738b717be9
-MD5 (openoffice/oo_moz1.0RC3_i386_FreeBSD-4-gcc2.95-system.tar.gz) = ea99811ee477a49bc1617dc9dace866d
-MD5 (openoffice/oo_moz1.0RC3_i386_FreeBSD-5-gcc2.95-ports.tar.gz) = 5364047f750d7fae380bb97887747b39
-MD5 (openoffice/oo_moz1.0RC3_i386_FreeBSD-5-gcc3.1-system.tar.gz) = 9b728c4b030c916050a4ba9665010a09
-MD5 (openoffice/oo_moz_1.0_i386_FreeBSD-4-gcc3.1-debug-ports.tar.gz) = 5cb569692f4371258bed419097989dbc
-MD5 (openoffice/oo_moz_1.0_i386_FreeBSD-4-gcc3.1-ports.tar.gz) = 52eb32f285cc2023887512c20b7e97de
-MD5 (openoffice/oo_moz_1.0_includes.tgz) = 375517c78ff96512d9e1eba6b5fc0e36
+MD5 (openoffice/helpcontent) = 832193e5f8954fea10392b73e8dab8c5
+MD5 (openoffice/helpcontent_33_unix.tgz) = 20dcbf3211c20afb27fc5677ab8f69e5
+MD5 (openoffice/helpcontent_34_unix.tgz) = ba6adc71dc5cb766dd75f5b13a7c6bc8
+MD5 (openoffice/helpcontent_39_unix.tgz) = 4c33e3f9f8a64be68c63f33ff1e0e4a7
+MD5 (openoffice/helpcontent_46_unix.tgz) = 5183879d8b57850d433351cb8a5634a8
+MD5 (openoffice/helpcontent_49_unix.tgz) = 68f0db91bb091065a4795d47d6ae0b0b
diff --git a/editors/openoffice-es/Makefile b/editors/openoffice-es/Makefile
index 92deeef5e9c7..89685af41da4 100644
--- a/editors/openoffice-es/Makefile
+++ b/editors/openoffice-es/Makefile
@@ -9,6 +9,8 @@ CATEGORIES= editors
LANG_PKGNAME= es
LANG_EXT= 34
+L10NHELP= helpcontent_${LANG_EXT}_unix.tgz
+
LANG_CONFIGURE_ARG= SPAN
MASTERDIR= ${.CURDIR}/../openoffice
diff --git a/editors/openoffice-it/Makefile b/editors/openoffice-it/Makefile
index 458c71b71728..1ada4e02d4c6 100644
--- a/editors/openoffice-it/Makefile
+++ b/editors/openoffice-it/Makefile
@@ -9,6 +9,7 @@ CATEGORIES= editors
LANG_PKGNAME= it
LANG_EXT= 39
+L10NHELP= helpcontent_${LANG_EXT}_unix.tgz
LANG_CONFIGURE_ARG= ITAL
MASTERDIR= ${.CURDIR}/../openoffice
diff --git a/editors/openoffice-se/Makefile b/editors/openoffice-se/Makefile
index 72cd34ac7e02..90143cf8e6bb 100644
--- a/editors/openoffice-se/Makefile
+++ b/editors/openoffice-se/Makefile
@@ -9,6 +9,7 @@ CATEGORIES= editors
LANG_PKGNAME= se
LANG_EXT= 46
+L10NHELP= helpcontent_${LANG_EXT}_unix.tgz
LANG_CONFIGURE_ARG= SWED
MASTERDIR= ${.CURDIR}/../openoffice
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index e54df00c22dd..3675db769315 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -7,13 +7,15 @@
PORTNAME= openoffice
PORTVERSION= 1.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= editors
MASTER_SITES+= http://sf1.mirror.openoffice.org/${PORTVERSION}/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/ \
- http://people.freebsd.org/~mbr/distfiles/ \
- http://dict.progbits.com/
+ http://sf1.mirror.openoffice.org/miscellaneous/helpcontent/
DISTFILES+= OOo_${PORTVERSION}_source.tar.bz2 gpc231.tar.Z
+.if defined(L10NHELP)
+DISTFILES+= ${L10NHELP}
+.endif
SORT?= /usr/bin/sort
CUT?= /usr/bin/cut
@@ -268,9 +270,17 @@ post-extract:
done
@${CP} ${WRKDIR}/gpc231/gpc.c ${WRKSRC}/../external/gpc/
@${CP} ${WRKDIR}/gpc231/gpc.h ${WRKSRC}/../external/gpc/
+ @${MAKE} extract-mozilla
@${RM} ${WRKSRC}/../moz/zipped/*.zip
+.if defined(L10NHELP)
+ @${ECHO_MSG} "===> Extracting L10NHELP sub project"
+ @${MKDIR} ${WRKDIR}/L10NHELP
+ @cd ${WRKDIR}/L10NHELP && \
+ ${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${L10NHELP}
+.endif
post-patch:
+ @${MAKE} patch-mozilla
.if defined(WITH_TTF_BYTECODE_ENABLED)
@if [ "`echo ${PATCHDIR}/optpatch-*`" != "${PATCHDIR}/optpatch-*" ]; then \
${ECHO_MSG} "===> Applying additional TTF bytecode patches for ${PKGNAME}" ; \
@@ -311,10 +321,9 @@ post-patch:
@${FIND} ${WRKSRC}/.. | ${EGREP} "\.(cxx|h|c)$$" | ${XARGS} \
${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g"
-mozilla:
-.if ! exists(${WRKDIR}/FREEBSDGCCIinc.zip)
+extract-mozilla:
.if ! exists(${WRKDIR}/mozilla/Makefile)
- @${ECHO_MSG} "===> Building mozilla sub project"
+ @${ECHO_MSG} "===> Extracting mozilla sub project"
@${MKDIR} ${WRKDIR}/mozilla
@${CP} -r ${PORTSDIR}/www/mozilla/files ${WRKDIR}/mozilla
@${CP} ${PORTSDIR}/www/mozilla/Makefile ${WRKDIR}/mozilla
@@ -323,6 +332,14 @@ mozilla:
@${CP} ${PORTSDIR}/www/mozilla/pkg-descr ${WRKDIR}/mozilla
@${CP} ${PORTSDIR}/www/mozilla/pkg-plist ${WRKDIR}/mozilla
.endif
+ @cd ${WRKDIR}/mozilla && ${MAKE} extract
+
+patch-mozilla:
+ @cd ${WRKDIR}/mozilla && ${MAKE} patch
+
+build-mozilla:
+.if ! exists(${WRKDIR}/FREEBSDGCCIinc.zip)
+ @${ECHO_MSG} "===> Building mozilla sub project"
.if defined(WITH_DEBUG)
@${CP} ${WRKDIR}/mozilla/Makefile ${WRKDIR}/mozilla/Makefile.new
@${SED} -e 's|--disable-debug||' \
@@ -332,12 +349,12 @@ mozilla:
.endif
.if defined(USE_GCC)
.if ${USE_GCC} == 3.1
- cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+ @cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
.else
- cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+ @cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
.endif
.else
- cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
+ @cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
.endif
@${CP} ${FILESDIR}/zipmoz.sh ${WRKDIR}
@${CHMOD} 755 ${WRKDIR}/zipmoz.sh
@@ -347,6 +364,11 @@ mozilla:
@${CP} ${WRKDIR}/FREEBSDGCCIruntime.zip ${WRKSRC}/../moz/zipped/
.endif
+mozilla:
+ @${MAKE} extract-mozilla
+ @${MAKE} patch-mozilla
+ @${MAKE} build-mozilla
+
do-build:
@${MAKE} mozilla
.if exists(${WRKDIR}/.Xvfb.pid)
@@ -361,6 +383,10 @@ do-build:
@sleep 5
.endif
@cd ${WRKSRC}/.. && PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" ./bootstrap
+.if defined(L10NHELP)
+ @${MKDIR} ${WRKSRC}/../solver/641/unxfbsd.pro/pck
+ @${MV} ${WRKDIR}/L10NHELP/*.zip ${WRKSRC}/../solver/641/unxfbsd.pro/pck
+.endif
.if !defined(DISPLAY)
@cd ${WRKSRC}/.. && DISPLAY=${DISPLAYHACK} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${DMAKE}'
@@ -378,8 +404,6 @@ do-build:
pre-install:
@${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/oo_setup.resp \
> ${WRKSRC}/../instsetoo/unxfbsd.pro/${LANG_EXT}/normal/oo_setup.resp
- @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/openoffice-wrapper \
- > ${WRKSRC}/openoffice
do-install:
.if !defined(DISPLAY)
@@ -405,7 +429,9 @@ install-user:
post-install:
@${ECHO_MSG} "===> Add wrapper scripts";
- @${INSTALL_SCRIPT} ${WRKSRC}/openoffice ${PREFIX}/bin/openoffice
+ @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/openoffice-wrapper \
+ > ${WRKDIR}/openoffice
+ @${INSTALL_SCRIPT} ${WRKDIR}/openoffice ${PREFIX}/bin/openoffice
@${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sagenda
@${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-scalc
@${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sdraw
diff --git a/editors/openoffice.org-1.0/distinfo b/editors/openoffice.org-1.0/distinfo
index 4cb1020701ed..92575f99c367 100644
--- a/editors/openoffice.org-1.0/distinfo
+++ b/editors/openoffice.org-1.0/distinfo
@@ -1,8 +1,8 @@
MD5 (openoffice/OOo_1.0.1_source.tar.bz2) = 34f2ca644b7d70573148c82d64eb6064
MD5 (openoffice/gpc231.tar.Z) = fdb06fdb5a4670b172f9fb738b717be9
-MD5 (openoffice/oo_moz1.0RC3_i386_FreeBSD-4-gcc2.95-system.tar.gz) = ea99811ee477a49bc1617dc9dace866d
-MD5 (openoffice/oo_moz1.0RC3_i386_FreeBSD-5-gcc2.95-ports.tar.gz) = 5364047f750d7fae380bb97887747b39
-MD5 (openoffice/oo_moz1.0RC3_i386_FreeBSD-5-gcc3.1-system.tar.gz) = 9b728c4b030c916050a4ba9665010a09
-MD5 (openoffice/oo_moz_1.0_i386_FreeBSD-4-gcc3.1-debug-ports.tar.gz) = 5cb569692f4371258bed419097989dbc
-MD5 (openoffice/oo_moz_1.0_i386_FreeBSD-4-gcc3.1-ports.tar.gz) = 52eb32f285cc2023887512c20b7e97de
-MD5 (openoffice/oo_moz_1.0_includes.tgz) = 375517c78ff96512d9e1eba6b5fc0e36
+MD5 (openoffice/helpcontent) = 832193e5f8954fea10392b73e8dab8c5
+MD5 (openoffice/helpcontent_33_unix.tgz) = 20dcbf3211c20afb27fc5677ab8f69e5
+MD5 (openoffice/helpcontent_34_unix.tgz) = ba6adc71dc5cb766dd75f5b13a7c6bc8
+MD5 (openoffice/helpcontent_39_unix.tgz) = 4c33e3f9f8a64be68c63f33ff1e0e4a7
+MD5 (openoffice/helpcontent_46_unix.tgz) = 5183879d8b57850d433351cb8a5634a8
+MD5 (openoffice/helpcontent_49_unix.tgz) = 68f0db91bb091065a4795d47d6ae0b0b
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index e54df00c22dd..3675db769315 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -7,13 +7,15 @@
PORTNAME= openoffice
PORTVERSION= 1.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= editors
MASTER_SITES+= http://sf1.mirror.openoffice.org/${PORTVERSION}/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/ \
- http://people.freebsd.org/~mbr/distfiles/ \
- http://dict.progbits.com/
+ http://sf1.mirror.openoffice.org/miscellaneous/helpcontent/
DISTFILES+= OOo_${PORTVERSION}_source.tar.bz2 gpc231.tar.Z
+.if defined(L10NHELP)
+DISTFILES+= ${L10NHELP}
+.endif
SORT?= /usr/bin/sort
CUT?= /usr/bin/cut
@@ -268,9 +270,17 @@ post-extract:
done
@${CP} ${WRKDIR}/gpc231/gpc.c ${WRKSRC}/../external/gpc/
@${CP} ${WRKDIR}/gpc231/gpc.h ${WRKSRC}/../external/gpc/
+ @${MAKE} extract-mozilla
@${RM} ${WRKSRC}/../moz/zipped/*.zip
+.if defined(L10NHELP)
+ @${ECHO_MSG} "===> Extracting L10NHELP sub project"
+ @${MKDIR} ${WRKDIR}/L10NHELP
+ @cd ${WRKDIR}/L10NHELP && \
+ ${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${L10NHELP}
+.endif
post-patch:
+ @${MAKE} patch-mozilla
.if defined(WITH_TTF_BYTECODE_ENABLED)
@if [ "`echo ${PATCHDIR}/optpatch-*`" != "${PATCHDIR}/optpatch-*" ]; then \
${ECHO_MSG} "===> Applying additional TTF bytecode patches for ${PKGNAME}" ; \
@@ -311,10 +321,9 @@ post-patch:
@${FIND} ${WRKSRC}/.. | ${EGREP} "\.(cxx|h|c)$$" | ${XARGS} \
${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g"
-mozilla:
-.if ! exists(${WRKDIR}/FREEBSDGCCIinc.zip)
+extract-mozilla:
.if ! exists(${WRKDIR}/mozilla/Makefile)
- @${ECHO_MSG} "===> Building mozilla sub project"
+ @${ECHO_MSG} "===> Extracting mozilla sub project"
@${MKDIR} ${WRKDIR}/mozilla
@${CP} -r ${PORTSDIR}/www/mozilla/files ${WRKDIR}/mozilla
@${CP} ${PORTSDIR}/www/mozilla/Makefile ${WRKDIR}/mozilla
@@ -323,6 +332,14 @@ mozilla:
@${CP} ${PORTSDIR}/www/mozilla/pkg-descr ${WRKDIR}/mozilla
@${CP} ${PORTSDIR}/www/mozilla/pkg-plist ${WRKDIR}/mozilla
.endif
+ @cd ${WRKDIR}/mozilla && ${MAKE} extract
+
+patch-mozilla:
+ @cd ${WRKDIR}/mozilla && ${MAKE} patch
+
+build-mozilla:
+.if ! exists(${WRKDIR}/FREEBSDGCCIinc.zip)
+ @${ECHO_MSG} "===> Building mozilla sub project"
.if defined(WITH_DEBUG)
@${CP} ${WRKDIR}/mozilla/Makefile ${WRKDIR}/mozilla/Makefile.new
@${SED} -e 's|--disable-debug||' \
@@ -332,12 +349,12 @@ mozilla:
.endif
.if defined(USE_GCC)
.if ${USE_GCC} == 3.1
- cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+ @cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
.else
- cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+ @cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
.endif
.else
- cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
+ @cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
.endif
@${CP} ${FILESDIR}/zipmoz.sh ${WRKDIR}
@${CHMOD} 755 ${WRKDIR}/zipmoz.sh
@@ -347,6 +364,11 @@ mozilla:
@${CP} ${WRKDIR}/FREEBSDGCCIruntime.zip ${WRKSRC}/../moz/zipped/
.endif
+mozilla:
+ @${MAKE} extract-mozilla
+ @${MAKE} patch-mozilla
+ @${MAKE} build-mozilla
+
do-build:
@${MAKE} mozilla
.if exists(${WRKDIR}/.Xvfb.pid)
@@ -361,6 +383,10 @@ do-build:
@sleep 5
.endif
@cd ${WRKSRC}/.. && PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" ./bootstrap
+.if defined(L10NHELP)
+ @${MKDIR} ${WRKSRC}/../solver/641/unxfbsd.pro/pck
+ @${MV} ${WRKDIR}/L10NHELP/*.zip ${WRKSRC}/../solver/641/unxfbsd.pro/pck
+.endif
.if !defined(DISPLAY)
@cd ${WRKSRC}/.. && DISPLAY=${DISPLAYHACK} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
tcsh -c 'source FreeBSDEnv.Set && unsetenv TOP && ${DMAKE}'
@@ -378,8 +404,6 @@ do-build:
pre-install:
@${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/oo_setup.resp \
> ${WRKSRC}/../instsetoo/unxfbsd.pro/${LANG_EXT}/normal/oo_setup.resp
- @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/openoffice-wrapper \
- > ${WRKSRC}/openoffice
do-install:
.if !defined(DISPLAY)
@@ -405,7 +429,9 @@ install-user:
post-install:
@${ECHO_MSG} "===> Add wrapper scripts";
- @${INSTALL_SCRIPT} ${WRKSRC}/openoffice ${PREFIX}/bin/openoffice
+ @${SED} -e 's#%%PREFIX%%#${PREFIX}#g' < ${FILESDIR}/openoffice-wrapper \
+ > ${WRKDIR}/openoffice
+ @${INSTALL_SCRIPT} ${WRKDIR}/openoffice ${PREFIX}/bin/openoffice
@${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sagenda
@${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-scalc
@${LN} -fs ${PREFIX}/bin/openoffice ${PREFIX}/bin/openoffice-sdraw
diff --git a/editors/openoffice/distinfo b/editors/openoffice/distinfo
index 4cb1020701ed..92575f99c367 100644
--- a/editors/openoffice/distinfo
+++ b/editors/openoffice/distinfo
@@ -1,8 +1,8 @@
MD5 (openoffice/OOo_1.0.1_source.tar.bz2) = 34f2ca644b7d70573148c82d64eb6064
MD5 (openoffice/gpc231.tar.Z) = fdb06fdb5a4670b172f9fb738b717be9
-MD5 (openoffice/oo_moz1.0RC3_i386_FreeBSD-4-gcc2.95-system.tar.gz) = ea99811ee477a49bc1617dc9dace866d
-MD5 (openoffice/oo_moz1.0RC3_i386_FreeBSD-5-gcc2.95-ports.tar.gz) = 5364047f750d7fae380bb97887747b39
-MD5 (openoffice/oo_moz1.0RC3_i386_FreeBSD-5-gcc3.1-system.tar.gz) = 9b728c4b030c916050a4ba9665010a09
-MD5 (openoffice/oo_moz_1.0_i386_FreeBSD-4-gcc3.1-debug-ports.tar.gz) = 5cb569692f4371258bed419097989dbc
-MD5 (openoffice/oo_moz_1.0_i386_FreeBSD-4-gcc3.1-ports.tar.gz) = 52eb32f285cc2023887512c20b7e97de
-MD5 (openoffice/oo_moz_1.0_includes.tgz) = 375517c78ff96512d9e1eba6b5fc0e36
+MD5 (openoffice/helpcontent) = 832193e5f8954fea10392b73e8dab8c5
+MD5 (openoffice/helpcontent_33_unix.tgz) = 20dcbf3211c20afb27fc5677ab8f69e5
+MD5 (openoffice/helpcontent_34_unix.tgz) = ba6adc71dc5cb766dd75f5b13a7c6bc8
+MD5 (openoffice/helpcontent_39_unix.tgz) = 4c33e3f9f8a64be68c63f33ff1e0e4a7
+MD5 (openoffice/helpcontent_46_unix.tgz) = 5183879d8b57850d433351cb8a5634a8
+MD5 (openoffice/helpcontent_49_unix.tgz) = 68f0db91bb091065a4795d47d6ae0b0b
diff --git a/french/openoffice-1.0/Makefile b/french/openoffice-1.0/Makefile
index 544ffdd04ae4..4377f2ea99fb 100644
--- a/french/openoffice-1.0/Makefile
+++ b/french/openoffice-1.0/Makefile
@@ -9,6 +9,7 @@ CATEGORIES= french editors
LANG_PKGNAME= fr
LANG_EXT= 33
+L10NHELP= helpcontent_${LANG_EXT}_unix.tgz
LANG_CONFIGURE_ARG= FREN
MASTERDIR= ${.CURDIR}/../../editors/openoffice
diff --git a/french/openoffice/Makefile b/french/openoffice/Makefile
index 544ffdd04ae4..4377f2ea99fb 100644
--- a/french/openoffice/Makefile
+++ b/french/openoffice/Makefile
@@ -9,6 +9,7 @@ CATEGORIES= french editors
LANG_PKGNAME= fr
LANG_EXT= 33
+L10NHELP= helpcontent_${LANG_EXT}_unix.tgz
LANG_CONFIGURE_ARG= FREN
MASTERDIR= ${.CURDIR}/../../editors/openoffice
diff --git a/german/openoffice-1.0/Makefile b/german/openoffice-1.0/Makefile
index 111070b07445..da37dd3a1115 100644
--- a/german/openoffice-1.0/Makefile
+++ b/german/openoffice-1.0/Makefile
@@ -9,6 +9,7 @@ CATEGORIES= german editors
LANG_PKGNAME= de
LANG_EXT= 49
+L10NHELP= helpcontent_${LANG_EXT}_unix.tgz
#
# Special case. We do not need LANG_CONFIGURE_ARG cause
# the EN_US and DE_DE versions are always built.
diff --git a/german/openoffice/Makefile b/german/openoffice/Makefile
index 111070b07445..da37dd3a1115 100644
--- a/german/openoffice/Makefile
+++ b/german/openoffice/Makefile
@@ -9,6 +9,7 @@ CATEGORIES= german editors
LANG_PKGNAME= de
LANG_EXT= 49
+L10NHELP= helpcontent_${LANG_EXT}_unix.tgz
#
# Special case. We do not need LANG_CONFIGURE_ARG cause
# the EN_US and DE_DE versions are always built.
diff --git a/japanese/openoffice-1.0/Makefile b/japanese/openoffice-1.0/Makefile
index 0cfb6846d5be..bffa5b188cbe 100644
--- a/japanese/openoffice-1.0/Makefile
+++ b/japanese/openoffice-1.0/Makefile
@@ -12,5 +12,7 @@ LANG_EXT= 81
LANG_CONFIGURE_ARG= JAPN
MASTERDIR= ${.CURDIR}/../../editors/openoffice
RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/TrueType/kochi-mincho.ttf:${PORTSDIR}/japanese/kochi-ttfonts
-
+MASTER_SITES+= ftp://ftp.kddlabs.co.jp/office/openoffice/ \
+ ftp://ftp.sfc.wide.ad.jp/pub/OpenOffice/
+L10NHELP= helpcontent
.include "${MASTERDIR}/Makefile"
diff --git a/japanese/openoffice/Makefile b/japanese/openoffice/Makefile
index 0cfb6846d5be..bffa5b188cbe 100644
--- a/japanese/openoffice/Makefile
+++ b/japanese/openoffice/Makefile
@@ -12,5 +12,7 @@ LANG_EXT= 81
LANG_CONFIGURE_ARG= JAPN
MASTERDIR= ${.CURDIR}/../../editors/openoffice
RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/TrueType/kochi-mincho.ttf:${PORTSDIR}/japanese/kochi-ttfonts
-
+MASTER_SITES+= ftp://ftp.kddlabs.co.jp/office/openoffice/ \
+ ftp://ftp.sfc.wide.ad.jp/pub/OpenOffice/
+L10NHELP= helpcontent
.include "${MASTERDIR}/Makefile"