aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cvs/Makefile23
-rw-r--r--devel/cvs/distinfo2
-rw-r--r--devel/cvs/files/patch-config.h.in32
-rw-r--r--devel/cvs/files/patch-configure43
-rw-r--r--devel/cvs/files/patch-configure.in26
-rw-r--r--devel/cvs/pkg-descr2
-rw-r--r--devel/cvs/pkg-plist23
8 files changed, 152 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 32445bcfeee2..fcf62a8d854c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -259,6 +259,7 @@
SUBDIR += cut
SUBDIR += cutils
SUBDIR += cutter
+ SUBDIR += cvs
SUBDIR += cvs+ipv6
SUBDIR += cvs-devel
SUBDIR += cvs-syncmail
diff --git a/devel/cvs/Makefile b/devel/cvs/Makefile
new file mode 100644
index 000000000000..30067269cba4
--- /dev/null
+++ b/devel/cvs/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= cvs
+PORTVERSION= 1.11.23
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= non-gnu/${PORTNAME}/source/stable/${PORTVERSION}
+
+MAINTAINER= eadler@FreeBSD.org
+COMMENT= Version control system
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+MAN1= cvs.1
+MAN5= cvs.5
+MAN8= cvsbug.8
+
+INFO= cvs cvsclient
+
+.include <bsd.port.mk>
diff --git a/devel/cvs/distinfo b/devel/cvs/distinfo
new file mode 100644
index 000000000000..00e66e7e3415
--- /dev/null
+++ b/devel/cvs/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cvs-1.11.23.tar.gz) = 0ad692e3c22e4b33274a53ad22a194deb3024ec833b9e87ad7968d9b0b58cdcf
+SIZE (cvs-1.11.23.tar.gz) = 3512175
diff --git a/devel/cvs/files/patch-config.h.in b/devel/cvs/files/patch-config.h.in
new file mode 100644
index 000000000000..a253524f8b02
--- /dev/null
+++ b/devel/cvs/files/patch-config.h.in
@@ -0,0 +1,32 @@
+--- ./config.h.in.orig 2008-05-07 16:13:06.000000000 -0400
++++ ./config.h.in 2012-09-04 22:07:00.000000000 -0400
+@@ -121,9 +121,6 @@
+ /* Define to 1 if you have the `getpagesize' function. */
+ #undef HAVE_GETPAGESIZE
+
+-/* Define to 1 if you have the `getpid' function. */
+-#undef HAVE_GETPID
+-
+ /* Define if you have the getspnam function. */
+ #undef HAVE_GETSPNAM
+
+@@ -214,9 +211,6 @@
+ /* Define to 1 if you have the <ndir.h> header file, and it defines `DIR'. */
+ #undef HAVE_NDIR_H
+
+-/* Define to 1 if you have the <process.h> header file. */
+-#undef HAVE_PROCESS_H
+-
+ /* Define to 1 if you have the `putenv' function. */
+ #undef HAVE_PUTENV
+
+@@ -327,9 +321,6 @@
+ /* Define to 1 if you have the <sys/types.h> header file. */
+ #undef HAVE_SYS_TYPES_H
+
+-/* Define to 1 if you have the <sys/utime.h> header file. */
+-#undef HAVE_SYS_UTIME_H
+-
+ /* Define to 1 if you have <sys/wait.h> that is POSIX.1 compatible. */
+ #undef HAVE_SYS_WAIT_H
+
diff --git a/devel/cvs/files/patch-configure b/devel/cvs/files/patch-configure
new file mode 100644
index 000000000000..694a19d05b5c
--- /dev/null
+++ b/devel/cvs/files/patch-configure
@@ -0,0 +1,43 @@
+--- ./configure.orig 2008-05-07 16:12:30.000000000 -0400
++++ ./configure 2012-09-04 22:07:00.000000000 -0400
+@@ -5642,8 +5642,6 @@
+
+
+
+-
+-
+ for ac_header in \
+ errno.h \
+ direct.h \
+@@ -5653,7 +5651,6 @@
+ limits.h \
+ memory.h \
+ ndbm.h \
+- process.h \
+ string.h \
+ syslog.h \
+ sys/bsdtypes.h \
+@@ -5663,7 +5660,6 @@
+ sys/select.h \
+ sys/time.h \
+ sys/timeb.h \
+- sys/utime.h \
+ unistd.h \
+ utime.h\
+
+@@ -8090,7 +8086,6 @@
+
+
+
+-
+ for ac_func in \
+ fchdir \
+ fchmod \
+@@ -8100,7 +8095,6 @@
+ getgroups \
+ getopt \
+ getpagesize \
+- getpid \
+ gettimeofday \
+ initgroups \
+ login \
diff --git a/devel/cvs/files/patch-configure.in b/devel/cvs/files/patch-configure.in
new file mode 100644
index 000000000000..df12cd412e06
--- /dev/null
+++ b/devel/cvs/files/patch-configure.in
@@ -0,0 +1,26 @@
+--- ./configure.in.orig 2008-05-07 16:10:34.000000000 -0400
++++ ./configure.in 2012-09-04 22:07:00.000000000 -0400
+@@ -148,7 +148,6 @@
+ limits.h \
+ memory.h \
+ ndbm.h \
+- process.h \
+ string.h \
+ syslog.h \
+ sys/bsdtypes.h \
+@@ -158,7 +157,6 @@
+ sys/select.h \
+ sys/time.h \
+ sys/timeb.h \
+- sys/utime.h \
+ unistd.h \
+ utime.h\
+ )
+@@ -218,7 +216,6 @@
+ getgroups \
+ getopt \
+ getpagesize \
+- getpid \
+ gettimeofday \
+ initgroups \
+ login \
diff --git a/devel/cvs/pkg-descr b/devel/cvs/pkg-descr
new file mode 100644
index 000000000000..a3916c2cc065
--- /dev/null
+++ b/devel/cvs/pkg-descr
@@ -0,0 +1,2 @@
+CVS is a version control system.
+It fills a similar role to the free software RCS, PRCS, and Aegis packages.
diff --git a/devel/cvs/pkg-plist b/devel/cvs/pkg-plist
new file mode 100644
index 000000000000..746a8e3a9fad
--- /dev/null
+++ b/devel/cvs/pkg-plist
@@ -0,0 +1,23 @@
+bin/cvs
+bin/cvsbug
+bin/rcs2log
+%%DATADIR%%/contrib/README
+%%DATADIR%%/contrib/check_cvs
+%%DATADIR%%/contrib/clmerge
+%%DATADIR%%/contrib/cln_hist
+%%DATADIR%%/contrib/commit_prep
+%%DATADIR%%/contrib/cvs2vendor
+%%DATADIR%%/contrib/cvs_acls
+%%DATADIR%%/contrib/cvscheck
+%%DATADIR%%/contrib/debug_check_log
+%%DATADIR%%/contrib/intro.doc
+%%DATADIR%%/contrib/log
+%%DATADIR%%/contrib/log_accum
+%%DATADIR%%/contrib/mfpipe
+%%DATADIR%%/contrib/pvcs2rcs
+%%DATADIR%%/contrib/rcs-to-cvs
+%%DATADIR%%/contrib/rcs2log
+%%DATADIR%%/contrib/rcslock
+%%DATADIR%%/contrib/sccs2rcs
+@dirrm %%DATADIR%%/contrib
+@dirrm %%DATADIR%%