aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-wm/e17-module-calendar/Makefile1
-rw-r--r--x11-wm/e17-module-calendar/files/patch-src_e_mod_main.c20
-rw-r--r--x11/e17-module-calendar/Makefile1
-rw-r--r--x11/e17-module-calendar/files/patch-src_e_mod_main.c20
4 files changed, 42 insertions, 0 deletions
diff --git a/x11-wm/e17-module-calendar/Makefile b/x11-wm/e17-module-calendar/Makefile
index 464c6cddaaf3..720cd6886157 100644
--- a/x11-wm/e17-module-calendar/Makefile
+++ b/x11-wm/e17-module-calendar/Makefile
@@ -7,6 +7,7 @@
PORTNAME= calendar
PORTVERSION= 23062006
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://mbsd.msk.ru/dist/
PKGNAMEPREFIX= e17-module-
diff --git a/x11-wm/e17-module-calendar/files/patch-src_e_mod_main.c b/x11-wm/e17-module-calendar/files/patch-src_e_mod_main.c
new file mode 100644
index 000000000000..1425a4ef7ec1
--- /dev/null
+++ b/x11-wm/e17-module-calendar/files/patch-src_e_mod_main.c
@@ -0,0 +1,20 @@
+--- src/e_mod_main.c.orig Thu Jul 6 23:11:37 2006
++++ src/e_mod_main.c Thu Jul 6 23:13:48 2006
+@@ -47,7 +47,7 @@
+
+ {
+ e_error_dialog_show
+- ("Module API Error", "Error initializing Module: calendar\n"
++ (module, "Module API Error", "Error initializing Module: calendar\n"
+ "It requires a minimum module API version of: %i.\n"
+ "The module API advertized by Enlightenment is: %i.\n"
+ "Aborting module.", E_MODULE_API_VERSION, module->api->version);
+@@ -102,7 +102,7 @@
+ EAPI int
+ e_modapi_about(E_Module *module)
+ {
+- e_error_dialog_show(D_("Enlightenment calendar Module"), D_("A simple module to give E17 a desktop calendar "));
++ e_error_dialog_show(module, D_("Enlightenment calendar Module"), D_("A simple module to give E17 a desktop calendar "));
+ return 1;
+ }
+
diff --git a/x11/e17-module-calendar/Makefile b/x11/e17-module-calendar/Makefile
index 464c6cddaaf3..720cd6886157 100644
--- a/x11/e17-module-calendar/Makefile
+++ b/x11/e17-module-calendar/Makefile
@@ -7,6 +7,7 @@
PORTNAME= calendar
PORTVERSION= 23062006
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://mbsd.msk.ru/dist/
PKGNAMEPREFIX= e17-module-
diff --git a/x11/e17-module-calendar/files/patch-src_e_mod_main.c b/x11/e17-module-calendar/files/patch-src_e_mod_main.c
new file mode 100644
index 000000000000..1425a4ef7ec1
--- /dev/null
+++ b/x11/e17-module-calendar/files/patch-src_e_mod_main.c
@@ -0,0 +1,20 @@
+--- src/e_mod_main.c.orig Thu Jul 6 23:11:37 2006
++++ src/e_mod_main.c Thu Jul 6 23:13:48 2006
+@@ -47,7 +47,7 @@
+
+ {
+ e_error_dialog_show
+- ("Module API Error", "Error initializing Module: calendar\n"
++ (module, "Module API Error", "Error initializing Module: calendar\n"
+ "It requires a minimum module API version of: %i.\n"
+ "The module API advertized by Enlightenment is: %i.\n"
+ "Aborting module.", E_MODULE_API_VERSION, module->api->version);
+@@ -102,7 +102,7 @@
+ EAPI int
+ e_modapi_about(E_Module *module)
+ {
+- e_error_dialog_show(D_("Enlightenment calendar Module"), D_("A simple module to give E17 a desktop calendar "));
++ e_error_dialog_show(module, D_("Enlightenment calendar Module"), D_("A simple module to give E17 a desktop calendar "));
+ return 1;
+ }
+