aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libnotifymm/Makefile27
-rw-r--r--devel/libnotifymm/distinfo3
-rw-r--r--devel/libnotifymm/pkg-descr1
-rw-r--r--devel/libnotifymm/pkg-plist21
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 035beafc61ef..36cf59e05ab1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -640,6 +640,7 @@
SUBDIR += libmtrie
SUBDIR += libnaji
SUBDIR += libnotify
+ SUBDIR += libnotifymm
SUBDIR += libnxt
SUBDIR += liboil
SUBDIR += libol
diff --git a/devel/libnotifymm/Makefile b/devel/libnotifymm/Makefile
new file mode 100644
index 000000000000..e2ad7f202c3c
--- /dev/null
+++ b/devel/libnotifymm/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libnotifymm
+# Date created: 2008-03-26
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnotifymm
+PORTVERSION= 0.6.1
+CATEGORIES= devel gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= C++ wrappers for libnotify
+
+LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify \
+ glibmm-2.4.1:${PORTSDIR}/devel/glibmm \
+ gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
+
+USE_BZIP2= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= pkgconfig gnomehack gnomeprefix ltverhack
+CONFIGURE_ENV= CPPFLAGS="-I${WRKSRC}/libnotify `pkg-config --cflags glibmm-2.4 libnotify gtkmm-2.4`"
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libnotifymm/distinfo b/devel/libnotifymm/distinfo
new file mode 100644
index 000000000000..f3bd08c8cc98
--- /dev/null
+++ b/devel/libnotifymm/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome2/libnotifymm-0.6.1.tar.bz2) = e7943688768aed3c695b1643448274c5
+SHA256 (gnome2/libnotifymm-0.6.1.tar.bz2) = fea7f6f7e436d343a14ceed749b5e9ad78e34c0a62c7790520710de5236c402f
+SIZE (gnome2/libnotifymm-0.6.1.tar.bz2) = 305654
diff --git a/devel/libnotifymm/pkg-descr b/devel/libnotifymm/pkg-descr
new file mode 100644
index 000000000000..4c4aa28887d6
--- /dev/null
+++ b/devel/libnotifymm/pkg-descr
@@ -0,0 +1 @@
+C++ wrappers for libnotify
diff --git a/devel/libnotifymm/pkg-plist b/devel/libnotifymm/pkg-plist
new file mode 100644
index 000000000000..8e3a91527f05
--- /dev/null
+++ b/devel/libnotifymm/pkg-plist
@@ -0,0 +1,21 @@
+include/libnotifymm-1.0/libnotifymm.h
+include/libnotifymm-1.0/libnotifymm/init.h
+include/libnotifymm-1.0/libnotifymm/notification.h
+include/libnotifymm-1.0/libnotifymm/notify.h
+include/libnotifymm-1.0/libnotifymm/private/notification_p.h
+include/libnotifymm-1.0/libnotifymm/wrap_init.h
+lib/libnotifymm-1.0.a
+lib/libnotifymm-1.0.la
+lib/libnotifymm-1.0.so
+lib/libnotifymm-1.0.so.7
+lib/libnotifymm-1.0/include/libnotifymmconfig.h
+lib/libnotifymm-1.0/proc/m4/convert.m4
+lib/libnotifymm-1.0/proc/m4/convert_libnotifymm.m4
+libdata/pkgconfig/libnotifymm-1.0.pc
+@dirrm lib/libnotifymm-1.0/proc/m4
+@dirrm lib/libnotifymm-1.0/proc
+@dirrm lib/libnotifymm-1.0/include
+@dirrm lib/libnotifymm-1.0
+@dirrm include/libnotifymm-1.0/libnotifymm/private
+@dirrm include/libnotifymm-1.0/libnotifymm
+@dirrm include/libnotifymm-1.0