aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/gpsbabel/Makefile2
-rw-r--r--audio/clementine-player/Makefile2
-rw-r--r--audio/qmpdclient/Makefile2
-rw-r--r--audio/vagalume/Makefile2
-rw-r--r--chinese/libtabe/Makefile2
-rw-r--r--devel/stlink/Makefile2
-rw-r--r--games/spring/Makefile2
-rw-r--r--korean/scim-hangul/Makefile2
-rw-r--r--lang/sagittarius-scheme/Makefile2
-rw-r--r--mail/faces/Makefile2
-rw-r--r--multimedia/libvpx/Makefile2
-rw-r--r--multimedia/mythtv/Makefile2
-rw-r--r--net/polyorb/Makefile2
-rw-r--r--net/wireshark/Makefile2
-rw-r--r--www/gohugo/Makefile2
-rw-r--r--www/sams2/Makefile2
-rw-r--r--x11/guake/Makefile2
17 files changed, 17 insertions, 17 deletions
diff --git a/astro/gpsbabel/Makefile b/astro/gpsbabel/Makefile
index 6aa5dad2c51a..fdfa36144cc5 100644
--- a/astro/gpsbabel/Makefile
+++ b/astro/gpsbabel/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS= --with-zlib=system
USES= localbase
OPTIONS_DEFINE= GUI
-OPTIONS_SUB= GUI
+OPTIONS_SUB= yes
GUI_ALL_TARGET= gui
GUI_USE= QT4=gui,xml,network,webkit
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 0ffd675d6aa6..e6b1dcafbc64 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -105,7 +105,7 @@ OPTIONS_DEFINE= AMAZON \
VISUALISATION \
WIIMOTEDEV
-OPTIONS_SUB= VISUALISATION
+OPTIONS_SUB= yes
AMAZON_DESC= Amazon Drive support
AUDIOCD_DESC= Devices: Audio CD support
diff --git a/audio/qmpdclient/Makefile b/audio/qmpdclient/Makefile
index 5122d071a9c5..546f64a246b8 100644
--- a/audio/qmpdclient/Makefile
+++ b/audio/qmpdclient/Makefile
@@ -23,7 +23,7 @@ OPTIONS_DEFINE= DBUS NLS DEBUG
DATADIR= ${PREFIX}/share/QMPDClient
WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS_SUB= NLS
+OPTIONS_SUB= yes
NLS_USE= QT4=linguisttools_build
diff --git a/audio/vagalume/Makefile b/audio/vagalume/Makefile
index a544eab23c60..9e08e234d925 100644
--- a/audio/vagalume/Makefile
+++ b/audio/vagalume/Makefile
@@ -24,7 +24,7 @@ INSTALLS_ICONS= yes
OPTIONS_DEFINE= DBUS TRAY NLS GCONF
OPTIONS_DEFAULT= DBUS TRAY
-OPTIONS_SUB= NLS DBUS
+OPTIONS_SUB= yes
TRAY_DESC= Tray icon and libnotify support
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
diff --git a/chinese/libtabe/Makefile b/chinese/libtabe/Makefile
index f6e67ac72466..885be5d6dd59 100644
--- a/chinese/libtabe/Makefile
+++ b/chinese/libtabe/Makefile
@@ -29,7 +29,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S|_|-|}
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= DOCS X11
-OPTIONS_SUB= X11
+OPTIONS_SUB= yes
X11_USE= XORG=x11
X11_CONFIGURE_WITH= x
diff --git a/devel/stlink/Makefile b/devel/stlink/Makefile
index d702dc0ac7b2..ace547e92f53 100644
--- a/devel/stlink/Makefile
+++ b/devel/stlink/Makefile
@@ -11,7 +11,7 @@ COMMENT= STM32 ST-Link JTAG variant tools
LICENSE= BSD3CLAUSE
OPTIONS_DEFINE= GTK3
-OPTIONS_SUB= GTK3
+OPTIONS_SUB= yes
GTK3_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-pacth-turn-off-gtk
GTK3_USE= GNOME=gtk30
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 2d91aef99d16..f6287203f382 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -57,7 +57,7 @@ PORTDATA= *
OPTIONS_DEFINE= MANPAGES PR_DOWNLOADER DOCS
OPTIONS_DEFAULT=MANPAGES PR_DOWNLOADER
-OPTIONS_SUB= *
+OPTIONS_SUB= yes
HTMLDOCS_DESC= Build and install HTML documentation
PR_DOWNLOADER_DESC= Map and game downloader
diff --git a/korean/scim-hangul/Makefile b/korean/scim-hangul/Makefile
index 5afac6dacf7a..f068c4b3088d 100644
--- a/korean/scim-hangul/Makefile
+++ b/korean/scim-hangul/Makefile
@@ -19,7 +19,7 @@ GNU_CONFIGURE= yes
USES= gmake libtool:keepla pkgconfig
OPTIONS_DEFINE= NLS
-OPTIONS_SUB= NLS
+OPTIONS_SUB= yes
.include <bsd.port.options.mk>
diff --git a/lang/sagittarius-scheme/Makefile b/lang/sagittarius-scheme/Makefile
index 478fe0ad299a..be422d744ce4 100644
--- a/lang/sagittarius-scheme/Makefile
+++ b/lang/sagittarius-scheme/Makefile
@@ -30,7 +30,7 @@ PLIST_SUB= PORTNAME=sagittarius PORTVERSION=${PORTVERSION}
ODBC_LIB_DEPENDS= libiodbc.so:databases/libiodbc
ODBC_CMAKE_ON= -DODBC_INCLUDE_DIR:STRING=${LOCALBASE}/include/libiodbc
SIMD_CMAKE_BOOL= USE_SSE
-OPTIONS_SUB= ODBC
+OPTIONS_SUB= yes
.include <bsd.port.pre.mk>
diff --git a/mail/faces/Makefile b/mail/faces/Makefile
index 0ce4cfb01fe0..bdbc3ea8ea00 100644
--- a/mail/faces/Makefile
+++ b/mail/faces/Makefile
@@ -25,7 +25,7 @@ SOX_DESC= Sox audio support
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-OPTIONS_SUB= X11
+OPTIONS_SUB= yes
X11_USE= GNOME=gtk12
X11_CPPFLAGS= -I../compface -I${LOCALBASE}/include
diff --git a/multimedia/libvpx/Makefile b/multimedia/libvpx/Makefile
index 0da01f3b43f7..fce97e810524 100644
--- a/multimedia/libvpx/Makefile
+++ b/multimedia/libvpx/Makefile
@@ -54,7 +54,7 @@ ASFLAGS+= ${ASFLAGS_armv7}
OPTIONS_DEFINE= DEBUG MULTIRES POSTPROC RTCPU SHARED SIZE_LIMIT TEST THREADS
OPTIONS_DEFAULT=MULTIRES POSTPROC RTCPU SHARED SIZE_LIMIT THREADS
OPTIONS_EXCLUDE_aarch64=RTCPU
-OPTIONS_SUB= SHARED
+OPTIONS_SUB= yes
DEBUG_CONFIGURE_ON= --enable-debug
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index 58ca717f4246..d7b0ede13c68 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -72,7 +72,7 @@ QMAKESPEC?= ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++
OPTIONS_DEFINE= BINDINGS LIRC MYSQL OPENGL VDPAU
OPTIONS_DEFAULT= BINDINGS OPENGL VDPAU
-OPTIONS_SUB= BINDINGS
+OPTIONS_SUB= yes
BINDINGS_DESC= Perl and Python bindings
LIRC_LIB_DEPENDS= liblirc_client.so:comms/lirc
diff --git a/net/polyorb/Makefile b/net/polyorb/Makefile
index 665cecf72257..afda8424df4b 100644
--- a/net/polyorb/Makefile
+++ b/net/polyorb/Makefile
@@ -42,7 +42,7 @@ CONFIGURE_ARGS= --with-appli-perso="corba dsa moma" \
# Polyorb 2014 = PCS version 6 GNAT GCC 4.9 = PCS version 6
OPTIONS_DEFINE= DOCS TESTSUITE
-OPTIONS_SUB= TESTSUITE
+OPTIONS_SUB= yes
TESTSUITE_ALL_TARGET= testsuite
TESTSUITE_BUILD_DEPENDS=gnatpython>=20101207:devel/gnatpython
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 6f774bf8491a..0f50bedb7b53 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -125,7 +125,7 @@ QT5_PLIST_SUB= GUI_GTK="@comment "
GTK2_PLIST_SUB= GUI_GTK=""
GTK3_PLIST_SUB= GUI_GTK=""
-OPTIONS_SUB= LUA
+OPTIONS_SUB= yes
.if defined(LITE)
CONFIGURE_ARGS+=--enable-androiddump=no
diff --git a/www/gohugo/Makefile b/www/gohugo/Makefile
index ddb10fd3727b..a89a43e0f1d3 100644
--- a/www/gohugo/Makefile
+++ b/www/gohugo/Makefile
@@ -65,7 +65,7 @@ GH_TUPLE= BurntSushi:toml:a368813:toml/src/github.com/BurntSushi/toml \
OPTIONS_DEFINE= MANPAGES
OPTIONS_DEFAULT= MANPAGES
-OPTIONS_SUB= MANPAGES
+OPTIONS_SUB= yes
MANPAGES_DESC= Build and/or install manual pages
diff --git a/www/sams2/Makefile b/www/sams2/Makefile
index 36508d4c5823..214a083ed40b 100644
--- a/www/sams2/Makefile
+++ b/www/sams2/Makefile
@@ -28,7 +28,7 @@ SUB_FILES= sams2.conf.sample
PORTDOCS= *
OPTIONS_DEFINE= DOCS APACHE
-OPTIONS_SUB= APACHE
+OPTIONS_SUB= yes
APACHE_USE= APACHE=22+
# We can't use <options> here, ${APACHE*} won't be populated
diff --git a/x11/guake/Makefile b/x11/guake/Makefile
index 08bc640343df..504c0f15f8d6 100644
--- a/x11/guake/Makefile
+++ b/x11/guake/Makefile
@@ -38,7 +38,7 @@ NLS_CONFIGURE_ENABLE= nls
OPTIONS_DEFINE= MANPAGES NLS
OPTIONS_DEFAULT= MANPAGES
-OPTIONS_SUB= NLS
+OPTIONS_SUB= yes
PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,${PREFIX}/,,}"