aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/gcc32/Makefile4
-rw-r--r--lang/gcc33/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index 71c46b26b7b9..db53693edad2 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -43,6 +43,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64"
+BROKEN= "Configure broken due to renaming this architecture from x86_84."
+.endif
+
.if ${PORTOBJFORMAT} == "aout"
CONFIGURE_TARGET= ${ARCH}-portbld-freebsdaout${OSREL}
.else
diff --git a/lang/gcc33/Makefile b/lang/gcc33/Makefile
index 5d75657db986..792e85df5d9d 100644
--- a/lang/gcc33/Makefile
+++ b/lang/gcc33/Makefile
@@ -49,6 +49,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64"
+BROKEN= "Configure broken due to renaming this architecture from x86_84."
+.endif
+
.if ${ARCH} == sparc64
BROKEN= "libgcj is not supported/packaging is broken on this platform"
.endif