aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/libmemcache/Makefile4
-rw-r--r--emulators/snes9express/Makefile8
-rw-r--r--japanese/kasumi/Makefile8
-rw-r--r--math/py-gsl/Makefile8
4 files changed, 25 insertions, 3 deletions
diff --git a/databases/libmemcache/Makefile b/databases/libmemcache/Makefile
index a96ebdf4d1e8..79d2f645f404 100644
--- a/databases/libmemcache/Makefile
+++ b/databases/libmemcache/Makefile
@@ -26,6 +26,10 @@ OPTIONS= DEBUG "Build with debugging turned on" off
PMKARGS= -e debug
.endif
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
do-configure:
cd ${WRKSRC}; ${LOCALBASE}/bin/pmk ${PMKARGS}
diff --git a/emulators/snes9express/Makefile b/emulators/snes9express/Makefile
index a5af55dd09b0..7cfb3ca4d119 100644
--- a/emulators/snes9express/Makefile
+++ b/emulators/snes9express/Makefile
@@ -24,6 +24,12 @@ USE_XLIB= yes
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-configure:
@${REINPLACE_CMD} -e 's|lstat$$U.o||' ${WRKSRC}/Makefile
@@ -39,4 +45,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/kasumi/Makefile b/japanese/kasumi/Makefile
index 0c28093cbe48..4b2e1a338854 100644
--- a/japanese/kasumi/Makefile
+++ b/japanese/kasumi/Makefile
@@ -29,4 +29,10 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index 13eec692db98..2aa7b3069bf1 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -26,4 +26,10 @@ PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>