aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/squeezeboxserver/Makefile9
-rw-r--r--audio/squeezeboxserver/distinfo6
-rw-r--r--audio/squeezeboxserver/files/patch-convert.conf50
-rw-r--r--audio/squeezeboxserver/pkg-plist8
-rw-r--r--audio/squeezecenter/Makefile9
-rw-r--r--audio/squeezecenter/distinfo6
-rw-r--r--audio/squeezecenter/files/patch-convert.conf50
-rw-r--r--audio/squeezecenter/pkg-plist8
8 files changed, 62 insertions, 84 deletions
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index e5b288165a5f..fbd3d4410bd2 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= squeezecenter
-PORTVERSION= 7.3.1
-PORTREVISION= 1
+PORTVERSION= 7.3.2
CATEGORIES= audio
MASTER_SITES= http://downloads.slimdevices.com/SqueezeCenter_v${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.0//}-noCPAN
@@ -24,7 +23,7 @@ OPTIONS= APE "Support Monkey's Audio Codec input" on \
LAME "Support MP3 output via LAME" off \
MUSEPACK "Support musepack input" on \
SHORTEN "Support Shorten input" off \
- VORBIS "Support OGG Vorbis input (SliMP3 and SB1)" on
+ SOX "Support OGG Vorbis input via SoX (SliMP3 and SB1)" on
RESTRICTED= Contains non-redistributable firmware, documentation, and images
@@ -74,8 +73,8 @@ RUN_DEPENDS+= mppdec:${PORTSDIR}/audio/musepack
.if !defined(WITHOUT_SHORTEN)
RUN_DEPENDS+= shorten:${PORTSDIR}/audio/shorten
.endif
-.if !defined(WITHOUT_VORBIS)
-RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
+.if !defined(WITHOUT_SOX)
+RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox
.endif
USE_RC_SUBR= squeezecenter.sh
diff --git a/audio/squeezeboxserver/distinfo b/audio/squeezeboxserver/distinfo
index fa5b9fded415..0e35c78144b2 100644
--- a/audio/squeezeboxserver/distinfo
+++ b/audio/squeezeboxserver/distinfo
@@ -1,3 +1,3 @@
-MD5 (squeezecenter-7.3.1-noCPAN.tgz) = 77a253de38600c34936748be7c5528a1
-SHA256 (squeezecenter-7.3.1-noCPAN.tgz) = 7d4fceb8b0b87e10a849cc08237addec910e135e15094e911da6386036302cea
-SIZE (squeezecenter-7.3.1-noCPAN.tgz) = 23765464
+MD5 (squeezecenter-7.3.2-noCPAN.tgz) = fc8d01eb4977bc583d8c6e851ebf9adf
+SHA256 (squeezecenter-7.3.2-noCPAN.tgz) = 42be2af96fd0924df3fb69bb6cbeb3d73304608bd865cb7f2c505c254f8d664d
+SIZE (squeezecenter-7.3.2-noCPAN.tgz) = 25322353
diff --git a/audio/squeezeboxserver/files/patch-convert.conf b/audio/squeezeboxserver/files/patch-convert.conf
index 299438e1fbf1..76e11f05dcad 100644
--- a/audio/squeezeboxserver/files/patch-convert.conf
+++ b/audio/squeezeboxserver/files/patch-convert.conf
@@ -1,47 +1,37 @@
---- convert.conf.orig 2008-12-19 17:30:03.000000000 -0800
-+++ convert.conf 2008-12-22 13:32:09.000000000 -0800
-@@ -75,7 +75,7 @@
+--- convert.conf.orig 2009-01-23 19:23:04.000000000 +0100
++++ convert.conf 2009-01-23 19:21:33.000000000 +0100
+@@ -74,8 +74,8 @@
+ # specific combinations match before wildcards
mov mp3 * *
- # FRB:{BITRATE=-B %B}
-- [mov123] $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ $RESAMPLE$ -v $BITRATE$ -r --big-endian - -
-+ [faad] $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ -r --big-endian - -
+- # FRB:{BITRATE=-B %B}D:{RESAMPLE=--resample %D}
+- [mov123] $FILE$ | [lame] -s 44100 --silent -q $QUALITY$ $RESAMPLE$ -v $BITRATE$ -r --big-endian - -
++ # FB:{BITRATE=-B %B}D:{RESAMPLE=--resample %D}
++ [faad] -q -w -f 2 $FILE$ | [lame] -s 44100 --silent -q $QUALITY$ $RESAMPLE$ -v $BITRATE$ -r --little-endian - -
alc mp3 * *
# FB:{BITRATE=-B %B}D:{RESAMPLE=--resample %D}
-@@ -83,7 +83,7 @@
+@@ -158,9 +158,9 @@
+ [wvunpack] $FILE$ -rq $START$ $END$ -o -
- ogg mp3 * *
- # IFB:{BITRATE=-B %B}D:{RESAMPLE=--resample %D}
-- [sox] -t ogg $FILE$ -t wav -w - | [lame] --silent -q $QUALITY$ $RESAMPLE$ -v $BITRATE$ - -
-+ [oggdec] -Q -o - $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ -r --big-endian - -
-
- wav mp3 * *
- # IFB:{BITRATE=-B %B}D:{RESAMPLE=--resample %D}
-@@ -160,7 +160,7 @@
## you can comment this out if you want to use LAME to transcode AAC/MOV files to MP3.
- mov aif * *
- # FR
+-mov aif * *
+- # FR
- [mov123] $FILE$
-+ [faad] -w -f 2 $FILE$
++mov wav * *
++ # F
++ [faad] -w -q $FILE$
wma wma * *
-
-@@ -183,7 +183,7 @@
-
- ogg flc * *
- # IFRD:{RESAMPLE=-r %d}
-- [sox] $RESAMPLE$ -t ogg $FILE$ -t wav - | [flac] -cs --compression-level-0 --totally-silent -
-+ [oggdec] -Q -o - $FILE$ | [flac] -cs --compression-level-0 --totally-silent --endian big --channels 2 --bps 16 --sample-rate 44100 --sign signed -
-
- wma flc * *
- # F:{PATH=%f}R:{PATH=%F}
-@@ -199,7 +199,7 @@
+@@ -198,8 +198,8 @@
+ [mac] $FILE$ - -d | [flac] -cs --totally-silent --compression-level-0 -
mov flc * *
- # FR
+- # FR
- [mov123] $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -
-+ [faad ] -w -f 2 $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -
++ # F
++ [faad] -w -q -f 2 $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian little --sign signed --channels 2 --bps 16 --sample-rate 44100 -
alc flc * *
# F
diff --git a/audio/squeezeboxserver/pkg-plist b/audio/squeezeboxserver/pkg-plist
index 8b4456284cbf..1a624a09ab51 100644
--- a/audio/squeezeboxserver/pkg-plist
+++ b/audio/squeezeboxserver/pkg-plist
@@ -627,16 +627,16 @@ bin/softsqueeze
%%SLIMDIR%%/Changelog7.html
%%SLIMDIR%%/Firmware/boom.version
%%SLIMDIR%%/Firmware/boom_30.bin
-%%SLIMDIR%%/Firmware/boom_41.bin
+%%SLIMDIR%%/Firmware/boom_43.bin
%%SLIMDIR%%/Firmware/receiver.version
-%%SLIMDIR%%/Firmware/receiver_56.bin
+%%SLIMDIR%%/Firmware/receiver_58.bin
%%SLIMDIR%%/Firmware/squeezebox.version
%%SLIMDIR%%/Firmware/squeezebox2.version
-%%SLIMDIR%%/Firmware/squeezebox2_121.bin
+%%SLIMDIR%%/Firmware/squeezebox2_123.bin
%%SLIMDIR%%/Firmware/squeezebox_10.bin
%%SLIMDIR%%/Firmware/squeezebox_40.bin
%%SLIMDIR%%/Firmware/transporter.version
-%%SLIMDIR%%/Firmware/transporter_71.bin
+%%SLIMDIR%%/Firmware/transporter_73.bin
%%SLIMDIR%%/Graphics/CODE2000.HTM
%%SLIMDIR%%/Graphics/CODE2000.TTF
%%SLIMDIR%%/Graphics/FreeSans.ttf
diff --git a/audio/squeezecenter/Makefile b/audio/squeezecenter/Makefile
index e5b288165a5f..fbd3d4410bd2 100644
--- a/audio/squeezecenter/Makefile
+++ b/audio/squeezecenter/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= squeezecenter
-PORTVERSION= 7.3.1
-PORTREVISION= 1
+PORTVERSION= 7.3.2
CATEGORIES= audio
MASTER_SITES= http://downloads.slimdevices.com/SqueezeCenter_v${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.0//}-noCPAN
@@ -24,7 +23,7 @@ OPTIONS= APE "Support Monkey's Audio Codec input" on \
LAME "Support MP3 output via LAME" off \
MUSEPACK "Support musepack input" on \
SHORTEN "Support Shorten input" off \
- VORBIS "Support OGG Vorbis input (SliMP3 and SB1)" on
+ SOX "Support OGG Vorbis input via SoX (SliMP3 and SB1)" on
RESTRICTED= Contains non-redistributable firmware, documentation, and images
@@ -74,8 +73,8 @@ RUN_DEPENDS+= mppdec:${PORTSDIR}/audio/musepack
.if !defined(WITHOUT_SHORTEN)
RUN_DEPENDS+= shorten:${PORTSDIR}/audio/shorten
.endif
-.if !defined(WITHOUT_VORBIS)
-RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
+.if !defined(WITHOUT_SOX)
+RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox
.endif
USE_RC_SUBR= squeezecenter.sh
diff --git a/audio/squeezecenter/distinfo b/audio/squeezecenter/distinfo
index fa5b9fded415..0e35c78144b2 100644
--- a/audio/squeezecenter/distinfo
+++ b/audio/squeezecenter/distinfo
@@ -1,3 +1,3 @@
-MD5 (squeezecenter-7.3.1-noCPAN.tgz) = 77a253de38600c34936748be7c5528a1
-SHA256 (squeezecenter-7.3.1-noCPAN.tgz) = 7d4fceb8b0b87e10a849cc08237addec910e135e15094e911da6386036302cea
-SIZE (squeezecenter-7.3.1-noCPAN.tgz) = 23765464
+MD5 (squeezecenter-7.3.2-noCPAN.tgz) = fc8d01eb4977bc583d8c6e851ebf9adf
+SHA256 (squeezecenter-7.3.2-noCPAN.tgz) = 42be2af96fd0924df3fb69bb6cbeb3d73304608bd865cb7f2c505c254f8d664d
+SIZE (squeezecenter-7.3.2-noCPAN.tgz) = 25322353
diff --git a/audio/squeezecenter/files/patch-convert.conf b/audio/squeezecenter/files/patch-convert.conf
index 299438e1fbf1..76e11f05dcad 100644
--- a/audio/squeezecenter/files/patch-convert.conf
+++ b/audio/squeezecenter/files/patch-convert.conf
@@ -1,47 +1,37 @@
---- convert.conf.orig 2008-12-19 17:30:03.000000000 -0800
-+++ convert.conf 2008-12-22 13:32:09.000000000 -0800
-@@ -75,7 +75,7 @@
+--- convert.conf.orig 2009-01-23 19:23:04.000000000 +0100
++++ convert.conf 2009-01-23 19:21:33.000000000 +0100
+@@ -74,8 +74,8 @@
+ # specific combinations match before wildcards
mov mp3 * *
- # FRB:{BITRATE=-B %B}
-- [mov123] $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ $RESAMPLE$ -v $BITRATE$ -r --big-endian - -
-+ [faad] $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ -r --big-endian - -
+- # FRB:{BITRATE=-B %B}D:{RESAMPLE=--resample %D}
+- [mov123] $FILE$ | [lame] -s 44100 --silent -q $QUALITY$ $RESAMPLE$ -v $BITRATE$ -r --big-endian - -
++ # FB:{BITRATE=-B %B}D:{RESAMPLE=--resample %D}
++ [faad] -q -w -f 2 $FILE$ | [lame] -s 44100 --silent -q $QUALITY$ $RESAMPLE$ -v $BITRATE$ -r --little-endian - -
alc mp3 * *
# FB:{BITRATE=-B %B}D:{RESAMPLE=--resample %D}
-@@ -83,7 +83,7 @@
+@@ -158,9 +158,9 @@
+ [wvunpack] $FILE$ -rq $START$ $END$ -o -
- ogg mp3 * *
- # IFB:{BITRATE=-B %B}D:{RESAMPLE=--resample %D}
-- [sox] -t ogg $FILE$ -t wav -w - | [lame] --silent -q $QUALITY$ $RESAMPLE$ -v $BITRATE$ - -
-+ [oggdec] -Q -o - $FILE$ | [lame] --resample 44100 --silent -q $QUALITY$ --abr $BITRATE$ -r --big-endian - -
-
- wav mp3 * *
- # IFB:{BITRATE=-B %B}D:{RESAMPLE=--resample %D}
-@@ -160,7 +160,7 @@
## you can comment this out if you want to use LAME to transcode AAC/MOV files to MP3.
- mov aif * *
- # FR
+-mov aif * *
+- # FR
- [mov123] $FILE$
-+ [faad] -w -f 2 $FILE$
++mov wav * *
++ # F
++ [faad] -w -q $FILE$
wma wma * *
-
-@@ -183,7 +183,7 @@
-
- ogg flc * *
- # IFRD:{RESAMPLE=-r %d}
-- [sox] $RESAMPLE$ -t ogg $FILE$ -t wav - | [flac] -cs --compression-level-0 --totally-silent -
-+ [oggdec] -Q -o - $FILE$ | [flac] -cs --compression-level-0 --totally-silent --endian big --channels 2 --bps 16 --sample-rate 44100 --sign signed -
-
- wma flc * *
- # F:{PATH=%f}R:{PATH=%F}
-@@ -199,7 +199,7 @@
+@@ -198,8 +198,8 @@
+ [mac] $FILE$ - -d | [flac] -cs --totally-silent --compression-level-0 -
mov flc * *
- # FR
+- # FR
- [mov123] $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -
-+ [faad ] -w -f 2 $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -
++ # F
++ [faad] -w -q -f 2 $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian little --sign signed --channels 2 --bps 16 --sample-rate 44100 -
alc flc * *
# F
diff --git a/audio/squeezecenter/pkg-plist b/audio/squeezecenter/pkg-plist
index 8b4456284cbf..1a624a09ab51 100644
--- a/audio/squeezecenter/pkg-plist
+++ b/audio/squeezecenter/pkg-plist
@@ -627,16 +627,16 @@ bin/softsqueeze
%%SLIMDIR%%/Changelog7.html
%%SLIMDIR%%/Firmware/boom.version
%%SLIMDIR%%/Firmware/boom_30.bin
-%%SLIMDIR%%/Firmware/boom_41.bin
+%%SLIMDIR%%/Firmware/boom_43.bin
%%SLIMDIR%%/Firmware/receiver.version
-%%SLIMDIR%%/Firmware/receiver_56.bin
+%%SLIMDIR%%/Firmware/receiver_58.bin
%%SLIMDIR%%/Firmware/squeezebox.version
%%SLIMDIR%%/Firmware/squeezebox2.version
-%%SLIMDIR%%/Firmware/squeezebox2_121.bin
+%%SLIMDIR%%/Firmware/squeezebox2_123.bin
%%SLIMDIR%%/Firmware/squeezebox_10.bin
%%SLIMDIR%%/Firmware/squeezebox_40.bin
%%SLIMDIR%%/Firmware/transporter.version
-%%SLIMDIR%%/Firmware/transporter_71.bin
+%%SLIMDIR%%/Firmware/transporter_73.bin
%%SLIMDIR%%/Graphics/CODE2000.HTM
%%SLIMDIR%%/Graphics/CODE2000.TTF
%%SLIMDIR%%/Graphics/FreeSans.ttf