aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/sdl12/Makefile2
-rw-r--r--graphics/blender/Makefile2
-rw-r--r--multimedia/libav/Makefile2
-rw-r--r--multimedia/libmpeg2/Makefile8
4 files changed, 7 insertions, 7 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index eb15025e9e50..50a1af7b89a5 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -59,7 +59,7 @@ SVGALIB_CONFIGURE_ENABLE= video-svga
SVGALIB_LIB_DEPENDS= libvga.so:${PORTSDIR}/graphics/svgalib
VGL_CONFIGURE_ENABLE= video-vgl
X11_CONFIGURE_ENABLE= video-x11
-X11_USE= XORG= x11 xrender xrandr xextproto
+X11_USE= XORG=x11,xrender,xrandr,xextproto
.include <bsd.port.options.mk>
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 1c770a9e7853..f4a1d629e2c9 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -122,7 +122,7 @@ XINPUT_CMAKE_OFF= -DWITH_X11_XINPUT:BOOL=OFF
XINPUT_USE= XORG=xi
XF86VMODE_CMAKE_ON= -DWITH_X11_XF86VMODE:BOOL=ON
XF86VMODE_CMAKE_OFF= -DWITH_X11_XF86VMODE:BOOL=OFF
-XF86VMODE_USE= XORG=xi xxf86vm
+XF86VMODE_USE= XORG=xi,xxf86vm
.include <bsd.port.options.mk>
diff --git a/multimedia/libav/Makefile b/multimedia/libav/Makefile
index b06d4d00ba9a..8ecc6a08f5eb 100644
--- a/multimedia/libav/Makefile
+++ b/multimedia/libav/Makefile
@@ -137,7 +137,7 @@ VORBIS_CONFIGURE_ENABLE= libvorbis
VPX_LIB_DEPENDS= libvpx.so:${PORTSDIR}/multimedia/libvpx
VPX_CONFIGURE_ENABLE= libvpx
-X11GRAB_USE= XORG=x11 xext xfixes
+X11GRAB_USE= XORG=x11,xext,xfixes
X264_LIB_DEPENDS= libx264.so:${PORTSDIR}/multimedia/x264
X264_CONFIGURE_ENABLE= libx264
diff --git a/multimedia/libmpeg2/Makefile b/multimedia/libmpeg2/Makefile
index 4c4aa811f15d..34d33fe1ae4f 100644
--- a/multimedia/libmpeg2/Makefile
+++ b/multimedia/libmpeg2/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= multimedia
MASTER_SITES= http://libmpeg2.sourceforge.net/files/
MAINTAINER= multimedia@FreeBSD.org
-COMMENT= Free library for decoding mpeg-2 and mpeg-1 video streams
+COMMENT= Free library for decoding MPEG-2 and MPEG-1 video streams
USES= libtool pathfix
GNU_CONFIGURE= yes
@@ -22,17 +22,17 @@ OPTIONS_DEFINE= DOCS SDL X11
SDL_USE= SDL=yes
SDL_CONFIGURE_ENABLE= sdl
-X11_USE= XORG=sm XORG=xv
+X11_USE= XORG=sm,xv
X11_CONFIGURE_WITH= x
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|-O3||;s|<termio.h>|<termios.h>|' \
+ @${REINPLACE_CMD} -e 's| -O3|| ; s|<termio|&s|' \
${WRKSRC}/configure
# AMD64 prefers position independent code
.if ${ARCH:L} == "amd64"
- @${REINPLACE_CMD} -e 's|-prefer-non-pic||' \
+ @${REINPLACE_CMD} -e '/CFLAGS/s| -prefer-non-pic||' \
${WRKSRC}/configure
.endif