aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--science/metaf2xml/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/science/metaf2xml/Makefile b/science/metaf2xml/Makefile
index 5b462cb6d890..82b8ee5247b5 100644
--- a/science/metaf2xml/Makefile
+++ b/science/metaf2xml/Makefile
@@ -12,6 +12,8 @@ COMMENT= Parse and Decode METAR, TAF, SYNOP, BUOY and AMDAR and Write as XML
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
+RUN_DEPENDS= p5-CGI>0:www/p5-CGI
+
OPTIONS_DEFINE= APACHE DOCS
OPTIONS_SUB= yes
APACHE_DESC= Install Apache config file for metaf2xml (depends on Apache)
@@ -34,17 +36,7 @@ SHEBANG_FILES= metaf.pl metaf2xml.pl metafsrc2raw.pl
PLIST_SUB= VERSION=${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502200
-RUN_DEPENDS+= p5-CGI>0:www/p5-CGI
-.endif
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MAPACHE}
-USE_APACHE_RUN= 22+
-MAKE_ARGS+= CONF_DIR=${PREFIX}/${APACHEETCDIR}/Includes
-.endif
+APACHE_MAKE_ARGS= CONF_DIR=${PREFIX}/${APACHEETCDIR}/Includes
+APACHE_USE= APACHE_RUN=22+
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>