aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/geteltorito/Makefile26
-rw-r--r--sysutils/geteltorito/distinfo3
-rw-r--r--sysutils/geteltorito/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ffb440b46497..84c10bbba17a 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -271,6 +271,7 @@
SUBDIR += gconf-editor
SUBDIR += gdmap
SUBDIR += geomgui
+ SUBDIR += geteltorito
SUBDIR += getdelta
SUBDIR += gfslicer
SUBDIR += ghasher
diff --git a/sysutils/geteltorito/Makefile b/sysutils/geteltorito/Makefile
new file mode 100644
index 000000000000..84ec7b55d381
--- /dev/null
+++ b/sysutils/geteltorito/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: geteltorito
+# Date created: Wed Apr 15 11:35:12 PDT 2009
+# Whom: Valerio Daelli <valerio.daelli@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= geteltorito
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.uni-koblenz.de/~krienke/ftp/noarch/geteltorito/
+DISTFILES= ${PORTNAME}.pl
+EXTRACT_ONLY=
+
+MAINTAINER= valerio.daelli@gmail.com
+COMMENT= El Torito image extractor
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${DISTDIR}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/geteltorito/distinfo b/sysutils/geteltorito/distinfo
new file mode 100644
index 000000000000..d8cefc4400fa
--- /dev/null
+++ b/sysutils/geteltorito/distinfo
@@ -0,0 +1,3 @@
+MD5 (geteltorito.pl) = 5881fe99171ba4c00eba88b706b71672
+SHA256 (geteltorito.pl) = 797f36647319f9aa1424eeaf10cd5bfb74db994848cdbb66c04086f18d8eb087
+SIZE (geteltorito.pl) = 5832
diff --git a/sysutils/geteltorito/pkg-descr b/sysutils/geteltorito/pkg-descr
new file mode 100644
index 000000000000..9022637755b3
--- /dev/null
+++ b/sysutils/geteltorito/pkg-descr
@@ -0,0 +1,6 @@
+geteltorito is a small Perl script which will extract
+(and display information about) an El Torito boot image
+from a real CD or a CD image. This helps you modify the boot
+image when you want to burn a modified version of the CD in question.
+
+WWW: http://www.uni-koblenz.de/~krienke/ftp/noarch/geteltorito/