aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ftp/proftpd/Makefile2
-rw-r--r--ftp/proftpd/files/proftpd.in16
2 files changed, 8 insertions, 10 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 1945e5d5eff1..7a61eb97fd43 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -5,7 +5,7 @@ PORTNAME?= proftpd
.if !defined(DISTVERSION)
PORTVERSION?= ${PROFTPD_VERSION}
.endif
-PORTREVISION?= 4
+PORTREVISION?= 5
CATEGORIES?= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
https://github.com/downloads/proftpd/proftpd.github.com/ \
diff --git a/ftp/proftpd/files/proftpd.in b/ftp/proftpd/files/proftpd.in
index a4674f2bb49b..cf2a338c7e75 100644
--- a/ftp/proftpd/files/proftpd.in
+++ b/ftp/proftpd/files/proftpd.in
@@ -22,22 +22,20 @@
name=proftpd
rcvar=proftpd_enable
+proftpd_enable=${proftpd_enable:="NO"}
+proftpd_config=${proftpd_config:="%%PREFIX%%/etc/proftpd.conf"}
+
command=%%PREFIX%%/sbin/proftpd
-pidfile=$(grep PidFile /usr/local/etc/proftpd.conf | awk '{print($2)}')
-required_files=%%PREFIX%%/etc/proftpd.conf
+command_args="-c ${proftpd_config}"
+pidfile=$(grep PidFile ${proftpd_config} | awk '{print($2)}')
+required_files=${proftpd_config}
+extra_commands="reload"
stop_postcmd=stop_postcmd
-
stop_postcmd()
{
rm -f $pidfile
}
-# set defaults
-
-proftpd_enable=${proftpd_enable:-"NO"}
-
-extra_commands="reload"
-
load_rc_config $name
run_rc_command "$1"