aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/gkrellmvolume2/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/audio/gkrellmvolume2/Makefile b/audio/gkrellmvolume2/Makefile
index 753e77b4cad4..dbdab001fa02 100644
--- a/audio/gkrellmvolume2/Makefile
+++ b/audio/gkrellmvolume2/Makefile
@@ -26,10 +26,14 @@ PLIST_FILES= libexec/gkrellm2/plugins/volume.so \
share/locale/ru/LC_MESSAGES/gkrellm-volume.mo
USES= gmake pkgconfig
-NO_STAGE= yes
-MAKE_ENV+= PLUGIN_DIR=${PREFIX}/libexec/gkrellm2/plugins \
- LOCALEDIR=${PREFIX}/share/locale \
+PLUGIN_DIR= ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
+
+MAKE_ENV+= PLUGIN_DIR=${PLUGIN_DIR} \
+ LOCALEDIR=${STAGEDIR}${PREFIX}/share/locale \
enable_nls=1
+pre-install:
+ @${MKDIR} ${PLUGIN_DIR}
+
.include <bsd.port.mk>