aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/tcpreplay/Makefile15
-rw-r--r--net-mgmt/tcpreplay/distinfo6
-rw-r--r--net-mgmt/tcpreplay/pkg-descr2
3 files changed, 16 insertions, 7 deletions
diff --git a/net-mgmt/tcpreplay/Makefile b/net-mgmt/tcpreplay/Makefile
index 45e2306e4f21..b39ea1782068 100644
--- a/net-mgmt/tcpreplay/Makefile
+++ b/net-mgmt/tcpreplay/Makefile
@@ -2,24 +2,33 @@
# $FreeBSD$
PORTNAME= tcpreplay
-PORTVERSION= 4.1.2
+PORTVERSION= 4.2.1
+DISTVERSIONPREFIX= v
CATEGORIES= net-mgmt
-MASTER_SITES= SF
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Tool to replay saved packet capture files
LICENSE= GPLv3
+LIB_DEPENDS= libopts.so:devel/autogen \
+ libdnet.so:net/libdnet
BUILD_DEPENDS= pcapnav-config:net/libpcapnav
+USES= autoreconf libtool pkgconfig
+USE_GITHUB= yes
GNU_CONFIGURE= yes
+GH_ACCOUNT= appneta
+
CONFIGURE_ARGS= --program-transform-name='s|.*\(tcp.*\)|\1|' \
--with-pcapnav-config=${LOCALBASE}/bin/pcapnav-config
+# required when using autogen
+CONFIGURE_ARGS+= --disable-local-libopts --disable-libopts-install
+
post-patch:
- @${REINPLACE_CMD} -e 's|-Wall -O3||' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-Wall -O3||' ${WRKSRC}/${CONFIGURE_SCRIPT}.ac
regression-test: build
@cd ${WRKSRC} && ${MAKE} -s test
diff --git a/net-mgmt/tcpreplay/distinfo b/net-mgmt/tcpreplay/distinfo
index 92616d4acf26..846eda2516da 100644
--- a/net-mgmt/tcpreplay/distinfo
+++ b/net-mgmt/tcpreplay/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1479618765
-SHA256 (tcpreplay-4.1.2.tar.gz) = da483347e83a9b5df0e0dbb0f822a2d37236e79dda35f4bc4e6684fa827f25ea
-SIZE (tcpreplay-4.1.2.tar.gz) = 2162175
+TIMESTAMP = 1490298727
+SHA256 (appneta-tcpreplay-v4.2.1_GH0.tar.gz) = 7c4f5841dc590b8ee1a47a2b59ae55434850a85ead9fd71d77e2312a846fc2d1
+SIZE (appneta-tcpreplay-v4.2.1_GH0.tar.gz) = 2917066
diff --git a/net-mgmt/tcpreplay/pkg-descr b/net-mgmt/tcpreplay/pkg-descr
index ba9c38b10c41..da133e2affd0 100644
--- a/net-mgmt/tcpreplay/pkg-descr
+++ b/net-mgmt/tcpreplay/pkg-descr
@@ -11,4 +11,4 @@ reproduce the real-world anomalies that appear on production networks
etc.), tcpreplay allows for exact replication of real traffic seen on real
networks.
-WWW: http://tcpreplay.appneta.com/
+WWW: https://github.com/appneta/tcpreplay