aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/horde-kronolith/Makefile9
-rw-r--r--deskutils/horde-kronolith/files/pkg-deinstall.in9
-rw-r--r--deskutils/horde-kronolith/files/pkg-install.in23
-rw-r--r--deskutils/horde-kronolith/pkg-plist3
-rw-r--r--deskutils/horde-mnemo/Makefile9
-rw-r--r--deskutils/horde-mnemo/files/pkg-deinstall.in9
-rw-r--r--deskutils/horde-mnemo/files/pkg-install.in23
-rw-r--r--deskutils/horde-mnemo/pkg-plist1
-rw-r--r--deskutils/horde-nag/Makefile9
-rw-r--r--deskutils/horde-nag/files/pkg-deinstall.in9
-rw-r--r--deskutils/horde-nag/files/pkg-install.in23
-rw-r--r--deskutils/horde-nag/pkg-plist2
-rw-r--r--deskutils/horde4-kronolith/Makefile9
-rw-r--r--deskutils/horde4-kronolith/files/pkg-deinstall.in9
-rw-r--r--deskutils/horde4-kronolith/files/pkg-install.in23
-rw-r--r--deskutils/horde4-kronolith/pkg-plist3
-rw-r--r--deskutils/horde4-mnemo/Makefile9
-rw-r--r--deskutils/horde4-mnemo/files/pkg-deinstall.in9
-rw-r--r--deskutils/horde4-mnemo/files/pkg-install.in23
-rw-r--r--deskutils/horde4-mnemo/pkg-plist1
-rw-r--r--deskutils/horde4-nag/Makefile9
-rw-r--r--deskutils/horde4-nag/files/pkg-deinstall.in9
-rw-r--r--deskutils/horde4-nag/files/pkg-install.in23
-rw-r--r--deskutils/horde4-nag/pkg-plist2
-rw-r--r--deskutils/kronolith/Makefile9
-rw-r--r--deskutils/kronolith/files/pkg-deinstall.in9
-rw-r--r--deskutils/kronolith/files/pkg-install.in23
-rw-r--r--deskutils/kronolith/pkg-plist3
-rw-r--r--deskutils/mnemo/Makefile9
-rw-r--r--deskutils/mnemo/files/pkg-deinstall.in9
-rw-r--r--deskutils/mnemo/files/pkg-install.in23
-rw-r--r--deskutils/mnemo/pkg-plist1
-rw-r--r--deskutils/nag/Makefile9
-rw-r--r--deskutils/nag/files/pkg-deinstall.in9
-rw-r--r--deskutils/nag/files/pkg-install.in23
-rw-r--r--deskutils/nag/pkg-plist2
36 files changed, 261 insertions, 126 deletions
diff --git a/deskutils/horde-kronolith/Makefile b/deskutils/horde-kronolith/Makefile
index d88d410b2b7d..57ca84077c3e 100644
--- a/deskutils/horde-kronolith/Makefile
+++ b/deskutils/horde-kronolith/Makefile
@@ -40,7 +40,7 @@ LKRONOLITHDIR?= ${LHORDEDIR}/kronolith
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= KRONOLITHDIR=${KRONOLITHDIR}
PLIST_SUB= KRONOLITHDIR=${LKRONOLITHDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
@@ -68,11 +68,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${KRONOLITHDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${KRONOLITHDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${KRONOLITHDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-kronolith.conf ${HORDE_INC}
@@ -85,6 +81,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/deskutils/horde-kronolith/files/pkg-deinstall.in b/deskutils/horde-kronolith/files/pkg-deinstall.in
index 896c740dd4da..97d0a7cca145 100644
--- a/deskutils/horde-kronolith/files/pkg-deinstall.in
+++ b/deskutils/horde-kronolith/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%KRONOLITHDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/deskutils/horde-kronolith/files/pkg-install.in b/deskutils/horde-kronolith/files/pkg-install.in
new file mode 100644
index 000000000000..84722b6dc70a
--- /dev/null
+++ b/deskutils/horde-kronolith/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%KRONOLITHDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/deskutils/horde-kronolith/pkg-plist b/deskutils/horde-kronolith/pkg-plist
index 86e9d88a32d9..d21da14948c1 100644
--- a/deskutils/horde-kronolith/pkg-plist
+++ b/deskutils/horde-kronolith/pkg-plist
@@ -13,11 +13,8 @@
%%KRONOLITHDIR%%/calendars.php
%%KRONOLITHDIR%%/config/.htaccess
%%KRONOLITHDIR%%/config/conf.xml
-%%KRONOLITHDIR%%/config/keywords.php
%%KRONOLITHDIR%%/config/keywords.php.dist
-%%KRONOLITHDIR%%/config/menu.php
%%KRONOLITHDIR%%/config/menu.php.dist
-%%KRONOLITHDIR%%/config/prefs.php
%%KRONOLITHDIR%%/config/prefs.php.dist
%%KRONOLITHDIR%%/contacts.php
%%KRONOLITHDIR%%/data.php
diff --git a/deskutils/horde-mnemo/Makefile b/deskutils/horde-mnemo/Makefile
index c768093122c6..c89b828222f1 100644
--- a/deskutils/horde-mnemo/Makefile
+++ b/deskutils/horde-mnemo/Makefile
@@ -30,7 +30,7 @@ USE_GETTEXT= yes
PLIST_SUB= MNEMODIR=${LMNEMODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= MNEMODIR=${MNEMODIR}
REINPLACE_ARGS= -i ""
@@ -66,11 +66,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${MNEMODIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${MNEMODIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${MNEMODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-mnemo.conf ${HORDE_INC}
@@ -83,6 +79,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/deskutils/horde-mnemo/files/pkg-deinstall.in b/deskutils/horde-mnemo/files/pkg-deinstall.in
index 0a40a68d052b..01e0ca9f6e7b 100644
--- a/deskutils/horde-mnemo/files/pkg-deinstall.in
+++ b/deskutils/horde-mnemo/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%MNEMODIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/deskutils/horde-mnemo/files/pkg-install.in b/deskutils/horde-mnemo/files/pkg-install.in
new file mode 100644
index 000000000000..2b5fd65ba10e
--- /dev/null
+++ b/deskutils/horde-mnemo/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%MNEMODIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/deskutils/horde-mnemo/pkg-plist b/deskutils/horde-mnemo/pkg-plist
index e7120e10d320..29af196f3325 100644
--- a/deskutils/horde-mnemo/pkg-plist
+++ b/deskutils/horde-mnemo/pkg-plist
@@ -9,7 +9,6 @@
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
%%MNEMODIR%%/config/.htaccess
%%MNEMODIR%%/config/conf.xml
-%%MNEMODIR%%/config/prefs.php
%%MNEMODIR%%/config/prefs.php.dist
%%MNEMODIR%%/data.php
%%MNEMODIR%%/index.php
diff --git a/deskutils/horde-nag/Makefile b/deskutils/horde-nag/Makefile
index f3ccc17bfe69..cb9a82b04abc 100644
--- a/deskutils/horde-nag/Makefile
+++ b/deskutils/horde-nag/Makefile
@@ -31,7 +31,7 @@ USE_GETTEXT= yes
PLIST_SUB= NAGDIR=${LNAGDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= NAGDIR=${NAGDIR}
REINPLACE_ARGS= -i ""
@@ -67,11 +67,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${NAGDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${NAGDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-nag.conf ${HORDE_INC}
@@ -84,6 +80,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/deskutils/horde-nag/files/pkg-deinstall.in b/deskutils/horde-nag/files/pkg-deinstall.in
index 8f85e546f5d4..6996f090da6d 100644
--- a/deskutils/horde-nag/files/pkg-deinstall.in
+++ b/deskutils/horde-nag/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%NAGDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/deskutils/horde-nag/files/pkg-install.in b/deskutils/horde-nag/files/pkg-install.in
new file mode 100644
index 000000000000..f7ec7e0017b6
--- /dev/null
+++ b/deskutils/horde-nag/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%NAGDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/deskutils/horde-nag/pkg-plist b/deskutils/horde-nag/pkg-plist
index a886f7e308a1..82967b8e0125 100644
--- a/deskutils/horde-nag/pkg-plist
+++ b/deskutils/horde-nag/pkg-plist
@@ -8,9 +8,7 @@
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
%%NAGDIR%%/config/.htaccess
%%NAGDIR%%/config/conf.xml
-%%NAGDIR%%/config/menu.php
%%NAGDIR%%/config/menu.php.dist
-%%NAGDIR%%/config/prefs.php
%%NAGDIR%%/config/prefs.php.dist
%%NAGDIR%%/data.php
%%NAGDIR%%/ics.php
diff --git a/deskutils/horde4-kronolith/Makefile b/deskutils/horde4-kronolith/Makefile
index d88d410b2b7d..57ca84077c3e 100644
--- a/deskutils/horde4-kronolith/Makefile
+++ b/deskutils/horde4-kronolith/Makefile
@@ -40,7 +40,7 @@ LKRONOLITHDIR?= ${LHORDEDIR}/kronolith
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= KRONOLITHDIR=${KRONOLITHDIR}
PLIST_SUB= KRONOLITHDIR=${LKRONOLITHDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
@@ -68,11 +68,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${KRONOLITHDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${KRONOLITHDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${KRONOLITHDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-kronolith.conf ${HORDE_INC}
@@ -85,6 +81,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/deskutils/horde4-kronolith/files/pkg-deinstall.in b/deskutils/horde4-kronolith/files/pkg-deinstall.in
index 896c740dd4da..97d0a7cca145 100644
--- a/deskutils/horde4-kronolith/files/pkg-deinstall.in
+++ b/deskutils/horde4-kronolith/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%KRONOLITHDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/deskutils/horde4-kronolith/files/pkg-install.in b/deskutils/horde4-kronolith/files/pkg-install.in
new file mode 100644
index 000000000000..84722b6dc70a
--- /dev/null
+++ b/deskutils/horde4-kronolith/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%KRONOLITHDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/deskutils/horde4-kronolith/pkg-plist b/deskutils/horde4-kronolith/pkg-plist
index 86e9d88a32d9..d21da14948c1 100644
--- a/deskutils/horde4-kronolith/pkg-plist
+++ b/deskutils/horde4-kronolith/pkg-plist
@@ -13,11 +13,8 @@
%%KRONOLITHDIR%%/calendars.php
%%KRONOLITHDIR%%/config/.htaccess
%%KRONOLITHDIR%%/config/conf.xml
-%%KRONOLITHDIR%%/config/keywords.php
%%KRONOLITHDIR%%/config/keywords.php.dist
-%%KRONOLITHDIR%%/config/menu.php
%%KRONOLITHDIR%%/config/menu.php.dist
-%%KRONOLITHDIR%%/config/prefs.php
%%KRONOLITHDIR%%/config/prefs.php.dist
%%KRONOLITHDIR%%/contacts.php
%%KRONOLITHDIR%%/data.php
diff --git a/deskutils/horde4-mnemo/Makefile b/deskutils/horde4-mnemo/Makefile
index c768093122c6..c89b828222f1 100644
--- a/deskutils/horde4-mnemo/Makefile
+++ b/deskutils/horde4-mnemo/Makefile
@@ -30,7 +30,7 @@ USE_GETTEXT= yes
PLIST_SUB= MNEMODIR=${LMNEMODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= MNEMODIR=${MNEMODIR}
REINPLACE_ARGS= -i ""
@@ -66,11 +66,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${MNEMODIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${MNEMODIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${MNEMODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-mnemo.conf ${HORDE_INC}
@@ -83,6 +79,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/deskutils/horde4-mnemo/files/pkg-deinstall.in b/deskutils/horde4-mnemo/files/pkg-deinstall.in
index 0a40a68d052b..01e0ca9f6e7b 100644
--- a/deskutils/horde4-mnemo/files/pkg-deinstall.in
+++ b/deskutils/horde4-mnemo/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%MNEMODIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/deskutils/horde4-mnemo/files/pkg-install.in b/deskutils/horde4-mnemo/files/pkg-install.in
new file mode 100644
index 000000000000..2b5fd65ba10e
--- /dev/null
+++ b/deskutils/horde4-mnemo/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%MNEMODIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/deskutils/horde4-mnemo/pkg-plist b/deskutils/horde4-mnemo/pkg-plist
index e7120e10d320..29af196f3325 100644
--- a/deskutils/horde4-mnemo/pkg-plist
+++ b/deskutils/horde4-mnemo/pkg-plist
@@ -9,7 +9,6 @@
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
%%MNEMODIR%%/config/.htaccess
%%MNEMODIR%%/config/conf.xml
-%%MNEMODIR%%/config/prefs.php
%%MNEMODIR%%/config/prefs.php.dist
%%MNEMODIR%%/data.php
%%MNEMODIR%%/index.php
diff --git a/deskutils/horde4-nag/Makefile b/deskutils/horde4-nag/Makefile
index f3ccc17bfe69..cb9a82b04abc 100644
--- a/deskutils/horde4-nag/Makefile
+++ b/deskutils/horde4-nag/Makefile
@@ -31,7 +31,7 @@ USE_GETTEXT= yes
PLIST_SUB= NAGDIR=${LNAGDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= NAGDIR=${NAGDIR}
REINPLACE_ARGS= -i ""
@@ -67,11 +67,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${NAGDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${NAGDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-nag.conf ${HORDE_INC}
@@ -84,6 +80,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/deskutils/horde4-nag/files/pkg-deinstall.in b/deskutils/horde4-nag/files/pkg-deinstall.in
index 8f85e546f5d4..6996f090da6d 100644
--- a/deskutils/horde4-nag/files/pkg-deinstall.in
+++ b/deskutils/horde4-nag/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%NAGDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/deskutils/horde4-nag/files/pkg-install.in b/deskutils/horde4-nag/files/pkg-install.in
new file mode 100644
index 000000000000..f7ec7e0017b6
--- /dev/null
+++ b/deskutils/horde4-nag/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%NAGDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/deskutils/horde4-nag/pkg-plist b/deskutils/horde4-nag/pkg-plist
index a886f7e308a1..82967b8e0125 100644
--- a/deskutils/horde4-nag/pkg-plist
+++ b/deskutils/horde4-nag/pkg-plist
@@ -8,9 +8,7 @@
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
%%NAGDIR%%/config/.htaccess
%%NAGDIR%%/config/conf.xml
-%%NAGDIR%%/config/menu.php
%%NAGDIR%%/config/menu.php.dist
-%%NAGDIR%%/config/prefs.php
%%NAGDIR%%/config/prefs.php.dist
%%NAGDIR%%/data.php
%%NAGDIR%%/ics.php
diff --git a/deskutils/kronolith/Makefile b/deskutils/kronolith/Makefile
index d88d410b2b7d..57ca84077c3e 100644
--- a/deskutils/kronolith/Makefile
+++ b/deskutils/kronolith/Makefile
@@ -40,7 +40,7 @@ LKRONOLITHDIR?= ${LHORDEDIR}/kronolith
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= KRONOLITHDIR=${KRONOLITHDIR}
PLIST_SUB= KRONOLITHDIR=${LKRONOLITHDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
@@ -68,11 +68,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${KRONOLITHDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${KRONOLITHDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${KRONOLITHDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-kronolith.conf ${HORDE_INC}
@@ -85,6 +81,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/deskutils/kronolith/files/pkg-deinstall.in b/deskutils/kronolith/files/pkg-deinstall.in
index 896c740dd4da..97d0a7cca145 100644
--- a/deskutils/kronolith/files/pkg-deinstall.in
+++ b/deskutils/kronolith/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%KRONOLITHDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/deskutils/kronolith/files/pkg-install.in b/deskutils/kronolith/files/pkg-install.in
new file mode 100644
index 000000000000..84722b6dc70a
--- /dev/null
+++ b/deskutils/kronolith/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%KRONOLITHDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/deskutils/kronolith/pkg-plist b/deskutils/kronolith/pkg-plist
index 86e9d88a32d9..d21da14948c1 100644
--- a/deskutils/kronolith/pkg-plist
+++ b/deskutils/kronolith/pkg-plist
@@ -13,11 +13,8 @@
%%KRONOLITHDIR%%/calendars.php
%%KRONOLITHDIR%%/config/.htaccess
%%KRONOLITHDIR%%/config/conf.xml
-%%KRONOLITHDIR%%/config/keywords.php
%%KRONOLITHDIR%%/config/keywords.php.dist
-%%KRONOLITHDIR%%/config/menu.php
%%KRONOLITHDIR%%/config/menu.php.dist
-%%KRONOLITHDIR%%/config/prefs.php
%%KRONOLITHDIR%%/config/prefs.php.dist
%%KRONOLITHDIR%%/contacts.php
%%KRONOLITHDIR%%/data.php
diff --git a/deskutils/mnemo/Makefile b/deskutils/mnemo/Makefile
index c768093122c6..c89b828222f1 100644
--- a/deskutils/mnemo/Makefile
+++ b/deskutils/mnemo/Makefile
@@ -30,7 +30,7 @@ USE_GETTEXT= yes
PLIST_SUB= MNEMODIR=${LMNEMODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= MNEMODIR=${MNEMODIR}
REINPLACE_ARGS= -i ""
@@ -66,11 +66,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${MNEMODIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${MNEMODIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${MNEMODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-mnemo.conf ${HORDE_INC}
@@ -83,6 +79,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/deskutils/mnemo/files/pkg-deinstall.in b/deskutils/mnemo/files/pkg-deinstall.in
index 0a40a68d052b..01e0ca9f6e7b 100644
--- a/deskutils/mnemo/files/pkg-deinstall.in
+++ b/deskutils/mnemo/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%MNEMODIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/deskutils/mnemo/files/pkg-install.in b/deskutils/mnemo/files/pkg-install.in
new file mode 100644
index 000000000000..2b5fd65ba10e
--- /dev/null
+++ b/deskutils/mnemo/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%MNEMODIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/deskutils/mnemo/pkg-plist b/deskutils/mnemo/pkg-plist
index e7120e10d320..29af196f3325 100644
--- a/deskutils/mnemo/pkg-plist
+++ b/deskutils/mnemo/pkg-plist
@@ -9,7 +9,6 @@
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
%%MNEMODIR%%/config/.htaccess
%%MNEMODIR%%/config/conf.xml
-%%MNEMODIR%%/config/prefs.php
%%MNEMODIR%%/config/prefs.php.dist
%%MNEMODIR%%/data.php
%%MNEMODIR%%/index.php
diff --git a/deskutils/nag/Makefile b/deskutils/nag/Makefile
index f3ccc17bfe69..cb9a82b04abc 100644
--- a/deskutils/nag/Makefile
+++ b/deskutils/nag/Makefile
@@ -31,7 +31,7 @@ USE_GETTEXT= yes
PLIST_SUB= NAGDIR=${LNAGDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= NAGDIR=${NAGDIR}
REINPLACE_ARGS= -i ""
@@ -67,11 +67,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${NAGDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${NAGDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-nag.conf ${HORDE_INC}
@@ -84,6 +80,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/deskutils/nag/files/pkg-deinstall.in b/deskutils/nag/files/pkg-deinstall.in
index 8f85e546f5d4..6996f090da6d 100644
--- a/deskutils/nag/files/pkg-deinstall.in
+++ b/deskutils/nag/files/pkg-deinstall.in
@@ -12,13 +12,10 @@ if [ -z "${PACKAGE_BUILDING}" ]; then
for cf in `ls %%NAGDIR%%/config/*php`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
- 0) # original config file, will be deleted by pkg-plist
+ 0) # original config file, delete it
+ rm -f $cf
;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
+ 1) # config file has been updated, leave it alone
;;
*) # not found?
;;
diff --git a/deskutils/nag/files/pkg-install.in b/deskutils/nag/files/pkg-install.in
new file mode 100644
index 000000000000..f7ec7e0017b6
--- /dev/null
+++ b/deskutils/nag/files/pkg-install.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%NAGDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/deskutils/nag/pkg-plist b/deskutils/nag/pkg-plist
index a886f7e308a1..82967b8e0125 100644
--- a/deskutils/nag/pkg-plist
+++ b/deskutils/nag/pkg-plist
@@ -8,9 +8,7 @@
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
%%NAGDIR%%/config/.htaccess
%%NAGDIR%%/config/conf.xml
-%%NAGDIR%%/config/menu.php
%%NAGDIR%%/config/menu.php.dist
-%%NAGDIR%%/config/prefs.php
%%NAGDIR%%/config/prefs.php.dist
%%NAGDIR%%/data.php
%%NAGDIR%%/ics.php