aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--benchmarks/wrk/Makefile2
-rw-r--r--benchmarks/wrk/files/patch-Makefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/benchmarks/wrk/Makefile b/benchmarks/wrk/Makefile
index a26e8003e766..3e61aad80265 100644
--- a/benchmarks/wrk/Makefile
+++ b/benchmarks/wrk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wrk
PORTVERSION= 4.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= benchmarks www
DISTNAME= ${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
diff --git a/benchmarks/wrk/files/patch-Makefile b/benchmarks/wrk/files/patch-Makefile
index 6407c911cddd..60d14b8af194 100644
--- a/benchmarks/wrk/files/patch-Makefile
+++ b/benchmarks/wrk/files/patch-Makefile
@@ -1,5 +1,5 @@
--- Makefile.orig 2015-03-24 13:03:52.000000000 +0300
-+++ Makefile 2015-05-31 22:58:26.276469000 +0300
++++ Makefile 2015-06-02 22:37:10.831330000 +0300
@@ -1,5 +1,5 @@
-CFLAGS := -std=c99 -Wall -O2 -D_REENTRANT
-LIBS := -lpthread -lm -lcrypto -lssl
@@ -38,7 +38,7 @@
$(ODIR)/bytecode.o: src/wrk.lua
@echo LUAJIT $<
- @$(SHELL) -c 'cd $(LDIR) && ./luajit -b $(CURDIR)/$< $(CURDIR)/$@'
-+ $(SHELL) -c 'cd $(LDIR) && ${PREFIX}/bin/luajit -b $(CURDIR)/$< $(CURDIR)/$@'
++ $(SHELL) -c '${PREFIX}/bin/luajit -b $(CURDIR)/$< $(CURDIR)/$@'
$(ODIR)/%.o : %.c
@echo CC $<