aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/hadoop/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/hadoop/Makefile b/devel/hadoop/Makefile
index 8948cfb7580d..a7723c70e86c 100644
--- a/devel/hadoop/Makefile
+++ b/devel/hadoop/Makefile
@@ -78,7 +78,11 @@ MAKE_ARGS= -Dbuild.classes=${WRKSRC}/hadoop-core-${PORTVERSION}.jar -Dversion=${
-Dcompile.c++=true -Dmake.cmd=gmake -Dlibhdfs=1 -Dlibrecordio=true -Dskip.record-parser=true
ALL_TARGET= compile-core-native compile-c++ compile-c++-libhdfs compile-c++-pipes compile-c++-utils
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+# The ssl.mk helper can augment MAKE_ARGS and break the build. Filter out
+# the OPENSSL_CFLAGS if it exists to prevent that from happening.
+MAKE_ARGS:= ${MAKE_ARGS:NOPENSSL_CFLAGS=*}
.if ${ARCH} == "amd64"
_HADOOP_ARCH= FreeBSD-amd64-64
@@ -142,4 +146,4 @@ do-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>