aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/ksmoothdock/Makefile12
-rw-r--r--deskutils/ksmoothdock/distinfo6
-rw-r--r--deskutils/ksmoothdock/files/patch-src::Makefile.in11
-rw-r--r--deskutils/ksmoothdock/files/patch-src__buttonisedstate.h11
-rw-r--r--deskutils/ksmoothdock/files/patch-src__desktopselector.cpp11
-rw-r--r--deskutils/ksmoothdock/files/patch-src__iconbaseddockitem.cpp20
-rw-r--r--deskutils/ksmoothdock/files/patch-src__ksmoothdock.cpp10
-rw-r--r--deskutils/ksmoothdock/files/patch-src__ksmoothdock.h10
-rw-r--r--deskutils/ksmoothdock/files/patch-src__normalzoomstate.cpp10
-rw-r--r--deskutils/ksmoothdock/files/patch-src__normalzoomstate.h10
-rw-r--r--deskutils/ksmoothdock/files/patch-src__paraboliczoomstate.cpp10
-rw-r--r--deskutils/ksmoothdock/files/patch-src__paraboliczoomstate.h10
-rw-r--r--deskutils/ksmoothdock/files/patch-src__task.cpp16
13 files changed, 129 insertions, 18 deletions
diff --git a/deskutils/ksmoothdock/Makefile b/deskutils/ksmoothdock/Makefile
index 65ff921268e3..77d03b50569c 100644
--- a/deskutils/ksmoothdock/Makefile
+++ b/deskutils/ksmoothdock/Makefile
@@ -6,18 +6,22 @@
#
PORTNAME= ksmoothdock
-PORTVERSION= 3.6.1
+PORTVERSION= 4.3
CATEGORIES= deskutils kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}_automake1.9
MAINTAINER= ports@FreeBSD.org
COMMENT= A dock program for KDE with smooth zooming
-USE_AUTOTOOLS= libtool:15
+USE_KDELIBS_VER= 3
USE_GMAKE= yes
-USE_KDELIBS_VER=3
+USE_AUTOTOOLS= autoconf:259:env automake:19:env libtool:15:env
+GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+pre-configure:
+ @cd ${WRKSRC}/admin && ${RM} -f ltmain.sh && ${CP} -f ${LTMAIN} .
+ @cd ${WRKSRC} && ${GMAKE} -f admin/Makefile.common
.include <bsd.port.mk>
diff --git a/deskutils/ksmoothdock/distinfo b/deskutils/ksmoothdock/distinfo
index 9efee17707f4..c8d017caf8b9 100644
--- a/deskutils/ksmoothdock/distinfo
+++ b/deskutils/ksmoothdock/distinfo
@@ -1,3 +1,3 @@
-MD5 (ksmoothdock-3.6.1.tar.gz) = f6d69c5d74de55f86bdc92e835df6cb8
-SHA256 (ksmoothdock-3.6.1.tar.gz) = 751ba7da13aed4780bc7f4e7d0f6b4d5c9f5029bb025976487a2d833b00849bb
-SIZE (ksmoothdock-3.6.1.tar.gz) = 800535
+MD5 (ksmoothdock-4.3_automake1.9.tar.gz) = fa75237f0b1102d31dc2b60304ab59fc
+SHA256 (ksmoothdock-4.3_automake1.9.tar.gz) = 3ec73d65107a03228a10afafac20e6ad9a0d7e16d469975dc14e2dd027718f27
+SIZE (ksmoothdock-4.3_automake1.9.tar.gz) = 606767
diff --git a/deskutils/ksmoothdock/files/patch-src::Makefile.in b/deskutils/ksmoothdock/files/patch-src::Makefile.in
deleted file mode 100644
index d3975166d05b..000000000000
--- a/deskutils/ksmoothdock/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Tue Jan 24 00:48:28 2006
-+++ src/Makefile.in Tue Jan 24 00:48:32 2006
-@@ -448,7 +448,7 @@
- done
- ksmoothdock$(EXEEXT): $(ksmoothdock_OBJECTS) $(ksmoothdock_DEPENDENCIES)
- @rm -f ksmoothdock$(EXEEXT)
-- $(CXXLINK) $(ksmoothdock_LDFLAGS) $(ksmoothdock_OBJECTS) $(ksmoothdock_LDADD) $(LIBS)
-+ $(CXXLINK) $(ksmoothdock_LDFLAGS) $(ksmoothdock_OBJECTS) $(ksmoothdock_LDADD) $(LIBS) $(KDE_MT_LIBS)
-
- mostlyclean-compile:
- -rm -f *.$(OBJEXT)
diff --git a/deskutils/ksmoothdock/files/patch-src__buttonisedstate.h b/deskutils/ksmoothdock/files/patch-src__buttonisedstate.h
new file mode 100644
index 000000000000..d3059cae8ca0
--- /dev/null
+++ b/deskutils/ksmoothdock/files/patch-src__buttonisedstate.h
@@ -0,0 +1,11 @@
+--- src/buttonisedstate.h.orig Sat Sep 16 05:10:50 2006
++++ src/buttonisedstate.h Thu Mar 15 17:24:14 2007
+@@ -20,6 +20,8 @@
+ #ifndef BUTTONISEDSTATE_H
+ #define BUTTONISEDSTATE_H
+
++#include <memory>
++
+ #include <qobject.h>
+ #include "dockstate.h"
+
diff --git a/deskutils/ksmoothdock/files/patch-src__desktopselector.cpp b/deskutils/ksmoothdock/files/patch-src__desktopselector.cpp
new file mode 100644
index 000000000000..01b943662196
--- /dev/null
+++ b/deskutils/ksmoothdock/files/patch-src__desktopselector.cpp
@@ -0,0 +1,11 @@
+--- src/desktopselector.cpp.orig Thu Nov 16 05:33:29 2006
++++ src/desktopselector.cpp Thu Mar 15 17:24:14 2007
+@@ -45,7 +45,7 @@
+
+ void DesktopSelector::draw(QPixmap& buffer, int x, int y, int size) {
+ if (size >= m_minSize && size <= m_maxSize) {
+- bitBlt(&buffer, x, y, &m_icons.at(size - m_minSize));
++ bitBlt(&buffer, x, y, &m_icons[size - m_minSize]);
+
+ QPainter p(&buffer);
+ if (KWin::currentDesktop() == m_targetDesktop)
diff --git a/deskutils/ksmoothdock/files/patch-src__iconbaseddockitem.cpp b/deskutils/ksmoothdock/files/patch-src__iconbaseddockitem.cpp
new file mode 100644
index 000000000000..e1a55680a3db
--- /dev/null
+++ b/deskutils/ksmoothdock/files/patch-src__iconbaseddockitem.cpp
@@ -0,0 +1,20 @@
+--- src/iconbaseddockitem.cpp.orig Thu Jun 8 09:25:54 2006
++++ src/iconbaseddockitem.cpp Thu Mar 15 17:24:14 2007
+@@ -86,7 +86,7 @@
+ s = m_maxSize;
+ }
+
+- return m_icons.at(s - m_minSize);
++ return m_icons[s - m_minSize];
+ }
+
+ /**
+@@ -109,7 +109,7 @@
+
+ void IconBasedDockItem::draw(QPixmap& buffer, int x, int y, int size) {
+ if (size >= m_minSize && size <= m_maxSize)
+- bitBlt(&buffer, x, y, &m_icons.at(size - m_minSize));
++ bitBlt(&buffer, x, y, &m_icons[size - m_minSize]);
+ }
+
+ /**
diff --git a/deskutils/ksmoothdock/files/patch-src__ksmoothdock.cpp b/deskutils/ksmoothdock/files/patch-src__ksmoothdock.cpp
new file mode 100644
index 000000000000..70d9bf4ad595
--- /dev/null
+++ b/deskutils/ksmoothdock/files/patch-src__ksmoothdock.cpp
@@ -0,0 +1,10 @@
+--- src/ksmoothdock.cpp.orig Thu Nov 16 06:00:33 2006
++++ src/ksmoothdock.cpp Thu Mar 15 17:24:14 2007
+@@ -24,6 +24,7 @@
+
+ #include <iostream>
+ #include <iterator>
++#include <typeinfo>
+
+ #include <qdir.h>
+
diff --git a/deskutils/ksmoothdock/files/patch-src__ksmoothdock.h b/deskutils/ksmoothdock/files/patch-src__ksmoothdock.h
new file mode 100644
index 000000000000..ca7b04d87acc
--- /dev/null
+++ b/deskutils/ksmoothdock/files/patch-src__ksmoothdock.h
@@ -0,0 +1,10 @@
+--- src/ksmoothdock.h.orig Thu Nov 16 06:02:06 2006
++++ src/ksmoothdock.h Thu Mar 15 17:24:14 2007
+@@ -26,6 +26,7 @@
+ #include <config.h>
+ #endif
+
++#include <memory>
+ #include <vector>
+
+ #include <qwidget.h>
diff --git a/deskutils/ksmoothdock/files/patch-src__normalzoomstate.cpp b/deskutils/ksmoothdock/files/patch-src__normalzoomstate.cpp
new file mode 100644
index 000000000000..94be385cfe40
--- /dev/null
+++ b/deskutils/ksmoothdock/files/patch-src__normalzoomstate.cpp
@@ -0,0 +1,10 @@
+--- src/normalzoomstate.cpp.orig Fri Nov 17 20:07:22 2006
++++ src/normalzoomstate.cpp Thu Mar 15 17:24:14 2007
+@@ -20,6 +20,7 @@
+ #include "normalzoomstate.h"
+
+ #include <iostream>
++#include <typeinfo>
+ #include <unistd.h>
+
+ #include <qapplication.h>
diff --git a/deskutils/ksmoothdock/files/patch-src__normalzoomstate.h b/deskutils/ksmoothdock/files/patch-src__normalzoomstate.h
new file mode 100644
index 000000000000..fd76a1ca217d
--- /dev/null
+++ b/deskutils/ksmoothdock/files/patch-src__normalzoomstate.h
@@ -0,0 +1,10 @@
+--- src/normalzoomstate.h.orig Wed Nov 15 21:01:02 2006
++++ src/normalzoomstate.h Thu Mar 15 17:24:14 2007
+@@ -28,6 +28,7 @@
+ * @author the KSmoothDock team <dangvd@yahoo.com>
+ */
+
++#include <memory>
+ #include <vector>
+
+ #include <qtimer.h>
diff --git a/deskutils/ksmoothdock/files/patch-src__paraboliczoomstate.cpp b/deskutils/ksmoothdock/files/patch-src__paraboliczoomstate.cpp
new file mode 100644
index 000000000000..59466a50ab49
--- /dev/null
+++ b/deskutils/ksmoothdock/files/patch-src__paraboliczoomstate.cpp
@@ -0,0 +1,10 @@
+--- src/paraboliczoomstate.cpp.orig Fri Nov 17 20:10:57 2006
++++ src/paraboliczoomstate.cpp Thu Mar 15 17:24:14 2007
+@@ -20,6 +20,7 @@
+ #include "paraboliczoomstate.h"
+
+ #include <iostream>
++#include <typeinfo>
+ #include <unistd.h>
+
+ #include <qapplication.h>
diff --git a/deskutils/ksmoothdock/files/patch-src__paraboliczoomstate.h b/deskutils/ksmoothdock/files/patch-src__paraboliczoomstate.h
new file mode 100644
index 000000000000..df2f199ca714
--- /dev/null
+++ b/deskutils/ksmoothdock/files/patch-src__paraboliczoomstate.h
@@ -0,0 +1,10 @@
+--- src/paraboliczoomstate.h.orig Wed Nov 15 23:33:25 2006
++++ src/paraboliczoomstate.h Thu Mar 15 17:24:14 2007
+@@ -28,6 +28,7 @@
+ * @author the KSmoothDock team <dangvd@yahoo.com>
+ */
+
++#include <memory>
+ #include <vector>
+
+ #include <qtimer.h>
diff --git a/deskutils/ksmoothdock/files/patch-src__task.cpp b/deskutils/ksmoothdock/files/patch-src__task.cpp
new file mode 100644
index 000000000000..beb6c4824fe0
--- /dev/null
+++ b/deskutils/ksmoothdock/files/patch-src__task.cpp
@@ -0,0 +1,16 @@
+--- src/task.cpp.orig Tue Nov 7 03:17:19 2006
++++ src/task.cpp Thu Mar 15 17:24:14 2007
+@@ -46,11 +46,11 @@
+ void Task::draw(QPixmap& buffer, int x, int y, int size) {
+ if (size >= m_minSize && size <= m_maxSize) {
+ if (m_demandsAttention && (m_timerCount == 1)) {
+- KPixmap pix(m_icons.at(size - m_minSize));
++ KPixmap pix(m_icons[size - m_minSize]);
+ KPixmapEffect::fade(pix, 0.5, QColor("#ffffff"));
+ bitBlt(&buffer, x, y, &pix);
+ } else {
+- bitBlt(&buffer, x, y, &m_icons.at(size - m_minSize));
++ bitBlt(&buffer, x, y, &m_icons[size - m_minSize]);
+ }
+ }
+ }