aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile2
-rw-r--r--devel/py-pyasn1/Makefile (renamed from devel/py-asn1/Makefile)4
-rw-r--r--devel/py-pyasn1/distinfo (renamed from devel/py-asn1/distinfo)0
-rw-r--r--devel/py-pyasn1/pkg-descr (renamed from devel/py-asn1/pkg-descr)0
-rw-r--r--net-im/gajim/Makefile3
-rw-r--r--net-mgmt/py-snmp4/Makefile3
-rw-r--r--net-p2p/tribler/Makefile4
-rw-r--r--net/py-impacket/Makefile3
-rw-r--r--net/py-ldap3/Makefile3
-rw-r--r--net/py-ndg_httpsclient/Makefile4
-rw-r--r--net/py-netlib/Makefile3
-rw-r--r--net/py-pysmb/Makefile3
-rw-r--r--security/py-acme/Makefile3
-rw-r--r--security/py-cryptography/Makefile4
-rw-r--r--security/py-oauth2client/Makefile4
-rw-r--r--security/py-rsa/Makefile3
-rw-r--r--security/py-service_identity/Makefile4
-rw-r--r--security/py-twistedConch/Makefile3
-rw-r--r--sysutils/azure-agent/Makefile3
-rw-r--r--www/mitmproxy/Makefile3
21 files changed, 35 insertions, 25 deletions
diff --git a/MOVED b/MOVED
index 0159a76607a3..a64b8600c9e6 100644
--- a/MOVED
+++ b/MOVED
@@ -7941,3 +7941,4 @@ devel/py-experimental.cssselect||2015-11-15|The only consumer of this port switc
databases/mariadb-client||2015-11-18|Vulnerable, no updates expected, use mariadb55 or mariadb100 instead
databases/mariadb-server||2015-11-18|Vulnerable, no updates expected, use mariadb55 or mariadb100 instead
databases/mariadb-scripts||2015-11-18|Vulnerable, no updates expected, use mariadb55 or mariadb100 instead
+devel/py-asn1|devel/py-pyasn1|2015-11-18|Renamed to match upstream naming
diff --git a/devel/Makefile b/devel/Makefile
index df5156228177..a20c932135f7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3906,7 +3906,6 @@
SUBDIR += py-argh
SUBDIR += py-argparse
SUBDIR += py-args
- SUBDIR += py-asn1
SUBDIR += py-aspects
SUBDIR += py-aspyct
SUBDIR += py-astroid
@@ -4185,6 +4184,7 @@
SUBDIR += py-pudb
SUBDIR += py-px
SUBDIR += py-py
+ SUBDIR += py-pyasn1
SUBDIR += py-pyasn1-modules
SUBDIR += py-pycalendar
SUBDIR += py-pycallgraph
diff --git a/devel/py-asn1/Makefile b/devel/py-pyasn1/Makefile
index 26b99bfd0d9c..013402c54858 100644
--- a/devel/py-asn1/Makefile
+++ b/devel/py-pyasn1/Makefile
@@ -1,13 +1,11 @@
# Created by: Martin Jackson <mhjacks@swbell.net>
# $FreeBSD$
-PORTNAME= asn1
+PORTNAME= pyasn1
PORTVERSION= 0.1.8
-PORTEPOCH= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= mhjacks@swbell.net
COMMENT= ASN.1 toolkit for Python
diff --git a/devel/py-asn1/distinfo b/devel/py-pyasn1/distinfo
index 1747c09436cb..1747c09436cb 100644
--- a/devel/py-asn1/distinfo
+++ b/devel/py-pyasn1/distinfo
diff --git a/devel/py-asn1/pkg-descr b/devel/py-pyasn1/pkg-descr
index 0d46f8998982..0d46f8998982 100644
--- a/devel/py-asn1/pkg-descr
+++ b/devel/py-pyasn1/pkg-descr
diff --git a/net-im/gajim/Makefile b/net-im/gajim/Makefile
index e84c00c22361..eec885f6a654 100644
--- a/net-im/gajim/Makefile
+++ b/net-im/gajim/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gajim
PORTVERSION= 0.16.4
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://gajim.org/downloads/0.16/
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>=0:${PORTSDIR}/security/py-openssl \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}asn1>=0:${PORTSDIR}/devel/py-asn1 \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>=0:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}nbxmpp>0:${PORTSDIR}/net-im/py-nbxmpp
NO_ARCH= yes
diff --git a/net-mgmt/py-snmp4/Makefile b/net-mgmt/py-snmp4/Makefile
index 71fce5d7fe0d..8e33fbd1c7a0 100644
--- a/net-mgmt/py-snmp4/Makefile
+++ b/net-mgmt/py-snmp4/Makefile
@@ -3,6 +3,7 @@
PORTNAME= snmp4
PORTVERSION= 4.2.5
+PORTREVISION= 1
CATEGORIES= net-mgmt python
MASTER_SITES= CHEESESHOP \
SF/pysnmp/pysnmp/${PORTVERSION}
@@ -14,7 +15,7 @@ COMMENT= SNMP framework for Python
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.2:${PORTSDIR}/devel/py-asn1 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.2:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}pycrypto>=2.4.1:${PORTSDIR}/security/py-pycrypto
USES= python
diff --git a/net-p2p/tribler/Makefile b/net-p2p/tribler/Makefile
index 3d2faa5881b0..82d8b0c106c7 100644
--- a/net-p2p/tribler/Makefile
+++ b/net-p2p/tribler/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tribler
PORTVERSION= 6.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p
MASTER_SITES= https://github.com/Tribler/tribler/releases/download/${PORTVERSION:S/^/v/}/
DISTFILES= ${PORTNAME}_${PORTVERSION}_all.deb
@@ -16,7 +16,7 @@ LICENSE_COMB= multi
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}apsw>0:${PORTSDIR}/databases/py-apsw \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.7:${PORTSDIR}/devel/py-asn1 \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.7:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
${PYTHON_PKGNAMEPREFIX}gmpy>0:${PORTSDIR}/math/py-gmpy \
${PYTHON_PKGNAMEPREFIX}netifaces>0:${PORTSDIR}/net/py-netifaces \
diff --git a/net/py-impacket/Makefile b/net/py-impacket/Makefile
index 1912255d23da..1bff82aa0906 100644
--- a/net/py-impacket/Makefile
+++ b/net/py-impacket/Makefile
@@ -3,6 +3,7 @@
PORTNAME= impacket
PORTVERSION= 0.9.13
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP \
https://github.com/CoreSecurity/impacket/releases/download/impacket_${PORTVERSION:S,.,_,g}/
@@ -14,7 +15,7 @@ COMMENT= Collection of Python classes providing access to network packets
LICENSE= APACHE11
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0:${PORTSDIR}/devel/py-asn1 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}pcapy>=0:${PORTSDIR}/net/py-pcapy \
${PYTHON_PKGNAMEPREFIX}pycrypto>=0:${PORTSDIR}/security/py-pycrypto
diff --git a/net/py-ldap3/Makefile b/net/py-ldap3/Makefile
index 9d99bbe72a11..0b2e6c54730f 100644
--- a/net/py-ldap3/Makefile
+++ b/net/py-ldap3/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ldap3
PORTVERSION= 0.9.9.2
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,7 @@ COMMENT= Strictly RFC 4511 conforming LDAP V3 pure Python client
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>0:${PORTSDIR}/devel/py-asn1
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>0:${PORTSDIR}/devel/py-pyasn1
NO_ARCH= yes
USES= python
diff --git a/net/py-ndg_httpsclient/Makefile b/net/py-ndg_httpsclient/Makefile
index 260ce583a836..d0636f21aa12 100644
--- a/net/py-ndg_httpsclient/Makefile
+++ b/net/py-ndg_httpsclient/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ndg_httpsclient
PORTVERSION= 0.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net python
MASTER_SITES= CHEESESHOP/source/n/ndg-httpsclient
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ COMMENT= Enhance HTTPS support for httplib and urllib2
LICENSE= BSD3CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.4:${PORTSDIR}/devel/py-asn1 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.4:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}openssl>=0.13:${PORTSDIR}/security/py-openssl
NO_ARCH= yes
diff --git a/net/py-netlib/Makefile b/net/py-netlib/Makefile
index e757c798ce4b..042f5c76efcf 100644
--- a/net/py-netlib/Makefile
+++ b/net/py-netlib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= netlib
PORTVERSION= 0.10
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,7 @@ COMMENT= Collection of network utilities
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>0:${PORTSDIR}/devel/py-asn1 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>0:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}openssl>0:${PORTSDIR}/security/py-openssl
USES= python
diff --git a/net/py-pysmb/Makefile b/net/py-pysmb/Makefile
index 442663235b40..e0d98b7d5cf9 100644
--- a/net/py-pysmb/Makefile
+++ b/net/py-pysmb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pysmb
PORTVERSION= 1.1.17
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP \
http://miketeo.net/files/Projects/${PORTNAME}/
@@ -14,7 +15,7 @@ COMMENT= SMB/CIFS library written in Python
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0:${PORTSDIR}/devel/py-asn1
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0:${PORTSDIR}/devel/py-pyasn1
OPTIONS_DEFINE= DOCS
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index 9f844bcb563f..b50aa0a702f7 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PORTNAME= acme
+PORTREVISION= 1
DISTVERSIONPREFIX= v
DISTVERSION= 0.0.0.dev20151104
CATEGORIES= security python
@@ -12,7 +13,7 @@ COMMENT= ACME implementation
LICENSE= APACHE20
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>0:${PORTSDIR}/devel/py-asn1 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>0:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}cryptography>=0.8:${PORTSDIR}/security/py-cryptography \
${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:${PORTSDIR}/devel/py-mock \
${PYTHON_PKGNAMEPREFIX}ndg_httpsclient>=0.4.0:${PORTSDIR}/net/py-ndg_httpsclient \
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 47293b31c864..2fb0922a2ed5 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cryptography
PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:${PORTSDIR}/devel/py-cffi
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4.1:${PORTSDIR}/devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.8:${PORTSDIR}/devel/py-asn1 \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.8:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:${PORTSDIR}/devel/py-cffi \
${PYTHON_PKGNAMEPREFIX}idna>=2.0:${PORTSDIR}/dns/py-idna
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest \
diff --git a/security/py-oauth2client/Makefile b/security/py-oauth2client/Makefile
index 7237f1f0fbc8..55f52f55ed49 100644
--- a/security/py-oauth2client/Makefile
+++ b/security/py-oauth2client/Makefile
@@ -3,7 +3,7 @@
PORTNAME= oauth2client
PORTVERSION= 1.4.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ COMMENT= OAuth 2.0 client library
LICENSE= APACHE20
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.7:${PORTSDIR}/devel/py-asn1 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.7:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}pyasn1-modules>=0.0.5:${PORTSDIR}/devel/py-pyasn1-modules \
${PYTHON_PKGNAMEPREFIX}httplib2>=0.9.1:${PORTSDIR}/www/py-httplib2 \
${PYTHON_PKGNAMEPREFIX}rsa>=3.1.4:${PORTSDIR}/security/py-rsa \
diff --git a/security/py-rsa/Makefile b/security/py-rsa/Makefile
index 5e468b48f5a1..a2b9f27c479e 100644
--- a/security/py-rsa/Makefile
+++ b/security/py-rsa/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rsa
PORTVERSION= 3.1.4
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,7 @@ COMMENT= Pure-Python RSA implementation
LICENSE= APACHE20
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.3:${PORTSDIR}/devel/py-asn1
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.3:${PORTSDIR}/devel/py-pyasn1
TEST_DEPENDS:= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2 \
${RUN_DEPENDS}
diff --git a/security/py-service_identity/Makefile b/security/py-service_identity/Makefile
index 2f6da9c23e01..9095d0753dd5 100644
--- a/security/py-service_identity/Makefile
+++ b/security/py-service_identity/Makefile
@@ -3,7 +3,7 @@
PORTNAME= service_identity
PORTVERSION= 14.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +15,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>=0.14:${PORTSDIR}/security/py-openssl \
- ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.7:${PORTSDIR}/devel/py-asn1 \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.7:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}pyasn1-modules>=0.0.5:${PORTSDIR}/devel/py-pyasn1-modules \
${PYTHON_PKGNAMEPREFIX}characteristic>=14.0.0:${PORTSDIR}/devel/py-characteristic
diff --git a/security/py-twistedConch/Makefile b/security/py-twistedConch/Makefile
index d0f8775bc068..fdf7898030b8 100644
--- a/security/py-twistedConch/Makefile
+++ b/security/py-twistedConch/Makefile
@@ -3,6 +3,7 @@
PORTNAME= twistedConch
PORTVERSION= 15.2.1
+PORTREVISION= 1
CATEGORIES= security devel python
MASTER_SITES= http://twistedmatrix.com/Releases/Conch/${PORTVERSION:R}/ \
LOCAL/sunpoet
@@ -14,7 +15,7 @@ COMMENT= SSH and SFTP protocol implementation with clients and servers
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.0.9a:${PORTSDIR}/devel/py-asn1
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.0.9a:${PORTSDIR}/devel/py-pyasn1
NO_ARCH= yes
USE_PYTHON= autoplist distutils
diff --git a/sysutils/azure-agent/Makefile b/sysutils/azure-agent/Makefile
index 658a7bf19bfa..30e01c02952d 100644
--- a/sysutils/azure-agent/Makefile
+++ b/sysutils/azure-agent/Makefile
@@ -2,6 +2,7 @@
PORTNAME= azure-agent
PORTVERSION= ${GH_TAGNAME}.11
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= gjb@FreeBSD.org
@@ -12,7 +13,7 @@ LICENSE= APACHE20
RUN_DEPENDS= python:${PORTSDIR}/lang/python \
sudo:${PORTSDIR}/security/sudo \
bash:${PORTSDIR}/shells/bash \
- ${PYTHON_PKGNAMEPREFIX}asn1>=0:${PORTSDIR}/devel/py-asn1
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>=0:${PORTSDIR}/devel/py-pyasn1
NO_BUILD= yes
USES= python:2
diff --git a/www/mitmproxy/Makefile b/www/mitmproxy/Makefile
index c49d05245058..5168f95c3dc4 100644
--- a/www/mitmproxy/Makefile
+++ b/www/mitmproxy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mitmproxy
PORTVERSION= 0.10.1
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= http://mitmproxy.org/download/
@@ -11,7 +12,7 @@ COMMENT= SSL-capable man-in-the-middle proxy
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>0:${PORTSDIR}/devel/py-asn1 \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>0:${PORTSDIR}/devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}Flask>0:${PORTSDIR}/www/py-flask \
${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}netlib>0:${PORTSDIR}/net/py-netlib \