aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/png/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 7f76fb96f5a5..0cde498feebe 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -30,15 +30,14 @@ PNGTEST_DESC=Enable Regression Test (recommended)
PATCHFILES= ${DISTNAME}-apng.patch.gz
.endif
+# Do not fail until https://sourceforge.net/p/libpng/bugs/243/ is fixed
.if ${PORT_OPTIONS:MPNGTEST}
post-build:
(cd ${BUILD_WRKSRC}; if ! ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} test; then \
- if [ x != x${BUILD_FAIL_MESSAGE} ] ; then \
- ${ECHO_MSG} "===> Compilation failed unexpectedly."; \
- (${ECHO_CMD} ${BUILD_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
- fi; \
- ${FALSE}; \
- fi)
+ if [ -f ${WRKSRC}/test-suite.log ]; then \
+ ${CAT} ${WRKSRC}/test-suite.log ; \
+ fi; \
+ fi)
.endif
.include <bsd.port.mk>