aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/e2fsprogs-libblkid/Makefile2
-rw-r--r--misc/e2fsprogs-libuuid/Makefile2
-rw-r--r--sysutils/e2fsprogs/Makefile4
-rw-r--r--sysutils/e2fsprogs/distinfo6
-rw-r--r--sysutils/e2fsprogs/files/patch-lib_ext2fs_unix__io.c60
-rw-r--r--sysutils/e2fsprogs/pkg-plist6
6 files changed, 9 insertions, 71 deletions
diff --git a/misc/e2fsprogs-libblkid/Makefile b/misc/e2fsprogs-libblkid/Makefile
index 6dc4357530a6..6f4e35e8dbbf 100644
--- a/misc/e2fsprogs-libblkid/Makefile
+++ b/misc/e2fsprogs-libblkid/Makefile
@@ -1,7 +1,7 @@
# Created by: Matthias Andree <matthias.andree@gmx.de>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= misc devel
PKGNAMESUFFIX= -libblkid
diff --git a/misc/e2fsprogs-libuuid/Makefile b/misc/e2fsprogs-libuuid/Makefile
index 7cd04de058ec..60f779ef0e67 100644
--- a/misc/e2fsprogs-libuuid/Makefile
+++ b/misc/e2fsprogs-libuuid/Makefile
@@ -1,7 +1,7 @@
# Created by: Matthias Andree <matthias.andree@gmx.de>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= misc devel
PKGNAMESUFFIX= -libuuid
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 01604b53d8dc..7c808dde72da 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= e2fsprogs
-PORTVERSION= 1.43.3
-PORTREVISION?= 3
+PORTVERSION= 1.43.4
+PORTREVISION?= 0
CATEGORIES?= sysutils
MASTER_SITES= KERNEL_ORG/linux/kernel/people/tytso/${PORTNAME}/v${PORTVERSION}
diff --git a/sysutils/e2fsprogs/distinfo b/sysutils/e2fsprogs/distinfo
index 907fb1b1176e..2c62d12f20f9 100644
--- a/sysutils/e2fsprogs/distinfo
+++ b/sysutils/e2fsprogs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1473526034
-SHA256 (e2fsprogs-1.43.3.tar.xz) = 744ca4e9a8e6c943601b2744d1ae658e5f37d35b5ea5b1dea86985320bd87f37
-SIZE (e2fsprogs-1.43.3.tar.xz) = 5220304
+TIMESTAMP = 1486335180
+SHA256 (e2fsprogs-1.43.4.tar.xz) = 54b3f21123a531a6a536b9cdcc21344b0122a72790dbe4dacc98e64db25e4a24
+SIZE (e2fsprogs-1.43.4.tar.xz) = 5265788
diff --git a/sysutils/e2fsprogs/files/patch-lib_ext2fs_unix__io.c b/sysutils/e2fsprogs/files/patch-lib_ext2fs_unix__io.c
deleted file mode 100644
index 4e7ae25ab81d..000000000000
--- a/sysutils/e2fsprogs/files/patch-lib_ext2fs_unix__io.c
+++ /dev/null
@@ -1,60 +0,0 @@
---- lib/ext2fs/unix_io.c.orig 2016-09-02 04:17:32 UTC
-+++ lib/ext2fs/unix_io.c
-@@ -188,16 +188,24 @@ static errcode_t raw_read_blk(io_channel
- * The buffer or size which we're trying to read isn't aligned
- * to the O_DIRECT rules, so we need to do this the hard way...
- */
-- while (size > 0) {
-- actual = read(data->dev, data->bounce, channel->block_size);
-- if (actual != channel->block_size)
-- goto short_read;
-- actual = size;
-- if (size > channel->block_size)
-- actual = channel->block_size;
-- memcpy(buf, data->bounce, actual);
-- size -= actual;
-- buf += actual;
-+ {
-+ ssize_t really_read = 0;
-+ while (size > 0) {
-+ actual = read(data->dev, data->bounce, channel->block_size);
-+ if (actual != channel->block_size) {
-+ actual = really_read;
-+ buf -= really_read;
-+ size += really_read;
-+ goto short_read;
-+ }
-+ actual = size;
-+ if (size > channel->block_size)
-+ actual = channel->block_size;
-+ memcpy(buf, data->bounce, actual);
-+ really_read += actual;
-+ size -= actual;
-+ buf += actual;
-+ }
- }
- return 0;
-
-@@ -283,8 +291,12 @@ static errcode_t raw_write_blk(io_channe
- actual = read(data->dev, data->bounce,
- channel->block_size);
- if (actual != channel->block_size) {
-- retval = EXT2_ET_SHORT_READ;
-- goto error_out;
-+ if (actual >= 0) {
-+ memset(data->bounce + actual, 0, channel->block_size - actual);
-+ } else {
-+ retval = EXT2_ET_SHORT_READ;
-+ goto error_out;
-+ }
- }
- }
- actual = size;
-@@ -300,6 +312,7 @@ static errcode_t raw_write_blk(io_channe
- goto short_write;
- size -= actual;
- buf += actual;
-+ location += actual;
- }
- return 0;
-
diff --git a/sysutils/e2fsprogs/pkg-plist b/sysutils/e2fsprogs/pkg-plist
index b9346c3affb7..96c55c45262c 100644
--- a/sysutils/e2fsprogs/pkg-plist
+++ b/sysutils/e2fsprogs/pkg-plist
@@ -22,11 +22,9 @@ man/man8/tune2fs.8.gz
man/man8/fsck.ext2.8.gz
man/man8/fsck.ext3.8.gz
man/man8/fsck.ext4.8.gz
-man/man8/fsck.ext4dev.8.gz
man/man8/mkfs.ext2.8.gz
man/man8/mkfs.ext3.8.gz
man/man8/mkfs.ext4.8.gz
-man/man8/mkfs.ext4dev.8.gz
man/man8/findfs.8.gz
man/man8/blkid.8.gz
man/man8/logsave.8.gz
@@ -45,14 +43,12 @@ sbin/findfs
sbin/fsck.ext2
sbin/fsck.ext3
sbin/fsck.ext4
-sbin/fsck.ext4dev
sbin/fsck_ext2fs
sbin/logsave
sbin/mke2fs
sbin/mkfs.ext2
sbin/mkfs.ext3
sbin/mkfs.ext4
-sbin/mkfs.ext4dev
sbin/mklost+found
sbin/resize2fs
sbin/tune2fs
@@ -62,10 +58,12 @@ sbin/tune2fs
%%NLS%%share/locale/de/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/eo/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/es/LC_MESSAGES/e2fsprogs.mo
+share/locale/fi/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/fr/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/hu/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/id/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/it/LC_MESSAGES/e2fsprogs.mo
+share/locale/ms/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/nl/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/pl/LC_MESSAGES/e2fsprogs.mo
%%NLS%%share/locale/sr/LC_MESSAGES/e2fsprogs.mo