aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/rudiments/Makefile29
-rw-r--r--devel/rudiments/distinfo6
-rw-r--r--devel/rudiments/files/patch-src-Makefile10
-rw-r--r--devel/rudiments/files/patch-src_intervaltimer.C16
-rw-r--r--devel/rudiments/pkg-plist43
5 files changed, 57 insertions, 47 deletions
diff --git a/devel/rudiments/Makefile b/devel/rudiments/Makefile
index 2eb4ab0493d7..add109599701 100644
--- a/devel/rudiments/Makefile
+++ b/devel/rudiments/Makefile
@@ -6,24 +6,31 @@
#
PORTNAME= rudiments
-PORTVERSION= 0.28.2
-PORTREVISION= 1
+PORTVERSION= 0.29
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rainer.alves@gmail.com
COMMENT= A utility C++ class library for daemons, clients, servers and more
-USE_GNOME= pkgconfig
-USE_GMAKE= yes
-USE_OPENSSL= yes
+USE_GNOME= pkgconfig
+USE_GMAKE= yes
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-ssl-includes=-I${OPENSSLBASE}/include \
- --with-ssl-libs=-L${OPENSSLBASE}/lib --disable-pcre
+CONFIGURE_ARGS= --with-ssl-includes=-I${OPENSSLBASE}/include \
+ --with-ssl-libs=-L${OPENSSLBASE}/lib --disable-pcre
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= PTHREADINCLUDES="${PTHREAD_CFLAGS}" \
- PTHREADLIB="${PTHREAD_LIBS}"
+CONFIGURE_ENV= PTHREADINCLUDES="${PTHREAD_CFLAGS}" \
+ PTHREADLIB="${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+PLIST_SUB+= NOT4X="@comment "
+.else
+PLIST_SUB+= NOT4X=""
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/rudiments/distinfo b/devel/rudiments/distinfo
index e3a591bcc2ad..4629ce20e628 100644
--- a/devel/rudiments/distinfo
+++ b/devel/rudiments/distinfo
@@ -1,3 +1,3 @@
-MD5 (rudiments-0.28.2.tar.gz) = d8d206d35cd05f17b3212d2bcd57411f
-SHA256 (rudiments-0.28.2.tar.gz) = 661b61d10daf6ac3b706ae2d206459bc1cf4bc35e1d30d23c939408dbd5c82ca
-SIZE (rudiments-0.28.2.tar.gz) = 592825
+MD5 (rudiments-0.29.tar.gz) = 5f823e39cb89b6bcd309e3628ba48d3e
+SHA256 (rudiments-0.29.tar.gz) = e3b10dbf5b33747ffa39587796df1fb9c300bcbf2e4095f7291bb4b8f3632b11
+SIZE (rudiments-0.29.tar.gz) = 605753
diff --git a/devel/rudiments/files/patch-src-Makefile b/devel/rudiments/files/patch-src-Makefile
index 7e054edf0f6b..b655b79ee876 100644
--- a/devel/rudiments/files/patch-src-Makefile
+++ b/devel/rudiments/files/patch-src-Makefile
@@ -1,11 +1,11 @@
---- src/Makefile.orig Mon May 9 01:11:53 2005
-+++ src/Makefile Mon May 9 01:12:10 2005
-@@ -334,7 +334,7 @@
+--- src/Makefile.orig Sat Jan 21 22:29:25 2006
++++ src/Makefile Wed May 3 18:04:50 2006
+@@ -330,7 +330,7 @@
rebuild: clean all
librudiments.la: $(SRCS) $(LOBJS)
-- $(LIBTOOL) --mode=link $(CXX) -o $@ $(LOBJS) $(LDFLAGS) $(SOCKETLIBS) $(PTHREADLIB) $(SSLLIBS) $(PCRELIBS) $(NANOSLEEPLIB) $(CLOCKNANOSLEEPLIB) $(SHMOPENLIB) $(CRYPTLIB) $(DLLIB) -rpath $(libdir) -release $(RUDIMENTS_VERSION) -version-info $(SONAME_VERSION_INFO) -no-undefined
-+ $(LIBTOOL) --mode=link $(CXX) -o $@ $(LOBJS) $(LDFLAGS) $(SOCKETLIBS) $(PTHREADLIB) $(SSLLIBS) $(PCRELIBS) $(NANOSLEEPLIB) $(CLOCKNANOSLEEPLIB) $(SHMOPENLIB) $(CRYPTLIB) $(DLLIB) -rpath $(libdir) -version-info $(SONAME_VERSION_INFO) -no-undefined
+- $(LIBTOOL) --mode=link $(CXX) -o $@ $(LOBJS) $(LDFLAGS) $(SOCKETLIBS) $(PTHREADLIB) $(SSLLIBS) $(PCRELIBS) $(NANOSLEEPLIB) $(CLOCKNANOSLEEPLIB) $(SHMOPENLIB) $(CRYPTLIB) $(INETATONLIB) $(DLLIB) -rpath $(libdir) -release $(RUDIMENTS_VERSION) -version-info $(SONAME_VERSION_INFO) -no-undefined
++ $(LIBTOOL) --mode=link $(CXX) -o $@ $(LOBJS) $(LDFLAGS) $(SOCKETLIBS) $(PTHREADLIB) $(SSLLIBS) $(PCRELIBS) $(NANOSLEEPLIB) $(CLOCKNANOSLEEPLIB) $(SHMOPENLIB) $(CRYPTLIB) $(INETATONLIB) $(DLLIB) -rpath $(libdir) -version-info $(SONAME_VERSION_INFO) -no-undefined
install:
$(MKINSTALLDIRS) $(libdir)
diff --git a/devel/rudiments/files/patch-src_intervaltimer.C b/devel/rudiments/files/patch-src_intervaltimer.C
index 5f0db82fe135..75601af1fc4a 100644
--- a/devel/rudiments/files/patch-src_intervaltimer.C
+++ b/devel/rudiments/files/patch-src_intervaltimer.C
@@ -1,11 +1,11 @@
---- src/intervaltimer.C.orig Tue Jan 31 20:22:04 2006
-+++ src/intervaltimer.C Tue Jan 31 20:22:26 2006
-@@ -111,7 +111,7 @@
- // Some systems define tv_usec as something other than long so we need
- // to get a long and then let it auto-cast during assignment below.
+--- src/intervaltimer.C.orig Sat Sep 24 00:31:57 2005
++++ src/intervaltimer.C Wed May 3 18:08:55 2006
+@@ -134,7 +134,7 @@
+ // assignment below.
+ long sec;
long usec;
-- bool retval=getTimeRemaining(&(tv->tv_sec),&usec);
-+ bool retval=getTimeRemaining((long*)(&tv->tv_sec),&usec);
+- bool retval=getTimeRemaining(&sec,&usec);
++ bool retval=getTimeRemaining((long*)(&sec),&usec);
+ tv->tv_sec=sec;
tv->tv_usec=usec;
return retval;
- }
diff --git a/devel/rudiments/pkg-plist b/devel/rudiments/pkg-plist
index 8ef3bec30dc1..8bff8e7de1c5 100644
--- a/devel/rudiments/pkg-plist
+++ b/devel/rudiments/pkg-plist
@@ -6,14 +6,13 @@ include/rudiments/client.h
include/rudiments/clientserverfactory.h
include/rudiments/clientsocket.h
include/rudiments/commandline.h
-include/rudiments/container.h
include/rudiments/crypt.h
include/rudiments/daemonprocess.h
include/rudiments/datetime.h
include/rudiments/device.h
include/rudiments/dictionary.h
include/rudiments/directory.h
-include/rudiments/dtd.h
+%%NOT4X%%include/rudiments/dtd.h
include/rudiments/dynamiclib.h
include/rudiments/environment.h
include/rudiments/error.h
@@ -29,7 +28,7 @@ include/rudiments/intervaltimer.h
include/rudiments/linkedlist.h
include/rudiments/listener.h
include/rudiments/logger.h
-include/rudiments/memorymap.h
+%%NOT4X%%include/rudiments/memorymap.h
include/rudiments/memorypool.h
include/rudiments/modemclient.h
include/rudiments/modemserver.h
@@ -40,6 +39,7 @@ include/rudiments/permissions.h
include/rudiments/private/characterincludes.h
include/rudiments/private/charstring.h
include/rudiments/private/charstringincludes.h
+include/rudiments/private/chat.h
include/rudiments/private/chatincludes.h
include/rudiments/private/client.h
include/rudiments/private/clientincludes.h
@@ -49,14 +49,13 @@ include/rudiments/private/clientsocketincludes.h
include/rudiments/private/commandline.h
include/rudiments/private/commandlineincludes.h
include/rudiments/private/config.h
-include/rudiments/private/container.h
-include/rudiments/private/containerincludes.h
include/rudiments/private/crypt.h
include/rudiments/private/cryptincludes.h
include/rudiments/private/daemonprocess.h
include/rudiments/private/daemonprocessincludes.h
include/rudiments/private/datetime.h
include/rudiments/private/datetimeincludes.h
+include/rudiments/private/device.h
include/rudiments/private/deviceincludes.h
include/rudiments/private/dictionary.h
include/rudiments/private/dictionaryincludes.h
@@ -65,8 +64,8 @@ include/rudiments/private/dictionarynode.h
include/rudiments/private/dictionarynodeinlines.h
include/rudiments/private/directory.h
include/rudiments/private/directoryincludes.h
-include/rudiments/private/dtd.h
-include/rudiments/private/dtdincludes.h
+%%NOT4X%%include/rudiments/private/dtd.h
+%%NOT4X%%include/rudiments/private/dtdincludes.h
include/rudiments/private/dynamiclib.h
include/rudiments/private/dynamiclibincludes.h
include/rudiments/private/environment.h
@@ -82,12 +81,15 @@ include/rudiments/private/groupentry.h
include/rudiments/private/groupentryincludes.h
include/rudiments/private/hostentry.h
include/rudiments/private/hostentryincludes.h
+include/rudiments/private/inetclientsocket.h
include/rudiments/private/inetclientsocketincludes.h
+include/rudiments/private/inetserversocket.h
include/rudiments/private/inetserversocketincludes.h
include/rudiments/private/inetsocketutil.h
include/rudiments/private/inetsocketutilincludes.h
include/rudiments/private/intervaltimer.h
include/rudiments/private/intervaltimerincludes.h
+include/rudiments/private/inttypes.h
include/rudiments/private/linkedlist.h
include/rudiments/private/linkedlistincludes.h
include/rudiments/private/linkedlistinlines.h
@@ -100,11 +102,10 @@ include/rudiments/private/listenerincludes.h
include/rudiments/private/logdestination.h
include/rudiments/private/logger.h
include/rudiments/private/loggerincludes.h
-include/rudiments/private/memorymap.h
-include/rudiments/private/memorymapincludes.h
+%%NOT4X%%include/rudiments/private/memorymap.h
+%%NOT4X%%include/rudiments/private/memorymapincludes.h
include/rudiments/private/memorypool.h
include/rudiments/private/memorypoolincludes.h
-include/rudiments/private/memorypoolnode.h
include/rudiments/private/modemclient.h
include/rudiments/private/modemclientincludes.h
include/rudiments/private/modemserver.h
@@ -120,7 +121,6 @@ include/rudiments/private/permissionsincludes.h
include/rudiments/private/processincludes.h
include/rudiments/private/protocolentry.h
include/rudiments/private/protocolentryincludes.h
-include/rudiments/private/randomnumber.h
include/rudiments/private/randomnumberincludes.h
include/rudiments/private/rawbufferincludes.h
include/rudiments/private/regularexpression.h
@@ -130,9 +130,11 @@ include/rudiments/private/rpcentryincludes.h
include/rudiments/private/rudimentsinlines.h
include/rudiments/private/semaphoreset.h
include/rudiments/private/semaphoresetincludes.h
+include/rudiments/private/serialport.h
include/rudiments/private/serialportincludes.h
include/rudiments/private/serialportprofile.h
include/rudiments/private/serialportprofileincludes.h
+include/rudiments/private/server.h
include/rudiments/private/serverincludes.h
include/rudiments/private/serversocket.h
include/rudiments/private/serversocketincludes.h
@@ -152,6 +154,7 @@ include/rudiments/private/stringbuffer.h
include/rudiments/private/stringbufferincludes.h
include/rudiments/private/syslogdestination.h
include/rudiments/private/timezonefile.h
+include/rudiments/private/unixclientsocket.h
include/rudiments/private/unixclientsocketincludes.h
include/rudiments/private/unixserversocket.h
include/rudiments/private/unixserversocketincludes.h
@@ -159,12 +162,12 @@ include/rudiments/private/unixsocketutil.h
include/rudiments/private/unixsocketutilincludes.h
include/rudiments/private/variablebuffer.h
include/rudiments/private/variablebufferincludes.h
-include/rudiments/private/xmldom.h
-include/rudiments/private/xmldomincludes.h
-include/rudiments/private/xmldomnode.h
-include/rudiments/private/xmldomnodeincludes.h
-include/rudiments/private/xmlsax.h
-include/rudiments/private/xmlsaxincludes.h
+%%NOT4X%%include/rudiments/private/xmldom.h
+%%NOT4X%%include/rudiments/private/xmldomincludes.h
+%%NOT4X%%include/rudiments/private/xmldomnode.h
+%%NOT4X%%include/rudiments/private/xmldomnodeincludes.h
+%%NOT4X%%include/rudiments/private/xmlsax.h
+%%NOT4X%%include/rudiments/private/xmlsaxincludes.h
include/rudiments/process.h
include/rudiments/protocolentry.h
include/rudiments/randomnumber.h
@@ -188,9 +191,9 @@ include/rudiments/unixclientsocket.h
include/rudiments/unixserversocket.h
include/rudiments/unixsocketutil.h
include/rudiments/variablebuffer.h
-include/rudiments/xmldom.h
-include/rudiments/xmldomnode.h
-include/rudiments/xmlsax.h
+%%NOT4X%%include/rudiments/xmldom.h
+%%NOT4X%%include/rudiments/xmldomnode.h
+%%NOT4X%%include/rudiments/xmlsax.h
lib/librudiments.a
lib/librudiments.la
lib/librudiments.so