aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--security/hs-crypto-api/Makefile21
-rw-r--r--security/hs-crypto-api/distinfo2
-rw-r--r--security/hs-crypto-api/pkg-descr9
4 files changed, 33 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 6846f50dfe9a..a6f8522fc00e 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -55,6 +55,7 @@ cpphs_port= devel/hs-cpphs # executable
cprng-aes_port= security/hs-cprng-aes
criterion_port= benchmarks/hs-criterion
Crypto_port= security/hs-Crypto
+crypto-api_port= security/hs-crypto-api
csv_port= textproc/hs-csv
curl_port= ftp/hs-curl
darcs_port= devel/hs-darcs # executable
diff --git a/security/hs-crypto-api/Makefile b/security/hs-crypto-api/Makefile
new file mode 100644
index 000000000000..6ce68a1ab270
--- /dev/null
+++ b/security/hs-crypto-api/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-crypto-api
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= crypto-api
+PORTVERSION= 0.8
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A generic interface for cryptographic operations
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= cereal>=0.2 entropy largeword>=1.0.0 tagged>=0.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-crypto-api/distinfo b/security/hs-crypto-api/distinfo
new file mode 100644
index 000000000000..573ec6111855
--- /dev/null
+++ b/security/hs-crypto-api/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/crypto-api-0.8.tar.gz) = 480cc686eb1c2f9668b67c38f255417012fd66a5b61315f24664889d965393bb
+SIZE (cabal/crypto-api-0.8.tar.gz) = 42443
diff --git a/security/hs-crypto-api/pkg-descr b/security/hs-crypto-api/pkg-descr
new file mode 100644
index 000000000000..34889f576186
--- /dev/null
+++ b/security/hs-crypto-api/pkg-descr
@@ -0,0 +1,9 @@
+A generic interface for cryptographic operations, platform independent quality
+RNG, property tests and known-answer tests (KATs) for common algorithms, and a
+basic benchmark infrastructure. Maintainers of hash and cipher implementations
+are encouraged to add instances for the classes defined in Crypto.Classes.
+Crypto users are similarly encouraged to use the interfaces defined in the
+Classes module. Any concepts or functions of general use to more than one
+cryptographic algorithm (ex: padding) is within scope of this package.
+
+WWW: http://trac.haskell.org/crypto-api/wiki