aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/staroffice52/Makefile9
-rw-r--r--editors/staroffice60/Makefile9
-rw-r--r--editors/staroffice70/Makefile9
-rw-r--r--german/staroffice70/Makefile9
4 files changed, 20 insertions, 16 deletions
diff --git a/editors/staroffice52/Makefile b/editors/staroffice52/Makefile
index d510844e3a06..4085d13df594 100644
--- a/editors/staroffice52/Makefile
+++ b/editors/staroffice52/Makefile
@@ -56,16 +56,17 @@ pre-fetch:
.if !exists(${CD_MOUNTPT}/linux/office52/setup)
@${ECHO}
@${ECHO} Please mount the Sun StarOffice 5.2 CDROM
- @${ECHO} onto /cdrom and run make again.
+ @${ECHO} onto ${CD_MOUNTPT} and run make again.
@${ECHO}
@${FALSE}
.endif
.endif
.if defined(WITH_CDROM)
-do-extract:
- @${MKDIR} ${WRKSRC}/office52
- @cd ${WRKSRC}/office52 && ${LN} -s ${CD_MOUNTPT}/linux/office52/* .
+do-extract: do-extract-cdrom
+do-extract-cdrom:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && ${LN} -s ${CD_MOUNTPT}/linux/office52/* .
.endif
do-extract:
diff --git a/editors/staroffice60/Makefile b/editors/staroffice60/Makefile
index d510844e3a06..4085d13df594 100644
--- a/editors/staroffice60/Makefile
+++ b/editors/staroffice60/Makefile
@@ -56,16 +56,17 @@ pre-fetch:
.if !exists(${CD_MOUNTPT}/linux/office52/setup)
@${ECHO}
@${ECHO} Please mount the Sun StarOffice 5.2 CDROM
- @${ECHO} onto /cdrom and run make again.
+ @${ECHO} onto ${CD_MOUNTPT} and run make again.
@${ECHO}
@${FALSE}
.endif
.endif
.if defined(WITH_CDROM)
-do-extract:
- @${MKDIR} ${WRKSRC}/office52
- @cd ${WRKSRC}/office52 && ${LN} -s ${CD_MOUNTPT}/linux/office52/* .
+do-extract: do-extract-cdrom
+do-extract-cdrom:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && ${LN} -s ${CD_MOUNTPT}/linux/office52/* .
.endif
do-extract:
diff --git a/editors/staroffice70/Makefile b/editors/staroffice70/Makefile
index d510844e3a06..4085d13df594 100644
--- a/editors/staroffice70/Makefile
+++ b/editors/staroffice70/Makefile
@@ -56,16 +56,17 @@ pre-fetch:
.if !exists(${CD_MOUNTPT}/linux/office52/setup)
@${ECHO}
@${ECHO} Please mount the Sun StarOffice 5.2 CDROM
- @${ECHO} onto /cdrom and run make again.
+ @${ECHO} onto ${CD_MOUNTPT} and run make again.
@${ECHO}
@${FALSE}
.endif
.endif
.if defined(WITH_CDROM)
-do-extract:
- @${MKDIR} ${WRKSRC}/office52
- @cd ${WRKSRC}/office52 && ${LN} -s ${CD_MOUNTPT}/linux/office52/* .
+do-extract: do-extract-cdrom
+do-extract-cdrom:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && ${LN} -s ${CD_MOUNTPT}/linux/office52/* .
.endif
do-extract:
diff --git a/german/staroffice70/Makefile b/german/staroffice70/Makefile
index d510844e3a06..4085d13df594 100644
--- a/german/staroffice70/Makefile
+++ b/german/staroffice70/Makefile
@@ -56,16 +56,17 @@ pre-fetch:
.if !exists(${CD_MOUNTPT}/linux/office52/setup)
@${ECHO}
@${ECHO} Please mount the Sun StarOffice 5.2 CDROM
- @${ECHO} onto /cdrom and run make again.
+ @${ECHO} onto ${CD_MOUNTPT} and run make again.
@${ECHO}
@${FALSE}
.endif
.endif
.if defined(WITH_CDROM)
-do-extract:
- @${MKDIR} ${WRKSRC}/office52
- @cd ${WRKSRC}/office52 && ${LN} -s ${CD_MOUNTPT}/linux/office52/* .
+do-extract: do-extract-cdrom
+do-extract-cdrom:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && ${LN} -s ${CD_MOUNTPT}/linux/office52/* .
.endif
do-extract: