aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ftp/profxp/Makefile14
-rw-r--r--games/3dc/Makefile3
-rw-r--r--games/p5-Games-Bingo/Makefile8
-rw-r--r--games/pengpong/Makefile12
-rw-r--r--games/ttraffic/Makefile15
-rw-r--r--games/zangband/Makefile15
-rw-r--r--graphics/cadubi/Makefile4
-rw-r--r--graphics/gtkgraph/Makefile8
-rw-r--r--graphics/p5-GD-Graph3d/Makefile11
-rw-r--r--graphics/p5-Image-IPTCInfo/Makefile11
-rw-r--r--mail/p5-Mail-Audit/Makefile9
-rw-r--r--mail/p5-Mail-DomainKeys/Makefile8
-rw-r--r--mail/p5-Mail-Sender/Makefile2
-rw-r--r--mail/premail/Makefile13
14 files changed, 46 insertions, 87 deletions
diff --git a/ftp/profxp/Makefile b/ftp/profxp/Makefile
index 529d077f4235..9206db9334e0 100644
--- a/ftp/profxp/Makefile
+++ b/ftp/profxp/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: profxp
-# Date created: Jun 1, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= profxp
PORTVERSION= 3p2
@@ -24,9 +19,12 @@ RUN_DEPENDS= p5-SOCKS>=0:${PORTSDIR}/net/p5-Socks \
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
+USES= shebangfix
+SHEBANG_FILES= profxpv3.pl
+perl_OLD_CMD= /home/tom/ActivePerl-5.6/bin/perl
-post-patch:
- @${PERL} -pi -e "s,^#!.*,#!${PERL},g" ${WRKSRC}/profxpv3.pl
+post-patch1:
+ @${REINPLACE_CMD} -i '' '1s|^\#.*|#!${PERL}|' ${WRKSRC}/profxpv3.pl
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/profxpv3.pl ${PREFIX}/bin/profxp
diff --git a/games/3dc/Makefile b/games/3dc/Makefile
index f9d0790949ef..095e16faf548 100644
--- a/games/3dc/Makefile
+++ b/games/3dc/Makefile
@@ -22,7 +22,8 @@ WRKSRC= ${WRKDIR}/3Dc/src
post-patch:
.for file in init.c main.c piece.c stack.c xif.c
- @${PERL} -pi -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -i '' -e 's|malloc.h|stdlib.h|' \
+ ${WRKSRC}/${file}
.endfor
do-install:
diff --git a/games/p5-Games-Bingo/Makefile b/games/p5-Games-Bingo/Makefile
index 165a47e69968..8d4347c33413 100644
--- a/games/p5-Games-Bingo/Makefile
+++ b/games/p5-Games-Bingo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Games-Bingo
-# Date created: 14. August 2003
-# Whom: Lars Thegler <lars@thegler.dk>
-#
+# Created by: Lars Thegler <lars@thegler.dk>
# $FreeBSD$
-#
PORTNAME= Games-Bingo
PORTVERSION= 0.15
@@ -26,6 +22,6 @@ MAN3= Games::Bingo.3 \
.include <bsd.port.pre.mk>
post-patch:
- @${PERL} -pi -e '$$_="" if m|Test::|' ${WRKSRC}/Build.PL
+ @${REINPLACE_CMD} -i '' '/Test::/d' ${WRKSRC}/Build.PL
.include <bsd.port.post.mk>
diff --git a/games/pengpong/Makefile b/games/pengpong/Makefile
index 2844fb42db5a..5808c5bf042d 100644
--- a/games/pengpong/Makefile
+++ b/games/pengpong/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pengpong
-# Date created: Fri Aug 24 18:21:25 EDT 2001
-# Whom: Patrick Li <pat@databits.net>
-#
+# Created by: Patrick Li <pat@databits.net>
# $FreeBSD$
-#
PORTNAME= pengpong
PORTVERSION= 0.3
@@ -22,11 +18,9 @@ DATAFILES= 24P_Copperplate_Blue.png ball.tga logo.jpg \
paddle.tga red.png
pre-patch:
- @${PERL} -pi.orig -e \
- 's|/usr/local/share/games/pengpong|${DATADIR}|' \
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local/share/games/pengpong|${DATADIR}|' \
${WRKSRC}/files.h
- @${PERL} -pi.orig -e 's|0.2|${PORTVERSION}|' \
- ${WRKSRC}/pengpong.cpp
+ @${REINPLACE_CMD} -i '' -e 's|V 0.2|V ${PORTVERSION}|' ${WRKSRC}/pengpong.cpp
do-install:
.ifndef(NOPORTDOCS)
diff --git a/games/ttraffic/Makefile b/games/ttraffic/Makefile
index a73656558e67..dcb9b0b93253 100644
--- a/games/ttraffic/Makefile
+++ b/games/ttraffic/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: games/ttraffic
-# Date created: 14 November 2001
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ttraffic
PORTVERSION= 0.8
@@ -20,11 +16,16 @@ RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
NO_BUILD= yes
USE_PERL5_BUILD=yes
+USES= shebangfix
+SHEBANG_FILES= ttraffic.tcl
+SHEBANG_LANG= wish
+wish_OLD_CMD= /usr/bin/wish
+wish_CMD= ${LOCALBASE}/bin/wish8.4
post-patch:
- ${PERL} -pi -e 's|/usr/local/share/ttraffic/|${DATADIR}/|g;' \
- -e 's|#!/usr/bin/wish|#!${LOCALBASE}/bin/wish8.4|g' \
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local/share/ttraffic/|${DATADIR}/|' \
${WRKSRC}/ttraffic.tcl
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/ttraffic.tcl ${PREFIX}/bin/ttraffic
${MKDIR} ${DATADIR}
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index 42b703292f04..9192507e030e 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zangband
-# Date created: 29 May 2000
-# Whom: Makoto YAMAKURA <makoto@pinpott.spnet.ne.jp>
-#
+# Created by: Makoto YAMAKURA <makoto@pinpott.spnet.ne.jp>
# $FreeBSD$
-#
PORTNAME= zangband
PORTVERSION= 2.6.2
@@ -38,10 +34,11 @@ ANGBANDLIB?= lib/${PORTNAME}
ANGBANDBIN?= bin/${PORTNAME}
pre-patch:
- @${PERL} -pi.orig -e 's|^aclocal|${ACLOCAL}|; \
- s|^autoheader|${AUTOHEADER}|; \
- s|^automake|${AUTOMAKE}|; s|^autoconf|${AUTOCONF}|' \
- ${WRKSRC}/bootstrap
+ @${REINPLACE_CMD} -i '' -e 's|^aclocal|${ACLOCAL}|' \
+ -e 's|^autoheader|${AUTOHEADER}|' \
+ -e 's|^automake|${AUTOMAKE}|' \
+ -e 's|^autoconf|${AUTOCONF}|' \
+ ${WRKSRC}/bootstrap
pre-configure:
(cd ${WRKSRC} ; ${SH} bootstrap)
diff --git a/graphics/cadubi/Makefile b/graphics/cadubi/Makefile
index 3e8552b4cc42..e6d79259f23c 100644
--- a/graphics/cadubi/Makefile
+++ b/graphics/cadubi/Makefile
@@ -25,8 +25,8 @@ PORTDOCS= *
.include <bsd.port.options.mk>
do-configure:
- @${PERL} -pi -e \
- 's|Bin/help|Bin/../share/cadubi/help|g' ${WRKSRC}/cadubi
+ @${REINPLACE_CMD} -i '' -e 's|Bin/help|Bin/../share/cadubi/help|' \
+ ${WRKSRC}/cadubi
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/graphics/gtkgraph/Makefile b/graphics/gtkgraph/Makefile
index 6e2f73973e84..48b046ac9892 100644
--- a/graphics/gtkgraph/Makefile
+++ b/graphics/gtkgraph/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gtkgraph
-# Date created: 12 October 1999
-# Whom: Chris D. Faulhaber <jedgar@fxp.org>
-#
+# Created by: Chris D. Faulhaber <jedgar@fxp.org>
# $FreeBSD$
-#
PORTNAME= gtkgraph
PORTVERSION= 0.6.1
@@ -24,7 +20,7 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; s|-O2|${CFLAGS}| ; \
+ @${REINPLACE_CMD} -i '' -e 's|-O2|${CFLAGS}| ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/graphics/p5-GD-Graph3d/Makefile b/graphics/p5-GD-Graph3d/Makefile
index 76b5a4f6ba80..c201ea05c387 100644
--- a/graphics/p5-GD-Graph3d/Makefile
+++ b/graphics/p5-GD-Graph3d/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-GD-Graph
-# Date created: 10 April 2000
-# Whom: Dmitry Sivachenko <dima@Chg.RU>
-#
+# Created by: Dmitry Sivachenko <dima@Chg.RU>
# $FreeBSD$
-#
PORTNAME= GD-Graph3d
PORTVERSION= 0.63
@@ -19,11 +15,8 @@ BUILD_DEPENDS= p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+USE_DOS2UNIX= lib/GD/Graph3d.pm # pod2man doesn't work without this
MAN3= GD::Graph3d.3
-post-patch:
-# pod2man doesn't work without this
- ${PERL} -pi -e 's/\r//' ${WRKSRC}/lib/GD/Graph3d.pm
-
.include <bsd.port.mk>
diff --git a/graphics/p5-Image-IPTCInfo/Makefile b/graphics/p5-Image-IPTCInfo/Makefile
index 150c3c96a69a..56baf249e8ba 100644
--- a/graphics/p5-Image-IPTCInfo/Makefile
+++ b/graphics/p5-Image-IPTCInfo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Image-IPTCInfo
-# Date created: 2006-08-11
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Image-IPTCInfo
PORTVERSION= 1.95
@@ -15,12 +11,13 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for extracting IPTC image meta-data
PERL_CONFIGURE= yes
+USES= shebangfix
+SHEBANG_FILES= demo.pl
MAN3= Image::IPTCInfo.3
post-patch:
- ${RM} -f ${WRKSRC}/._*
- ${PERL} -pi -e 's,/usr/bin/perl,${PERL},' ${WRKSRC}/demo.pl
+ @${RM} -f ${WRKSRC}/._*
.if !defined(NOPORTDOCS)
post-install:
diff --git a/mail/p5-Mail-Audit/Makefile b/mail/p5-Mail-Audit/Makefile
index 163975ade478..fc233efec73b 100644
--- a/mail/p5-Mail-Audit/Makefile
+++ b/mail/p5-Mail-Audit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Mail-Audit
-# Date created: Wed Jan 3 12:31:10 2001
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= Mail-Audit
PORTVERSION= 2.2.27
@@ -37,7 +33,8 @@ PORTDOCS= Changes FAQ README
PORTEXAMPLES= popread proc2ma
post-patch:
- @${PERL} -pi -e 's,/var/spool/mail,/var/mail,g' ${WRKSRC}/lib/Mail/Audit.pm
+ @${REINPLACE_CMD} -i '' -e 's|/var/spool/mail|/var/mail|g' \
+ ${WRKSRC}/lib/Mail/Audit.pm
post-install:
.if !defined(NOPORTDOCS)
diff --git a/mail/p5-Mail-DomainKeys/Makefile b/mail/p5-Mail-DomainKeys/Makefile
index 10fca248f47b..63a6f8be9c8e 100644
--- a/mail/p5-Mail-DomainKeys/Makefile
+++ b/mail/p5-Mail-DomainKeys/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Mail-DomainKeys
-# Date created: 23 May 2005
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Mail-DomainKeys
PORTVERSION= 1.0
@@ -25,6 +21,6 @@ PERL_CONFIGURE= yes
MAN3= Mail::DomainKeys.3
post-patch:
- @${PERL} -pi -e '$$_="" if $$.>=6 && $$.<=38' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -i '' '6,38d' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/mail/p5-Mail-Sender/Makefile b/mail/p5-Mail-Sender/Makefile
index 104773e8203a..65aedbdea98f 100644
--- a/mail/p5-Mail-Sender/Makefile
+++ b/mail/p5-Mail-Sender/Makefile
@@ -16,7 +16,7 @@ MAN3= Mail::Sender.3
post-patch:
.if defined(BATCH)
- @${PERL} -pi -e 's/res = <STDIN>;/res = "N";/' ${WRKSRC}/Config.PL
+ @${REINPLACE_CMD} -e 's/res = <STDIN>;/res = "N";/' ${WRKSRC}/Config.PL
.endif
.include <bsd.port.mk>
diff --git a/mail/premail/Makefile b/mail/premail/Makefile
index e6a93453fe81..878375faeb2e 100644
--- a/mail/premail/Makefile
+++ b/mail/premail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: premail
-# Date created: 31 Jan 1997
-# Whom: ache
-#
+# Created by: ache
# $FreeBSD$
-#
PORTNAME= premail
PORTVERSION= 0.46
@@ -20,11 +16,8 @@ BUILD_DEPENDS+= pgp:${PORTSDIR}/security/pgp
WRKSRC= ${WRKDIR}/premail
USE_PERL5= yes
NO_BUILD= yes
-
-post-patch:
- cd ${WRKSRC}; \
- ${CP} premail premail.old; \
- ${SED} 's=#!/usr/local/bin/perl=#!${PERL} -w=' < premail.old > premail
+USES= shebangfix
+SHEBANG_FILES= premail
do-install:
cd ${WRKSRC} && ${INSTALL_SCRIPT} premail ${PREFIX}/bin